Connect RD Connection Broker to SQL


  • Hello I'm not being able to install RD Connection Broker with High Availability.

    The RDS deployment consists on two servers running win2012

    server1 - RDWA and RDG

    server2 - RDSH and RDCB

    The SQL server 2012 that I'm using is installed on server2 itself and had to be installed after the RDS otherwise the SQL installation failed and had to be done using the RD-install. It's working fine , I've applications that run on it.

    As when configuring RDCB HA "both" RDCB hosts access directly to the SQL DB to create a new database, their accounts need to be authenticated as a SQL login with dbcreator role.

    1 step: I checked a straight forward installation_

    Installing and Configuring RD Connection Broker High Availability in Windows Server 2012


    2 step: I checked an installation where my problem happened.

    I checked RD Connection Broker HA – SQL Permissions
    Added the host to a domain group and added the group as an SQL login, SQL authentication failed.

    4 step: Google for how to create SQL login for a computer account and  I added it by executing:

    “CREATE LOGIN [MyDomain\MyComputer$] FROM WINDOWS”

    Also tried to use Add-ADcomputerServiceAccount without success.

    3 step: I ended here

    Taking a closer look at RD Connection Broker High Availability in Windows Server 2012

    Where I verified that none of the following explanations were correct:

    • The SQL Server Native client is not installed
    • A firewall is blocking SQL Access from the RD Connection Broker (port 1433)
    • The incorrect SQL Server Native Client version is specified
    • An incorrect SQL Server name is specified

    I tried several variations of the string to use but this is the one I think it's correct:

    DRIVER=SQL Server Native Client 11.0;SERVER=WIN2012-1;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;Database=RDCB

    The error registered on SQL is:

    Login failed for user 'RDS\WIN2012-1$'. Reason: Could not find a login matching the name provided. [CLIENT: <local machine>]"

    I tried to connect via ODBC with an existing username an it succeeded.

    The problem seems to be with the computer account not existing as an SQL login...the thing is that it exists.

    I need to set this up in order to be able to change the RDCB FQDN to a public FQDN.

    How were you guys able to overcome this? Did you faced this at all?



    Thursday, June 27, 2013 7:23 PM

All replies

  • I'm having the exact same problem. Any luck solving it yet?
    Thursday, September 19, 2013 1:25 PM
  • I think it absolutely does not work --- Remote Desktop Connection Broker High Availability


    DRIVER=SQL Server Native Client 11.0;SERVER=WIN2012-1;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;Database=RDCB, after this screen

    Im create sql database. Database created, starting to work in single-user mode...   DAMN It.

    Tuesday, November 12, 2013 1:00 PM
  • Hi,

    Have a look at the following Article:

    Please see the following article on deploying SQL for RDS Connection Broker HA.

    This take you through the step by step configuration of SQL

    This should assist you with the deployment.

    Best regards,

    Help keep the forums tidy, if this has helped please mark it as an answer

    • Proposed as answer by Ryan Mangan Saturday, January 04, 2014 11:25 PM
    • Edited by Ryan Mangan Sunday, January 05, 2014 12:08 AM
    Saturday, January 04, 2014 11:25 PM
  • I don't see you mentioning anything about the role you assign to the SQL login. Your login needs DBCREATOR role to be able to work.

    You need to reboot the server(s) to make them know they are now a member of the domain group.

    You might want to check the steps I describe in This is the step-by-step guide for a single server installation and you might be able to identify the step you missed?



    Saturday, January 04, 2014 11:33 PM
  • I to have followed all the correct steps via your post (part1), my member server IS a member of the RDS Connection Broker AD group that I created, per your post. I logged into sql mgmt studio and added it first as the dbcreator that you specified ... didn't work.  Added it as a sysadmin... didn't work.  Rebooted more than once... same result.  DB creation failed. 


    Friday, November 07, 2014 8:18 PM
  • Hi Stephen,

    Not sure what could be wrong in your setup then.

    Database path maybe? Should be the path on the SQL server, not on the server you are configuring the DB connection.

    SQL should not be shared with the broker role, choose a different server for your SQL instance.

    Other than that, the steps in my article work every time I deploy my lab setup...


    There's a new blog in town:

    Saturday, November 08, 2014 11:05 AM
  • today i have same problem with RDCB and 2012 SQL, the solution is to store the rdcb Database not to system drive. Then you are able to create the HA Connection Broker configuration.
    Friday, February 20, 2015 4:30 PM
  • Guys,

    I suffered with a very similar problem when setting up an RDS 2012 environment using SQL Server 2014 sitting on a server core VM, and two connection brokers sitting on server core OS as well. 

    My SQL logs were filling with with login failed for the connection brokers computer account even though I had configured the SQL permissions correctly. 

    In the end it was Arjan's post above that got me fixed, rebooting the connection broker VMs. Really annoying, as I let AD propagate over night, just in case that was the issue. After simply rebooting the connection brokers, this worked. For anyone who needs it, my SQL databases are stored on a separate D: drive and I used the string below:

    DRIVER=SQL Server Native Client 11.0;SERVER=<SQL Server Name>;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;DATABASE=<DB Name>.

    Hope this helps someone else.

    Tuesday, March 10, 2015 9:39 AM