locked
Sharepoint 2016- OWA Excel issue RRS feed

  • Question

  • Hi all

    I have configured OWA server with sharepoint 2016. Now I am able to access all other document except excel. I end up with loading screen whenever I try to access Excel. I have also configured Excel SOAP api in SharePoint2016 server. Please give me any suggestion. 


    • Edited by Navasshereef1 Wednesday, July 15, 2020 7:34 AM Forgot to attach
    Wednesday, July 15, 2020 7:32 AM

Answers

  • Hi Julie,

    Thanks for suggestion and your time. I have found the issue.

    WopiZone is set to internal-http and office web app farm internal URL is set to https. I ran below command to set the internal URL to http. Mow, works good.

    Set-OfficeWebAppsFarm -InternalUrl "http:OfficeServer"

    • Marked as answer by Navasshereef1 Monday, July 20, 2020 8:11 AM
    Monday, July 20, 2020 8:11 AM

All replies

  • Hi Navasshereef1,

    Whether all Excel files fail to open in Office Online?

    Please run below PowerShell to check the Excel SPWOPI supports ‘’View’’ or “Edit” action.

    Get-SPWOPIBinding –Application "Excel"


    If Excel application doesn’t support correct action, please run following PowerShell to configure default action for excel documents:

    Get-SPWOPIBinding -Action "View" -Application "Excel"| Set-SPWOPIBinding -DefaultAction:$true

    If everything is ok however the issue still exists, I suggest you rebuild the OOS bindings using following PowerShell:

    Remove-SPWOPIBinding –All:$true
    
    New-SPWOPIBinding –ServerName "Server.corp.Contoso.com" -AllowHttp

    This “SharePoint 2013 - Setup, Upgrade, Administration and Operations” Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Best regards,

    Julie


    "SharePoint" forums will be migrating to a new home on Microsoft Q&A !
    We invite you to post new questions in the "SharePoint" forums' new home on Microsoft Q&A !

    Thursday, July 16, 2020 6:17 AM
  • Hi Julie,

    Thanks for the reply. I have tried the Get command and got expected result. I tried to open Excel in different SharePoint sites and different document library. But it keeps on loading. Any other suggestions?

    Screenshot of the resut of powershell command.

    

    Thursday, July 16, 2020 8:43 AM
  • SharePoint 2016 is not compatible with Office Web Apps. You need to be using Office Online Server which is the newer version of Office Web Apps.

    Trevor Seward

    Office Apps and Services MVP



    Author, Deploying SharePoint 2019

    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, July 16, 2020 7:03 PM
  • Hi Navasshereef1,

    Have you tried to rebuild the OOS bindings mentioned above?

    Please try it and let me know the result.

    This “SharePoint 2013 - Setup, Upgrade, Administration and Operations” Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Best regards,

    Julie


    "SharePoint" forums will be migrating to a new home on Microsoft Q&A !
    We invite you to post new questions in the "SharePoint" forums' new home on Microsoft Q&A !

    Friday, July 17, 2020 9:47 AM
  • Hi Julie,

    Thanks for suggestion and your time. I have found the issue.

    WopiZone is set to internal-http and office web app farm internal URL is set to https. I ran below command to set the internal URL to http. Mow, works good.

    Set-OfficeWebAppsFarm -InternalUrl "http:OfficeServer"

    • Marked as answer by Navasshereef1 Monday, July 20, 2020 8:11 AM
    Monday, July 20, 2020 8:11 AM
  • Hi Navasshereef1,

    Congratulations on solving this issue and thanks for sharing your solution.

    It will do great help to those who meet the similar question in this forum.

    Thanks again for your contribution.

    Best regards,

    Julie


    "SharePoint" forums will be migrating to a new home on Microsoft Q&A !
    We invite you to post new questions in the "SharePoint" forums' new home on Microsoft Q&A !

    Monday, July 20, 2020 8:14 AM