none
MAP - Inventory and Assessment Wizard failed RRS feed

  • Question

  • HI,

    sorry I am new to this. I tried to search this forum but I couldn't found the problem I have. I just installed the new MAP 4.0.2925.0.
    I started the inventory and assessment wizard. It looks like it starts...entering all the credentials and either an IP address or AD identification.
    But then when the wizard start collecting the information it stops with this pop-up. Saying : "An error occurred while collecting inventory data. You will need to close and rerun the wizard."
    I did a couple of times..even rebooted the machine where it is installed. I checked Remote registry service is running on the remote compouter I want to check....firewall is off.
    I am running this tool on a windows Xp workstation.

    That is all I have ;-) any hint would be great

    cheers

    Bernd
    Monday, October 19, 2009 10:49 AM

All replies

  • Bernd,

     

    We sometimes see this error when the user ID used in the inventory collection does not have proper access to the SQL database that was installed by MAPS.  If you make sure that the ID your using on the Active Directory credential page of the wizard also has access to your database you should be able to continue successfully.  You can either add your AD user to the local administrators on your box, or use an ID that has both local admin rights and AD rights.

     

    Let me know if this helps.

     

    Thanks,

    Eric

    Monday, October 19, 2009 5:29 PM
  • Hi Eric,

    thanks for the reply. I tried it with a couple of AD accounts. Both are local administrator and domain administrators. But still the same error when I run the wizard. I saw that when the error appears that I see one more error message : Task processor failed. But guess this indicates no access to the database. I tried now all possible combinations of user and domain I could think off.

    Any other idea ?

    thanks a lot

    Bernd

    Tuesday, October 20, 2009 7:05 AM
  • Huh…this is troublesome isn’t it?

     

    How about, with a domain admin, running setup and having it remove your installed databases and applications and then rerun setup and have it recreate the SQL instance (which should happen automatically).  Then launch with same user and run inventory using same user.  This should definitely get rid of any credential issues you might have...

     

     

    If your still having issues please send you logs to mapfdbk@microsoft.com.

     

    Thanks,

    Eric

    Tuesday, October 20, 2009 9:38 PM
  • Ok the reinstall doesn't helped :-/. But worth to try :-). All was done with a domain admin.

    Ok so next step...what kind of logs do you need ? Which can I send to you ?

    cheers

    Bernd

    Friday, October 23, 2009 12:52 PM
  • Sorry I should have said in that last post...

    You can get the logs from C:\Program Files\Microsoft Assessment and Planning Solution Accelerator\bin\log (or equivalent folder).

     

    please send them to mapfdbk@microsoft.com

    -Eric

    Friday, October 23, 2009 3:50 PM
  •  

    Logs received.  I am pushing this issue for investigation from the development team now…

     

    I’ll let you know their findings.

     

    Thanks,

    Eric

    Monday, October 26, 2009 11:01 PM
  •  

    After reviewing your logs, the developers believe that your issue is related to: http://support.microsoft.com/kb/300956

     

    With the relevant excerpt being:

    To rebuild all Performance counters including extensible and third-party counters in Windows Server 2003, type the following commands at a command prompt. Press ENTER after each command.

    cd\windows\system32

    lodctr /R

    Note /R is uppercase. You must have administrative rights on the computer to successfully perform this command.

     

    Please let me know how/if this works for you.

     

    Thanks,

    Eric

    Tuesday, October 27, 2009 1:03 AM
  • Sorry was off a few days...So you say I have to do this on all my server systems ?
    Or just where the tool is running ? Because the tool is running on Windows XP.

    cheers

    Bernd

    Monday, November 9, 2009 5:05 AM
  • Just need to do it on the machine that is running the tool.  Please refer to the instructions on that KB article to fix your specific machine.

    Thanks,
    Eric
    Monday, November 9, 2009 5:04 PM