locked
How do I specify the IP address used by outbound SMTP connections? RRS feed

  • Question

  • I have an Exchange 2010 server called MAIL1 that has two IP addresses (10.0.0.10 and 10.0.0.20).  When the server sends email to external systems it seems to use both addresses.  Is there a way to specify that it should only use 10.0.0.10?
    Wednesday, March 16, 2011 1:00 PM

Answers

  • On the set-sendconnector cmdlet. Use the "-SourceIPAddrerss" parameter.
    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, March 18, 2011 12:44 AM

All replies

  • Hi,

    By default, a Receive connector is configured to use all available network adapters and TCP port 25. If a transport server has multiple network adapters, you can change Receive connector to be bound to a particular network adapter, or to accept connections through an alternative port.

    Please see below KB in detail for more help.

    See section Local Network Settings

    http://technet.microsoft.com/en-us/library/aa996395.aspx

     

     


    Anil
    Wednesday, March 16, 2011 5:52 PM
  • Exchange 2007 could only manage this on an edge server. Exchange 2010 may still have the same limitation.
    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, March 17, 2011 1:53 AM
  • Thanks Anil, I've read that article already however it specifically talks about the receive connector. I'm not trying to modify the receive connector. I'm looking to bind the outbound SMTP transmission to a particular IP.
    Thursday, March 17, 2011 1:22 PM
  • Thanks Rich, I don't mind doing this on the edge server if necessary.  I've tried searching but only some up with how to modify the receive connectors.  Do you know where I would find the settings on a 2007 server?
    Thursday, March 17, 2011 1:25 PM
  • There does not appear to be a way to do this in Send Connector EMC properties.

    Thought there might be options in the EMS:

    Get-SendConnector | fl

    AddressSpaces
    AuthenticationCredential
    Comment
    ConnectedDomains
    ConnectionInactivityTimeOut
    DNSRoutingEnabled
    DomainSecureEnabled
    Enabled
    ForceHELO
    Fqdn
    HomeMTA
    HomeMtaServerId
    Identity
    IgnoreSTARTTLS
    IsScopedConnector
    IsSmtpConnector
    LinkedReceiveConnector
    MaxMessageSize
    Name
    Port
    ProtocolLoggingLevel
    RequireTLS
    SmartHostAuthMechanism
    SmartHosts
    SmartHostsString
    SourceIPAddress
    SourceRoutingGroup
    SourceTransportServers
    UseExternalDNSServersEnabled

    Googling around, I saw something about changing the binding order on the NICs so Exchange would use whatever IP is highest in the binding order but I have no idea whether that would work reliably (or at all).

     

    Note: this was on a HT server. Not sure about ET because we do not use one (hosted mail hygiene here).
    Thursday, March 17, 2011 2:26 PM
  • On the set-sendconnector cmdlet. Use the "-SourceIPAddrerss" parameter.
    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, March 18, 2011 12:44 AM
  • It's the "SourceIPAddress" value. You can only set that on the edge server role.
    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, March 18, 2011 12:46 AM
  • Right...because exchange doesn't control selecting that NIC, exchange request from the networking stack just a socket not an IP, the IP provided will be based on the the windows routing table. I would try setting the different metric values on the NIC cards, you can find this on the tcp\ip properties.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Friday, March 18, 2011 12:46 AM
  • Hi azuppinger,

     

    "SourceIPAddress" parameter specifies the local IP address to use as the endpoint for an SMTP connection to a remote messaging Server.

     

    You can get more information from this document:

     

    Set-SendConnector

    http://technet.microsoft.com/en-us/library/aa998294.aspx

     

    Thanks,

     

    Evan

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, March 18, 2011 5:32 AM
    Moderator
  • Awesome thanks Rich and everyone!
    Friday, March 18, 2011 12:33 PM