locked
The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine RRS feed

  • Question

  • My machine is a 64 bit machine.
    Last week, I was able to import Excel 2013 file to SQL Server.
    But today, on SQL Server Management Studio, when trying to import Excel 2013 file to SQL Server, after selecting my excel file, I am getting the error "The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine"

    Our network person has been trying to install Visio on my machine with no luck, so today they uninstall Sharepoint designer 32 bit on my machine. Then I rebooted my machine.
    I am not sure if that causes the error that I am getting or not.

    I installed Microsoft Access Database Engine 2010 64 bit, but still getting the error.

    How can I fix this error ?

    Thank you.

    Thursday, January 21, 2016 9:42 PM

Answers

  • Hello,

    Let’s try a few things:

    1. Install the 32-bit version of the driver too.
    2. Install the “2007 Office System Driver: data connectivity components” from here.

    Hope this helps.

    Regards,



    Alberto Morillo
    SQLCoffee.com

    • Proposed as answer by Ice Fan Friday, January 22, 2016 7:28 AM
    • Marked as answer by aujong Friday, January 22, 2016 7:48 PM
    Thursday, January 21, 2016 11:40 PM

All replies

  • Hello,

    Let’s try a few things:

    1. Install the 32-bit version of the driver too.
    2. Install the “2007 Office System Driver: data connectivity components” from here.

    Hope this helps.

    Regards,



    Alberto Morillo
    SQLCoffee.com

    • Proposed as answer by Ice Fan Friday, January 22, 2016 7:28 AM
    • Marked as answer by aujong Friday, January 22, 2016 7:48 PM
    Thursday, January 21, 2016 11:40 PM
  • Thank you !

    Installing 2007 driver from https://www.microsoft.com/en-us/download/details.aspx?id=23734 fixed the problem.

    • Proposed as answer by Ice Fan Sunday, January 24, 2016 9:14 AM
    Friday, January 22, 2016 7:48 PM

  • Hi aujong,

    Glad to hear that the issue is resolved. Thanks for your sharing, other community members could benefit from your solution.

    Thanks,

    Ice fan


    Ice Fan
    TechNet Community Support



    • Edited by Ice Fan Tuesday, February 2, 2016 11:05 AM
    Sunday, January 24, 2016 9:15 AM