locked
OWA issue - OWA exception in CAS server RRS feed

  • Question

  • Hi

    CAS server : Exchange 2010 on Windows 2008 R2 64bit

    I am having OWA connection issue, try to browse the owa page in CAS server error :

    Request
    Url: https://127.0.0.1:443/owa/
    User host address: 127.0.0.1
    OWA version: 14.1.270.1

    Exception
    Exception type: System.NullReferenceException
    Exception message: Object reference not set to an instance of an object.

    Call stack

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.GetUserIdentities(OwaContext owaContext, OwaIdentity& logonIdentity, OwaIdentity& mailboxIdentity, Boolean& isExplicitLogon, Boolean& isAlternateMailbox, ExchangePrincipal& logonExchangePrincipal)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e)
    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

    Event log :

    Log Name:      Application
    Source:        Microsoft-Windows-IIS-W3SVC-WP
    Date:          4/7/2011 10:11:55 AM
    Event ID:      2280
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      MEXCHCAS01.domainname.grp
    Description:
    The Module DLL C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-IIS-W3SVC-WP" Guid="{670080D9-742A-4187-8D16-41143D1290BD}" EventSourceName="W3SVC-WP" />
        <EventID Qualifiers="49152">2280</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-04-07T02:11:55.000000000Z" />
        <EventRecordID>99632</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>
        <Computer>MEXCHCAS01</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="ModuleDll">C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll</Data>
        <Binary>05000000</Binary>
      </EventData>
    </Event>

     

    Have tried to restart the IIS services and server, but problem persist.

    Wondering if anyone can advice?

    thanks and regards

    Jinfa


    • Edited by supa4 Thursday, April 7, 2011 9:37 AM
    Thursday, April 7, 2011 2:46 AM

All replies

  • This is a fairly generic error. Is your public folders working ok? If you open adsiedit and navigate to the public folder store, is it inheriting permissions? Can you run exchange best practice analyzer and post the report?


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Thursday, April 7, 2011 2:58 AM
  • Hi JInfa,

    In IIS 7.0, worker processes are managed by WAS (the Windows Process Activation Service). If a worker process fails to respond, you may get this error.

    Please Verify that an application pool worker process is running in CAS server and veiry this. See below KB/s for event id 2280.

    Also run EXBPA as suggested by James above and share information with us.

    Event ID 2280 — IIS Worker Process Availability::

    Anil
    Thursday, April 7, 2011 3:18 AM
  • Hi James and Anil

    Thanks for the reply.

    Apparently, I can now access the OWA via my CAS server's IIS.

    But the event is still there every other minute.

    I have tried to config the bitness = 64 according to this link http://www.jjclements.co.uk/2010/10/24/exchange-2010-sp1-issues/ but problem still persist.

    Btw, my EXPA report seems abit too big... do i paste the xml codes here?

     

    Please advice

    thanks and regards

    Jinfa

    Thursday, April 7, 2011 9:41 AM
  • Hi Supa4
       I just read your case.
       You can post error information of exbpa report.
       Can you post how do you fix owa exception? Why you get module error and owa works well…

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 8, 2011 2:44 AM
  • Has there been any resolution to this? I have the same issue. 

     

    C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll
       

    05000000

     

    The Module DLL C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.

     

    A listener channel for protocol 'http' in worker process '1080' serving application pool 'DefaultAppPool' reported a listener channel failure.  The data field contains the error number.

     

    I have set bitness on exppw.dll and still get this error.

    Tuesday, May 17, 2011 6:08 PM