none
Internet explorer slow, in private Browsing fast RRS feed

  • Question

  • Hi,

    I'm having performance issues with Internet explorer for a number of users. as an example easyjet.com is slow and takes over 10 seconds to load. However if i switch to in private browsing the same site loads in around a second. I have tried disabling all toolbars and extensions and disabling Protected mode. Are there other settings that in private browsing disables?

    Thanks,

    Nick


    Thursday, June 5, 2014 2:11 PM

Answers

  • Hi,

    by default InPrivate browsing runs without Browser extensions and Toolbars. Flash and server cookies are not read or written to.

    When you disable addons from the Addons Manager.... you have to close and reopen IE before the full changes take affect.

    or

    Tools>Internet Options>Advanced tab, uncheck "Enable third-party browser extensions".

    Close and restart IE for the full changes to take affect.

    Start>Control Panel>Flash..... to adjust your flash cookie settings.

    Post consumer questions about IE to http://answers.microsoft.com . Include with your questions the full address of any web pages you are having problems with.

    Regards.


    Rob^_^

    Friday, June 6, 2014 4:42 AM
  • Also, furthering Rob's comment about cookies, some sites "log you in" using stored information, and send/do significantly less stuff if they don't "log you in".  In short, the site itself may be delivering a completely different experience based on that setting.

    Rob suggests disabling all your browser extensions, which is effective if a bit extreme.  If you'd rather not disable everything in sight I suggest you review your Add-ons via clicking the Gear icon and choosing Manage Add-ons. You can disable those you don't know you need (and re-enable specific ones if disabling them causes an unacceptable loss of functionality). 

    Bear in mind you really don't need any Add-ons for IE to work, so you may well end up disabling them all or very nearly all of them.  But some are actually useful.

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Sunday, June 8, 2014 6:16 PM

All replies

  • Hi,

    by default InPrivate browsing runs without Browser extensions and Toolbars. Flash and server cookies are not read or written to.

    When you disable addons from the Addons Manager.... you have to close and reopen IE before the full changes take affect.

    or

    Tools>Internet Options>Advanced tab, uncheck "Enable third-party browser extensions".

    Close and restart IE for the full changes to take affect.

    Start>Control Panel>Flash..... to adjust your flash cookie settings.

    Post consumer questions about IE to http://answers.microsoft.com . Include with your questions the full address of any web pages you are having problems with.

    Regards.


    Rob^_^

    Friday, June 6, 2014 4:42 AM
  • Also, furthering Rob's comment about cookies, some sites "log you in" using stored information, and send/do significantly less stuff if they don't "log you in".  In short, the site itself may be delivering a completely different experience based on that setting.

    Rob suggests disabling all your browser extensions, which is effective if a bit extreme.  If you'd rather not disable everything in sight I suggest you review your Add-ons via clicking the Gear icon and choosing Manage Add-ons. You can disable those you don't know you need (and re-enable specific ones if disabling them causes an unacceptable loss of functionality). 

    Bear in mind you really don't need any Add-ons for IE to work, so you may well end up disabling them all or very nearly all of them.  But some are actually useful.

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Sunday, June 8, 2014 6:16 PM
  • @Noel,

    'extreme' but correct.

    "Enable third-party browser extensions" stops Toolbars and browser helpers (COM addons) from being loaded into the browser frame... (Instantiated from iSetSite)... ActiveX controls and scripted extensions, search providers and accelerators are unaffected as they are not using the COM model.

    the COM addons have always been a resource hog as they are loaded with each new frame instance (iSetSite).

    Commonly a toolbar addon includes a browser helper extension... when you disable the GTB from the Addons manager or from the View menu, you are asked to also disable the Google Toolbar helper BHO... users may be confused by this an opt to not disable the helper as well.

    When you disable addons from the MAI (manage addons interface), it does not 'unload' the instances of those addons that have already been loaded into a browser frame. It stops them from being loaded into a new tab in the currently running IE Processes.

    A user could conceivably disable a COM addon with a satellite BHO, but neglect to restart ALL of their IE sessions leading to confusion... I have disabled such and such addon, but the error still persists.... it must be another one of my (many) addons that is the cause....

    the troubleshooting documentation suggests disabling your Addons (using the MAI) one by one to try to find the offending addon. MAI states that you must restart the browser for the changes to take effect.. a user with many COM addons installed and enabled, will find the troubleshooting process tedious and confusing.

    I suggest that the sledge hammer approach (uncheck "Enable third-party browser extensions" and restart IE) is the simplest solution when the user has little interest in finding and disabling the one COM addon that is the root cause.

    Immersive IE hopefully will encourage users to adopt an addon and plugin free browsing environment.

    the GTB also has the Google Toolbar Updater process running on a thread.... it used to switch the "Enable third party browser extension" on when it detected that it had been switched off... to be sure you need to also kill that process from tasksmanger and remove it from your windows startup list using MSConfig.


    Rob^_^

    Saturday, June 21, 2014 12:03 AM