none
VMMAdminUI has stopped working - Microsoft System Center 2012 SP1

    Question

  • Hi,

    When selecting 'Properties' of a VM SCVmm crashes with the following error - "VMMAdminUI has stopped working".

    I get the following Event Log errors:

    Faulting application name: VmmAdminUI.exe, version: 3.1.6011.0, time stamp: 0x50ab00c1
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.18666, time stamp: 0x58f32841
    Exception code: 0xe0434352
    Fault offset: 0x00015608
    Faulting process id: 0x7c4
    Faulting application start time: 0x01d2e0ebc2a23d63
    Faulting application path: D:\Microsoft System Center 2012\Virtual Machine Manager\Bin\VmmAdminUI.exe
    Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll
    Report Id: 19c03445-4cdf-11e7-80ea-42f2e9db8049
    Faulting package full name: 
    Faulting package-relative application ID: 

    Application: VmmAdminUI.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
       at Microsoft.VirtualManager.UI.WpfControls.ElementHostGC.GetFieldValue[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.Type, System.String)
       at Microsoft.VirtualManager.UI.WpfControls.ElementHostGC..cctor()

    (I've trimmed this one down)

    And the following trace error:

    [14]1A00.1B10::‎2017‎-‎06‎-‎09 09:37:10.254 [Microsoft-VirtualMachineManager-Debug]24,1,Program.cs,52,System.TypeInitializationException: The type initializer for 'Microsoft.VirtualManager.UI.WpfControls.ElementHostGC' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object.  

    I have tried a fresh install to 2012 R2 with the same issue. And also a re-install of 2012 SP1 with a brand new database. I add one VM to test and the same thing happens. This happens when clicking ANY VM. Installed the latest Rollup 11 and the issue remains so I'm pretty stuck! Any ideas?

    Was led here by this thread which shows the exact same error that I am getting - https://answers.microsoft.com/en-us/windows/forum/windows_other-winapps/vmmadminui-has-stopped-working-microsoft-system/728899b0-a258-40d5-a91f-5af57d9fbdb6 

    Regards,

    Simon

    Friday, June 09, 2017 9:33 AM

All replies

  • Hello Simon,

    Based on my experience, you can try to reset the settings for SCVMM console by deleting the Settings folder at the location below in Registry, and then re-launch the VMM Console.

    HKEY_CURRENT_USER\Software\Microsoft\Microsoft System Center Virtual Machine Manager Administrator Console\

    Before deletion, I would recommend to back up the registry.



    Best regards,
    Andy Liu

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, June 12, 2017 5:46 AM
  • Hi Andy,

    Thanks for the suggestion. Unfortunately it's no different. Deleted the registry key (after backing up), rebooted and tried again. Still crashing when selecting properties of a host.

    Regards,

    Simon

    Monday, June 12, 2017 7:54 AM
  • Simon,

    I too am having the same problem, other than my VmmAdminUI.exe is different.  My Framework is the same version.  

    Faulting application name: VmmAdminUI.exe, version: 3.2.7895.0, time stamp: 0x54bca98e
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.23796, time stamp: 0x59028e59
    Exception code: 0xe0434352
    Fault offset: 0x0000c54f
    Faulting process id: 0x2dec
    Faulting application start time: 0x01d2e39bdf066012
    Faulting application path: C:\Program Files\Microsoft System Center 2012 R2\Virtual Machine Manager\bin\VmmAdminUI.exe
    Faulting module path: C:\WINDOWS\syswow64\KERNELBASE.dll
    Report Id: 2bdaec32-4f8f-11e7-a62c-ecf4bb57a310

    This is the first time I have tried to use my system was updated (Windows updates).  I noticed that on 6/9/2017 that an update for .NET 4.6.1 (KB4014606 was applied)

    Update:

    I removed the .NET 4.6.1 update (KB4014606) and rebooted my system and the problem with the VmmAdminUI.exe did not come back.  I am able to get into the properties of my VMs and modify them without issue.


    • Proposed as answer by Heath S. _ Monday, June 12, 2017 5:47 PM
    • Edited by Heath S. _ Monday, June 12, 2017 5:49 PM
    Monday, June 12, 2017 5:22 PM
  • Hey Heath,

    Great news that you've managed to fix it. Unfortunately I don't have KB4014606 installed on my machine. I've made a list of updates done recently but none seem to be related to .NET which is annoying!

    I'm going to work through this list and uninstall one-by-one, testing after each one and hopefully I'll get somewhere. Thanks for the heads up.

    Regards,

    Simon

    Tuesday, June 13, 2017 7:59 AM
  • Hi,

    Just thought I'd update this to say the problem is solved. I had to get Microsoft Support on the case to assist and it was long fought but it now seems stable.

    Was first advised that they couldn't assist because SCVMM 2012 SP1 is not compatible with Windows Server 2012 R2. So I had to upgrade to SCVMM 2012 R2 before they would help me, which I did.

    I retained the database from SCVMM 2012 SP1 during the upgrade to SCVMM 2012 R2. The problem remained. The support agent advised that I needed to install Update Rollup 1 (KB2904712) and then straight to Update Rollup 13 (KB4014525) . Once I'd done this the crashing problem had stopped.

    There were other issues related to the runas account which I had to resolve. Library servers would not work and needed an agent update before they could work properly. Currently in the process of fixing the library servers and updating all host agents but it's looking better.

    • Proposed as answer by Alex Kosmich Friday, December 22, 2017 12:25 PM
    Thursday, June 15, 2017 12:42 PM
  • I am having a similar issue:

    It started on a Windows 2012 R2 with SCVMM 2012 UR14 after some MS Update. I have in-place upgraded the OS to Windows 2016, no joy; Upgraded SCVMM 2016- no joy; applied UR5- no joy. Logged with MS support and they are investigating it.

    My error is slightly different and is as below:

    Application: VmmAdminUI.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
       at Microsoft.VirtualManager.UI.WorkloadCreation.NetworkAdapterSettingsViewModelForVmOnWin8AndAboveHost.<UpdatePortClassificationsForLogicalSwitch>b__20(Microsoft.SystemCenter.VirtualMachineManager.VirtualNetworkAdapterPortProfileSet)
       at System.Linq.Enumerable+WhereSelectListIterator`2[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].MoveNext()
       at System.Linq.Enumerable+<DistinctIterator>d__64`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].MoveNext()
       at System.Collections.Generic.List`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]..ctor(System.Collections.Generic.IEnumerable`1<System.__Canon>)

    All versions of consoles from different machines are crashing when trying to see VM properties.

    Any advise appreciated.


    Regards, Ilkin

    Friday, April 27, 2018 9:39 AM