none
Unable to protect Exchange 2010 databases on secondary DPM server RRS feed

  • Question

  • I am trying to protect 4 Exchange 2010 databases that are part of a DAG on a secondary DPM server.  When I add the PG, I get to the Review Disk Allocation and get the following error:

    The operation failed because the data source VSS component 287d78db-a4bb-4474-aaa5-aeac38aeec45 is missing.

    Check to see that the protected data source is installed properly  and the VSS writer service is running.

    ID: 915
    Details: The operation completed successfully (0x0)

    Does anybody have any idea what that means or how to get past it?

    Wednesday, March 13, 2013 8:56 PM

Answers

  • Hi,

    This was a known issue that was fixed, What version of DPM is this ?  (Get the version from under the i icon next to the management tab)

    Workarounds:- There are two possible workarounds.
    -------------------------------------------------
    A) DPM only workaround.
    ---------------------
    1. On the primary DPM, stop protect the database with retain data and reprotect the same DB again.
    2. Let the consistency check complete.
    3. Setup secondary protection. This time it will work since the tables are updated.

    B) Exchange based workaround.
    ----------------------------
    1. Get the database to the same state on the DAG Node (active or passive) as it was when the node based primary protection was setup.

    This means:-
    a. If the Db on the node was passive at the time of setting up protection on primary, currently make it passive.
       OR
    b. If the Db on the node was active at the time of setting up protection on primary, currently make it active.

    2. Setup the secondary protection.
    3. Revert back the Db to the state it currently has to be on the DAG node.

    <dir>

    </dir>

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, March 20, 2013 6:07 PM
    Moderator

All replies

  • Hi,

    This was a known issue that was fixed, What version of DPM is this ?  (Get the version from under the i icon next to the management tab)

    Workarounds:- There are two possible workarounds.
    -------------------------------------------------
    A) DPM only workaround.
    ---------------------
    1. On the primary DPM, stop protect the database with retain data and reprotect the same DB again.
    2. Let the consistency check complete.
    3. Setup secondary protection. This time it will work since the tables are updated.

    B) Exchange based workaround.
    ----------------------------
    1. Get the database to the same state on the DAG Node (active or passive) as it was when the node based primary protection was setup.

    This means:-
    a. If the Db on the node was passive at the time of setting up protection on primary, currently make it passive.
       OR
    b. If the Db on the node was active at the time of setting up protection on primary, currently make it active.

    2. Setup the secondary protection.
    3. Revert back the Db to the state it currently has to be on the DAG node.

    <dir>

    </dir>

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, March 20, 2013 6:07 PM
    Moderator
  • This occurs when the Exchange DB is protected on the Primary DPM server under it's 1st preference server (e.g. serv-exch-mbx1) and it then fails over or mounts to it's second preference server (e.g. serv-exch-mbx2). So when you go to protect this server on the secondary it has failed over and is no longer mounted to the server you protected the DAG DB on the primary DPM server (serv-exch-mbx1). It is now failed over and mounted to serv-exch-mbx2.

    To resolve this problem have the exchange admin balance the DB back to it's number 1 preference server (serv-exch-mbx1) Once this is done you can then protect the DAG DB on the secondary DPM Server because the data is actually mounted to the correct Exchange server. Let me know if this makes sense or if you need further instruction.

    Thursday, August 29, 2013 2:35 PM