none
Not enough memory available to create a ramdisk device RRS feed

  • Question

  • We're struggling with trying to deploy a Windows 7 image created with MDT 2012 via Windows 2008 WDS to an HP notebook. We boot through WDS and then when we choose the OS to deploy we get a Windows Boot Manager message

    Status: 0xc0000017

    Info: There isn't enough memory available to create a ramdisk device.

    Anyone seen this before?


    Orange County District Attorney

    Monday, May 13, 2013 9:11 PM

All replies

  • When you built the boot disk, how much Scratch space did you set and how much memory does that device (HP notebook) have?  If you boot a Virtual Machine from WDS, does it work?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, May 13, 2013 9:38 PM
    Answerer
  • We're booting from a WDS server that we use to deploy our LiteTouchPE_x64.wim to our systems. It dies right at the point where it needs to download the .wim file. I've tried PXE booting to other systems in the office and they are successful. There's 4GB of RAM and the memory tests out successful. It might be that these notebooks are 'consumer' grade and may not play well with WDS.

    Orange County District Attorney

    Monday, May 13, 2013 9:53 PM
  • After further investigation, I'm starting to think that the problem I'm having is due to UEFI. I've disabled this in the BIOS to get the system to run in Legacy Mode but it still fails with the Boot Manager Error. It could be that the existing Windows 8 installation has made some changes as part of UEFI (I'm still trying to understand it) and it cannot be booted and installed normally. Maybe time to boot to a USB stick with Win 7 on.

    Orange County District Attorney

    Tuesday, May 14, 2013 2:54 PM
  • Yeah... might try getting this to work on the machine from a USB stick first before dealing with WDS/PXE.

    There is a long thread semi-related to this.  Might be some useful information toward the bottom: http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/ceca6149-bedd-4860-8a7f-a1c83bf99aa4/


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, May 14, 2013 3:00 PM
    Answerer
  • Thanks David. After more reading, and the great link you added, I think our best option is to boot to Win 7 installation media and do a clean install before PXE-booting to WDS.

    Orange County District Attorney

    Tuesday, May 14, 2013 3:24 PM
  • i was having the same problem but from a usb except i did not disable the uefi i still get thiss error and dont know how to fix it

    Monday, December 26, 2016 3:56 PM
  • How were you able to fix this?  We are getting this exact error on all HP computers as soon as we try to boot from the usb device.  We are trying to deploy Win 7 x64 via MDT 2013 Update 2 and we are not using WDS at this point.
    Monday, February 13, 2017 1:54 PM
  • Boy, it's been quite a while since I had this error. If my memory serves me well, we may have had a mismatch with out BIOs boot settings. I think we may have been trying to boot an NTFS formatted USB when the HP notebook was configured to boot in Secure Boot (UEFI).

    Because of issues with the HP notebooks we now have, we're booting them to USB in Legacy mode and formatting USB sticks similar to this article

    http://systemspecialist.net/2013/05/13/create-bootable-usb-for-mdt-media/

    (part iv of step 3 is out of order, I think it should be create partition primary)

    We've tested and been able to boot when the notebooks are configured to Secure Boot by making FAT formatted USBs.

    What boot mode are your HP systems configure to boot in?


    Orange County District Attorney

    Monday, February 13, 2017 4:46 PM
  • At this point none of our computers are working - UEFI and non-UEFI.

    I've tried several different formats of the bootable USB, we've updated MDT to the latest build, increased the scratch space, removed any obsolete OS's and Task Sequences as well as duplicate drivers.  We've pretty tried everything but starting from scratch...

    Thursday, February 16, 2017 5:28 PM
  • We found that we had to use a FAT formatted USB for our HP systems that were configured for secure boot (UEFI) and NTFS formatted USB for our HP systems configured as legacy boot.

    Orange County District Attorney

    Thursday, February 16, 2017 5:48 PM
  • I found a workaround where we used the LiteTouchPE_x86.iso instead of the x64 and it worked...

    I can only assume that it is due to the fact that our LiteTouchPE_x64.iso is fairly large (2.67GB) and that's where the "memory" error was coming from.  Now I just need to figure out how to reduce the size of it...

    Thursday, February 23, 2017 8:18 PM
  • I've never seen this problem. There is a lot of missing information here.

    1. all USB keys should be formatted as Fat32, no more than 32GB in size. partition 1 marked active. *then* copy the contents of the LitetouchPE_???.iso to the drive.

    2. Please list the make/model of HP machine. My HP 8470p and 600 G1 don't have this problem.

    3. You don't list the specific BIOS settings. UEFI? CSM? try both.

    3. If you are still having problems, try copying a WIndows 10 install disk to a USB drive (see #1 above), and see if that boots. If even this does not boot, then ask HP.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, February 23, 2017 10:38 PM
    Moderator
  • It was indeed the size of the LiteTouchPE_x64 that was causing the issue.  We have a selection profile just for WinPE drivers, but it looks like ALL drivers were selected inadvertently.  
    • Proposed as answer by HNIS Monday, February 27, 2017 3:55 PM
    Monday, February 27, 2017 3:54 PM
  • LiteTouchPEx64.iso or LiteTouchPEx64.wim  ?? I am having the same problem, and its my .wim file that is 4GB and my .iso file is well under 1GB.
    Friday, August 3, 2018 3:57 PM