none
My formula does not work in all areas of my IMS. RRS feed

  • Question

  • I have an IMS with 30 build files in it.

    I am trying to use a formula to give me a calculated EV from either an EV method (0,25,100) or an equivalent unit.  I have a column, Number4, containing 0,.25, or 1 as a EV method, and another field, Number11, using a manual entry % (equivalent unit).  My 3rd field (Number12) uses a formula, (IIf([Number11]=0,[Number4],IIf([Number11]<>0,([Number11])))), to select a value from Number4 if Number11=0 or to put the value from Number11 if is does not = 0.

    If I set these fields up in a sub-project, they work perfectly.  However, if I do a Tools, Organizer, Fields and copy them to the Global, then copy the Global to the Master Schedule, the formula in Number12 does not work in all areas of the IMS.  Some of the cells will calculate correctly but some will either not work period.

    I had a collegue watch me as I did this exercise and we both got the same results.

    Wednesday, May 18, 2011 6:11 PM

Answers

  • > (IIf([Number11]=0,[Number4],IIf([Number11]<>0,([Number11]))))
     
    ...could be simplified IIF([Number11]=0,[Number4],[Number11])
     
    My first guess would be that the field is not in the master or not in all
    subprojects.  It sounds like you've done that with the organizer.  Maybe
    you just need to hit F9 to refresh the calculations?
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Wednesday, May 18, 2011 6:25 PM
    Moderator

All replies

  • > (IIf([Number11]=0,[Number4],IIf([Number11]<>0,([Number11]))))
     
    ...could be simplified IIF([Number11]=0,[Number4],[Number11])
     
    My first guess would be that the field is not in the master or not in all
    subprojects.  It sounds like you've done that with the organizer.  Maybe
    you just need to hit F9 to refresh the calculations?
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Wednesday, May 18, 2011 6:25 PM
    Moderator
  • I used the simplified version of the formula and it seems to be working now.

    Thanks for your help.

    Wednesday, May 18, 2011 6:51 PM
  • I also discovered I had to add that field to every project or it would not calculate in the IMS.
    Wednesday, May 18, 2011 7:31 PM