locked
Windows Explorer always opens folders in a new window RRS feed

Answers

  • Hi!!

    The problem lies in this sh***y MVT application which you must install before downloading beta of whole Mcaffe center. I've removed only the MVT (Mcaffe Virtual Technician) and explorer started working automagically just like it should.

    MVT is used to report bugs to Mcaffe... and now how to properly report a bug without an app for doing it? :]
    • Marked as answer by jkyoutsey Wednesday, June 24, 2009 11:55 PM
    Friday, June 19, 2009 8:54 AM

All replies

  • Jared,

    "Launch folder windows in a separate process" isn't enabled from the folder options, is it? This will override all other settings.
    -Alex
    Wednesday, June 10, 2009 9:23 PM
  • Jared,

    "Launch folder windows in a separate process" isn't enabled from the folder options, is it? This will override all other settings.
    -Alex
    No.  It is not checked.
    Jared
    Wednesday, June 10, 2009 9:25 PM
  • I've been having the same problem. I'm not a newbie. I've even checked registry entries and all say my folders should be opening in the same window. But they don't. Not only that, but when I create a new user for test puposes, folders do open in the same window. But when I try to make the change to have them open in seperate windows, that change does not take effect either.
    Friday, June 12, 2009 2:50 AM
  • Open up Registry Editor, and go to:
    HKEY_USERS\S-1-5-21-xxxxxxxxxx-xxxxxxxxxx-xxxxxxxxx-1000\Software\Microsoft\Windows\CurrentVersion\

    Delete "Explorer". It will be re-created.

    Reboot.

    Note:
    From the computers that I have studied, the 'x' are numerical values that differ between computers.

    But it should begin with: HKEY_USERS\S-1-5-21

    and end with:
    1000

    TRY  THIS IT WORK FOR ME MAY BE IT WILL WORK FOR YOU

    NOTE THAT YOU ARE PLAYING WITH REGISTRY SO BETTER YOU CREAT RESTOR POINT BEFOR DOING THIS OR CREAT A BACKUP OF YOUR C: DRIVE. IN CASE IF ANY THING GOSE WRONG YOU CAN RESTORE YOUR SYSTEM.

    Saturday, June 13, 2009 12:32 AM
  • Althought this trick did indeed rid me of my original problem, it also unfortunately added additional user interface quirks, such as the inability to configure the taskbar, etc. So, I restored back to my original registry settings. But, this does tell me in what part of the registry this change is being effected from, after having tried tweaks in other areas of the registry. From here I will slowly test various settings in this area until I nail it down. When I am successful I will report the info here. Thanks.
    Saturday, June 13, 2009 12:05 PM
  • Even I'm facing the same problem.

    Reminds me of GNOME Nautilus open in new window by default. Atleast in it you could have closed the tree/all parent windows at once. And the option to switch to browser mode(no-new windows) works perfectly.

    Could you please list the anti-virus you are using. It may be a conflict.
    This is a wild guess, I read that this could be a problem somewhere.

    I'm using McAfee .
    • Edited by ramblezeus Tuesday, June 16, 2009 2:22 PM
    Tuesday, June 16, 2009 1:53 PM
  • I'm having this problem and I'm running the new McAfee Beta
    Tuesday, June 16, 2009 2:02 PM
  • I'm using McAfee .

    Yep, I'm using McAfee's Windows 7 Beta product also.

    Jared
    • Marked as answer by axfelix Tuesday, June 16, 2009 2:40 PM
    • Unmarked as answer by jkyoutsey Tuesday, June 16, 2009 2:42 PM
    Tuesday, June 16, 2009 2:05 PM
  • I'm having this problem and I'm running the new McAfee Beta
    I'm going to log this as a bug with McAfee and see what happens on that front.
    Jared
    Tuesday, June 16, 2009 2:06 PM
  • I'm having this problem and I'm running the new McAfee Beta
    I'm going to log this as a bug with McAfee and see what happens on that front.
    Jared
    You should all log bugs with McAfee as well.  See if we can get enough attention to be sure that this is getting fixed.
    I might try uninstalling McAfee later to see if it fixes it.  Might be nice if someone has a test system to see what happens with a clean box before and after McAfee install.  That would confirm/deny the theory.

    Jared
    Tuesday, June 16, 2009 2:44 PM
  • I'm using McAfee also. Not the Beta but the one provided by Comcast to it's users, the one with known but unspecified compatibilty issues.
    Wednesday, June 17, 2009 11:26 AM
  • I've just uninstalled my incompatible Comcast version of McAfee. The problem is fixed. Report to McAfee.
    • Marked as answer by Nick FV Thursday, June 18, 2009 4:11 PM
    • Unmarked as answer by jkyoutsey Wednesday, June 24, 2009 11:55 PM
    Wednesday, June 17, 2009 12:02 PM
  • Just for the record, I was also having a problem with IE8. Popups that were supposed to be coming up as a seperate window weren't loading either. The uninstall of McAfee fixed that also. Do we see a common thread here?
    Wednesday, June 17, 2009 12:09 PM
  • It seems that this bug has been isolated as a McAfee problem so I will mark the thread answered.

    -Nick
    Thursday, June 18, 2009 4:11 PM
  • It seems that this bug has been isolated as a McAfee problem so I will mark the thread answered.

    -Nick
    Why?  The CAUSE is NOT an answer.  The answer will be something like "hey McAffe has a new version, go download it".  I don't pay for AV because Comcast provides it.  And it worked fine right up until Windows 7.  So the beta is broken.  The ANSWER will be when we have a working version from McAfee.
    Jared
    Thursday, June 18, 2009 9:21 PM
  • This statement is a true thing. Although the problem is not Microsoft's, it is still a problem until McAfee fixes their product. I too don't pay seperately for my AV but rather it's cost is obsorbed as part of my ISP costs. ( I refuse to say "it's free". Nothing is free.) Although my experience with Win 7 has for the most part been favorable, I will not be upgrading when the time comes until this McAfee problem is resolved.
    Thursday, June 18, 2009 10:33 PM
  • Hi!!

    The problem lies in this sh***y MVT application which you must install before downloading beta of whole Mcaffe center. I've removed only the MVT (Mcaffe Virtual Technician) and explorer started working automagically just like it should.

    MVT is used to report bugs to Mcaffe... and now how to properly report a bug without an app for doing it? :]
    • Marked as answer by jkyoutsey Wednesday, June 24, 2009 11:55 PM
    Friday, June 19, 2009 8:54 AM
  • I must admit that I too had installed MVT because I had been thinking about trying the beta. But then I changed my mind about that. And when I uninstalled my Comcast McAfee, I uninstalled MVT FIRST! But never checked on what change that might have brought about before uninstalling Comcast's McAfee.
    Friday, June 19, 2009 11:09 AM
  • Uninstalling MVT cleared up both problems but also fixed an issue I had with devices not showing in the Devices and Printers window.  It's nice when you can fix most of what's wrong with your system at one time.  Thanks!
    Wednesday, June 24, 2009 5:59 PM
  • Hi!!

    The problem lies in this sh***y MVT application which you must install before downloading beta of whole Mcaffe center. I've removed only the MVT (Mcaffe Virtual Technician) and explorer started working automagically just like it should.

    MVT is used to report bugs to Mcaffe... and now how to properly report a bug without an app for doing it? :]
    Now THAT's the answer.  Thanks!  That really did fix the issue.
    Jared
    • Proposed as answer by Brian Borg Thursday, June 25, 2009 12:58 AM
    Wednesday, June 24, 2009 11:55 PM
  • I'm not convinced it's a McAfee thing - I am using AVG Free as my AV software and am getting the same problem.  I ran this combo fine for ages without the issue, and I have a non-Windows Update'd Windows 7 RC1 machine that isn't giving this problem.  I think it's one of the WU that is causing this problem - suggestions?

    Cheers

    Pete
    Tuesday, July 7, 2009 12:00 AM
  • I have a fully updated RC machine and I solved my problem by uninstalling the McAfee MVT application. You don't need it after you install McAfee itself.
    Tuesday, July 7, 2009 8:09 AM
  • Totally appreciate that, however it still stands that I have 2 machines (Sony Vaio UX1XN and Sony Vaio VGN-N21SW) which both have Windows 7 RC1, neither of them use McAfee - just AVG - and one of them works whereas the non-updated one doesn't.

    I've also just finished building another computer (desktop) which I will try when I get home tomorrow morning.  I have Win7 32bit and Win7 64bit installed on that.  Both updated.

    However I've just powered up my Acer Aspire One (dualboot XP and Win7 32bit) and it does the same thing - same problem with multiple windows.  Again, McAfee hasn't even been near this machine so it can't be the problem causer on mine.  The Acer, out of interest, is also fully Windows Updated.
    • Edited by PeteGraham Tuesday, July 7, 2009 7:22 PM ridiculous spelling errors.
    Tuesday, July 7, 2009 7:21 PM
  • It's definately not limited to McAfee users. I don't have an AV installed yet explorer still opens new windows even with it set not to.
    Wednesday, July 8, 2009 2:35 PM
  • I'm having the same problem and I've never installed McAfee.  I've tried changing the settings in Control Panel | Folder Options, through the explorer menus, and deleting the explorer registry entry (as suggested by frriction above) .  Nothing seems to work. 

    I'm running Windows 7 Build 7100
    Wednesday, July 8, 2009 7:08 PM
  • Right, update.  When I tried it on my X64 Win7 build it was fine, but on the same machine X86 build, opens in new windows. 

    I've noticed if you right click on the folder and choose Open (bolded option) it does as it should, but it's as if when you double click on the folder it's not using the bolded choice in the menu (default), and instead opting for the next one down - new window.

    Friday, July 10, 2009 9:17 AM
  • I did a system restore to about two weeks ago and the issue is gone! Annoying little bug....
    Tuesday, July 14, 2009 3:17 PM
  • Dude, i fixed this problem, cuz its very annoying.... this is what i did:

    run regedit and go to HKEY_CLASSES_ROOT\Directory\shell, change the default key from none to open.

    Hope this helps, if its not so late :P. 
    Saturday, November 21, 2009 2:15 AM
  • I had the same problem for so long and it was very frustrating also! After trying several tips to no avail I finally stumbled upon the fix!
    Im sure most of yall did the same!
    I wanted explorer to open up in computer rather than libraries! so I did the part where I changed properties and the target! edit the string that you added, remove root! should look like this >>> %SystemRoot%\explorer.exe ,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

    That was the ticket!!
    • Proposed as answer by Baiju Nagori Monday, January 10, 2011 9:53 PM
    Wednesday, February 3, 2010 9:28 PM
  • Apologies for rearing an old thread, but I'm doing so for the purpose of making a contribution.  (...and it's still near the top of Google)

    Relevant to Microsoft Windows Vista SP2 x64:

    Solution:
    TaskKill.Exe /IM Explorer.Exe /F

    Reg.Exe COPY "HKEY_CURRENT_USER\Software\Classes\Interface" "HKEY_CURRENT_USER\Software\Classes\Interface.DISABLED" /S

    Reg.Exe DELETE "HKEY_CURRENT_USER\Software\Classes\Interface" /F

    Shutdown.Exe -L

    Essentially all that was done was rename the user-specific "Interface" key under the Software\Classes key.  I recommend replacing that key with entries from a freshly created, temporary user.  You can use RegEdit.Exe to EXPORT "HKEY_CURRENT_USER\Software\Classes\Interface" from the other user to the Public/Shared Documents folder, then IMPORTing that file under the problematic account.  The INTERFACE key did not appear to contain any paths that would need correcting.  The above commands can be run via the Command Console/Prompt, which can be launched before forcing Explorer closed.  Running it with elevated privileges is not necessary or recommended.  RegEdit when launched should not be run with elevated privileges.

     

    Problem Description:
    There are a number of potential causes for this issue.  For me, it was not any of the things listed by others above.  Right-clicking the object, (folder or drive,) shows "Explore" in bold, as it should be.  If I double-clicked the object however, it would perform the equivalent of "Open," which opens a new window.  If I selected "Explore," again already in bold, it would open in the same window.  Other accounts on the PC, such as the Guest account, all operated normally.  So this is a user-specific issue in my case. 

    NOTE:  If this is NOT a user-specific issue... that is, ALL users experience this issue, then you may wish to rename and restore the "HKEY_LOCAL_MACHINE" portion of "WOW6432Node\Classes\Interface" and "Software\Classes\Interface".

     

    Background:
    This started to occur after transferring specific WPWin9.Exe related registry entries from another XP x86 (32-bit) installation.  (Getting WordPerfect 9 operational.)  Having a list of changes, (REG files,) it was a simple matter of methodically undoing those changes.

    In short, problem caused by USER.  ;)

    -Intuit

    • Proposed as answer by Intuit Thursday, April 22, 2010 6:43 PM
    Monday, March 15, 2010 5:04 PM
  • I must express my highest gratitude to Intuit for this last note. I was suffering a lot with this nasty problem and none of the previous solution was useful. I was in exactly the same situation than Intuit ("Explore" in bold, but when double-clicking always appeared a new window). I performed this solution proposed by Intuit and now I have peace of mind and I'm getting to know the nirvana. This is a very, very annoying problem and you save me from it. I almost forgot the sensation of controlling Windows. My deepest gratitude. Thanks.
    Thursday, March 25, 2010 9:53 PM
  • Hi Intuit!

    That solution didn't work for me... :(

    I'm using the Windows 7 and I still have the same problem (Double-clicking a folder in the right pane always opens a new window).

    Do you know what I have to do?

    Thanks!

    WLins

    Thursday, April 22, 2010 12:24 PM
  • JPMarichal, thanks for the thanks.  You, others can vote the post as helpful.

    This may help others find that one amongst the many more quickly.

     

    Hi WLins.  Review the problem description.  It being Windows 7 aside, does this match your case precisely ?  

    Regarding the HKEY_LOCAL_MACHINE\.....\Interface key(s), if you don't have a backup of the registry that predates the issue's occurrence, then you may try EXPORTing that key from a new or known-good installation that matches your own; in terms of being Windows 7, OEM/Retail, Home/Ultimate/Corporate/Etc and FULLY updated.  Export and delete, or rename your original Interface key(s).  Then IMPORT the key from that new or known-good install, to the affected system.

    The solution that was posted, was with regard to Vista x64.  It's possible that it works with Vista x86, Windows 7 x64/x86, however this is yet untested and unconfirmed.  Whether it works, of course heavily depends on the described circumstances being nearly identical in nature.

    Thursday, April 22, 2010 6:55 PM
  • Hi Intuit, thanks for the answer and being so fast! Yes, my case is precisely (Windows Explorer always opens folders in a new window) on Win7. I don't have a backup of the registry and there's no Windows 7 (x86) installation around me. Just two of (x64), can I try one of that? Is still there something more I can do? Once again, thank you! Windson (WLins)
    Friday, April 23, 2010 8:05 AM
  • Hi Everybody!

    I solved the problem!!!

    All I did to solve was a system restore from a point (that OS created automatically) before the installation of one program. The program? I can't believe... Was the JAVA (TM) Update 20!!! 

    Intuit. I tried to import the key from that known-good windows installation and it didn't work too (but was a 64bits).

    And now, I'm afraid to update de newest version of java...

    Thx!

    Windson

     

    Friday, April 23, 2010 9:37 AM
  • <<...tried to import the key from that known-good windows installation ...... (but was 64bits)...>>

    importing x64 keys to an x86 installation may not work.  HKLM\WOW6432Node\Classes\Interface would have to be combined with (overwrite) the standard location and then that be copied/imported to the x86 install.  Even then, there might be some unanticipated problems. 

    It's good that you had a registry backup available in system restore.  Although I like the inherent security and reliability in the Vista/Win7 system restore implementations, one thing that I miss was being able to pluck only the registry files from a restore point; like I used to do with WinXP.

     

    <<...Yes, my case is precisely (Windows Explorer always opens folders in a new window) on Win7. ....>>

    Also, that is too general.  There is more nitty-gritty details that have to be verified, such as whether the issue is per-user, or whether the "Explore" option is in bold and works properly when manually selected.  In a lot of cases, that simply may not be in bold which means it's no longer the default action on double-click.  (requires different set of steps to resolve, focusing on another part of the registry)  But from what you've stated on JAVA update 20, there well could be some changes to the HKLM portion of that Interface key... don't know.  A before and after registry compare usually helps pin down the issue.

    EDIT 10y04m24d_130735:  One other thing that occurs to me, is that the dreaded Yahoo toolbar often installs with Sun Microsystems's JAVA.  I've removed such toolbars on many browsers because they render IE8 unstable/unreliable with occasional to routine freezes/crashes.

    Friday, April 23, 2010 12:21 PM
  • So, I don't know if the problem was installing Java **20, as I've installed it on 5 machines and only have this problem on 1.

    I've also installed TortoiseSVN on 2 machines and only have the problem on the one.

    I don't have McAffe installed at all. We use TrendMicro here and it's been installed for years.

    For me, I noticed that when I opened a folder, say a desktop folder, it always opened up with 'folders' in the left pane. Clicking a folder in the right pane correctly opened the folder in the same window, but it always had the 'folders' in the left pane (what a pain!)

    Researching that I found that by going to Tools->Folder Options->File Types, selecting 'Folder' (not 'File Folder'), pressing 'Advanced' and selecting 'open' as the default would fix that problem.

    And, indeed it did, but now I get all double-clicking-right-panel-folders opening in a new window. Drat! Another pain!

    If I switch back to 'explore' as the default I get 1 window but 'folders' in the left pane - always

     

    I notice on my other machines, that nothing is set as default in Tools->Folder Options->*->Folders->Advanced. I've been tempted to set it and see if the problem appears on the 2nd machine, but then I'd have two broke machines instead of just 1.

    Anyone know how to de-select the default value for the Folder Options?

     

    Thanks,

     

    - mike

     

    Wednesday, April 28, 2010 2:25 PM
  • I had the same problem for so long and it was very frustrating also! After trying several tips to no avail I finally stumbled upon the fix!
    Im sure most of yall did the same!
    I wanted explorer to open up in computer rather than libraries! so I did the part where I changed properties and the target! edit the string that you added, remove root! should look like this >>> %SystemRoot%\explorer.exe ,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

    That was the ticket!!


    I did the exact thing- changed explorer to open in "computer" rather than the user library root- and once I took out "/root" from the path above, everything worked perfectly.  I'd guess many of you above did something similar.

    No registry hacking required.

    Wednesday, July 7, 2010 3:42 PM
  • simple fix for this guys, just run this registry hack. http://iefaq.info/attachments/133/ie8-rereg.zip

     

    Job done!!!

    Wednesday, August 11, 2010 7:25 AM
  • Hey Grantardo, add

     

     

    regsvr32 /s "%SystemRoot%\System32\ScrRun.DLL"

     

     

    to that as well.  Also, like a lot of command line utilities, RegSvr32 might return an exit code.  If %ErrorLevel% neq 0, then something may have not registered correctly; in which case it is then usually necessary, to rewrite registry permissions; and in more rare cases, rewrite and replace a file(s) permissions.  In cases where the IE8 (re)installer fails to resolve the issue, it's due to the fact that the installer doesn't redress the permissions side of things; or/and for whatever reason fails to unregister before reregistering a component; or/and can't possibly know to remove offending or interfering registry entries.  Such additions must be removed and unfortunately restoration, is the only way to do so.

     

    Everybody, always, always research and inspect scripting content before executing.  LINKED CONTENT can be changed at any time and some servers are not properly secured against hacking.

     

     

     

     

    • Proposed as answer by weilik Monday, October 18, 2010 9:45 PM
    Wednesday, August 11, 2010 11:15 AM
  • I renamed the internet explorer directories for security reasons. This caused the problem with windows explorer. I have no idea why windows explorer would exhibit such a strange dependency on IE but this just adds to my distrust of IE.

     

    Sunday, March 27, 2011 11:54 PM
  • I DELETED Internet Explorer AND Windows media player. And this caused the same problem. I have tried ALL the current solutions, and none of them works. I even imported registry from a Working computer on the same OS as me (Windows 7) and it didn't do any good. Any ideas?
    Wednesday, April 25, 2012 2:22 AM
  • I tried this one and it worked for me (Windows 7)

    Just open up My Computers

    Click on organize on top left corner of your screen

    Then click on Folder and Seach Option

    On General and View tab click on restore default. 

    Apply and Ok and it should work.



    • Edited by Shanks Ozil Friday, November 8, 2013 12:50 PM
    Friday, November 8, 2013 12:47 PM
    1. open cmd as administrator from start menu
    2. and type SFC /SCANNOW
    3. and it will resolve your promblem
    Monday, March 31, 2014 8:27 AM
  • Try this (as Administrator):

    regsvr32 "%SystemRoot%\System32\actxprxy.dll"
    regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

    Thanks to http://superuser.com/questions/277924/windows-explorer-opens-a-new-window-every-time

    Sunday, August 30, 2015 11:11 PM