none
Hyper-V encountered an error trying to access an object... RRS feed

  • Question

  • I've Googled this issue on and off for most of the day, more or less attempting every potential fix in the hope of resolving this issue so that I can move on and deploy a bunch of servers via Docker.  I've so far being unsuccessful.

    Earlier today I installed Hyper-V.  Simple enough (and throughout my attempts to get it to work I've uninstalled, reinstalled, purged and re-imaged OS backups countless times).  Then I threw Docker into the mix.  Docker complained with the noted error, so during my attempts to resolve it I ended up where I started: a recent OS image and a fresh install of Hyper-V.

    When I attempt to use Hyper-V Manager, the issue is highlighted further because most entries within Hyper-V Settings, under Server, such as Virtual Hard Disks, Virtual Machines, NUMA Spanning and Enchanced Session Mode Policy list "Load Failed" as the only item, with the error "There was an error loading the data for this setting." explaining how Hyper-V encountered an error trying to access an object...

    The same goes with the Global Network Settings, under Mac Address Range, where "Load Failed" rears its ugly head again.  To cap it all, the Hyper-V Quick Create app throws the error the moment it starts.

    No matter what I have attempted today, I simply cannot get Hyper-V working, and I've tried every solution Google has thrown at me.  Therefore I'd be eternally greatful for any assistance resolving the issue.

    Thanks.





    • Edited by ErichZann1 Saturday, November 30, 2019 8:23 PM
    Saturday, November 30, 2019 7:47 PM

All replies

  • Hi,

    Thanks for your question.

    Any error message in the event viewer regarding Hyper-V and system?

    And would you mind please posting a screenshot for your current failure information so that we can find more clue about this issue?

    Please note, please cover up your privacy information for your security if you post something.

    Highly appreciate your effort and time. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 2, 2019 9:28 AM
    Moderator
  • First thing to check is if you hardware supports the version of Windows Server that you are trying to install - windowsservercatalog.com.

    tim

    Monday, December 2, 2019 2:17 PM