locked
How do I create an account on my Windows 7 notebook that I can use for sharing, but cannot login ? RRS feed

  • Question

  • Windows 7 requires a username for shared folders and I only want to give my work colleagues (running Windows XP in a non-Domain environment - we are consultants at a client site) an account name and password that they can use for accessing shared folders on my Notebook.  I don't want a collegue to be able to log into my notebook, only access the shared folders. 
    How do I set up this account on my Windows 7 notebook or how should I approach this problem?
    Monday, November 30, 2009 2:07 AM

Answers

  • My-Display-Name,

    Indeed the tool is officialy not supported on windows 7.
    But 85% chance that it will work on windows 7.

    But if don't want to use it you can do it with the windows GUI. (This only works if you have windows 7 pro, enterprise or ultimate)

    • Open an administrative prompt.
    • Type the command Secpol.msc
    • And in the security policie editor you click Local Policies > User Rights Assignment > Deny logon localy.
    • And add there your user to that list. Save it. Try to logon with that user.
    • Create the folder that you want to share.
    • Set the give your user the nesseary NTFS permissions
    • Set the give your user the nesseary Share permissions.

    Kind Regards
    DFT


    IM me - TWiTTer: @DFTER
    Monday, November 30, 2009 2:28 PM

All replies

  • My-Display-Name,

    If a user has the "interactive logon" privilege (SeInteractiveLogonRight) a user is allowed to physicaly logon to your desktop.
    Or trough remote desktop.

    If this is what you want to disable you can download NTrights.Exe from the following link
    http://support.microsoft.com/kb/315276

    And execute it with the following syntaxis in a administrative prompt (in this case i called my user MySharedUser). 
    NTRIGHTS +r SeDenyServiceLogonRight -u MySharedUser
    Remove all the security groups from the local user MySharedUser.
    Asign the share & NTFS rights to the MySharedUser

    And that should do it.

    Kind Regards
    DFT
    IM me - TWiTTer: @DFTER
    Monday, November 30, 2009 10:07 AM
  • Thanks for the link, but it says:
       This article applies to a different version of Windows than the one you are using. Content in this article may not be relevant to you.
       Visit the Windows 7 Solution Center
    Is there a Windows 7 version of this tool?
    Is there a better way to share a folder with Windows 7?

    Thanks
    Monday, November 30, 2009 1:54 PM
  • My-Display-Name,

    Indeed the tool is officialy not supported on windows 7.
    But 85% chance that it will work on windows 7.

    But if don't want to use it you can do it with the windows GUI. (This only works if you have windows 7 pro, enterprise or ultimate)

    • Open an administrative prompt.
    • Type the command Secpol.msc
    • And in the security policie editor you click Local Policies > User Rights Assignment > Deny logon localy.
    • And add there your user to that list. Save it. Try to logon with that user.
    • Create the folder that you want to share.
    • Set the give your user the nesseary NTFS permissions
    • Set the give your user the nesseary Share permissions.

    Kind Regards
    DFT


    IM me - TWiTTer: @DFTER
    Monday, November 30, 2009 2:28 PM
  • That did it!
    Thanks!
    Tuesday, December 1, 2009 2:23 PM