locked
Exchange server 2007 resource mailbox problem RRS feed

  • Question

  • Hi,

    We have an exchange 2007 equipment mailbox just created. I need it to accept bookings automaticaly. How should I do it? How do I make this calendar visible to everyone without giving full access to the mailbox?

    Thank you very much.

    Kind Regards,

    David.

    Wednesday, July 4, 2012 11:05 AM

Answers

  • Hi

    See this and links within.  Users shuld be able to search the resource caledar via OLK.


    Sukh

    Wednesday, July 4, 2012 11:16 AM
  • You can configure to automatically accept/decline bookings using the command.

    Set-MailboxCalendarSettings <mailboxname> -AutomateProcessing AutoAccept

    By default, Equipment mailboxes will have default reviewer access to the calendar.

    Wednesday, July 4, 2012 12:12 PM
  • Hello,

    By default, equipment mailboxes will allow default to view free/busy information on it calendar.

    If you need Default can access the equipment mailbox calendar, use this command to grant permission:

    Set-MailboxFolderPermission -identity Equipmentmailbox:\Calendar -user Default -AccessRights reviewer

    Set-MailboxFolderPermission
    http://technet.microsoft.com/en-us/library/ff522363.aspx

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Thursday, July 5, 2012 5:43 AM
  • Sorry, I ignored you are using Exchange 2007, this command will not work in Exchange 2007, it only supported for Exchange 2010.

    In Exchange 2007, you can configure that resource mailbox in Outlook, then go to change Default permission on Calendar.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Friday, July 6, 2012 2:09 AM

All replies

  • Hi

    See this and links within.  Users shuld be able to search the resource caledar via OLK.


    Sukh

    Wednesday, July 4, 2012 11:16 AM
  • You can configure to automatically accept/decline bookings using the command.

    Set-MailboxCalendarSettings <mailboxname> -AutomateProcessing AutoAccept

    By default, Equipment mailboxes will have default reviewer access to the calendar.

    Wednesday, July 4, 2012 12:12 PM
  • Thank you both for your answers,

    I have created the mailbox as equipment and set automateProcessing with that command. I have updated offline address list but I can't open the calendar. There is a message awaring that i have no permission to see that calendar and asking if I want to ask yhe mailbox user to gain access to it. Should I do anything else?

    I will review the information Sukh sent in his post

    thank you.

    Wednesday, July 4, 2012 2:38 PM
  • Can't you search it rather than try and open it.


    Sukh

    Wednesday, July 4, 2012 3:30 PM
  • Hello,

    By default, equipment mailboxes will allow default to view free/busy information on it calendar.

    If you need Default can access the equipment mailbox calendar, use this command to grant permission:

    Set-MailboxFolderPermission -identity Equipmentmailbox:\Calendar -user Default -AccessRights reviewer

    Set-MailboxFolderPermission
    http://technet.microsoft.com/en-us/library/ff522363.aspx

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Thursday, July 5, 2012 5:43 AM
  • Hi,

    I get to make the equipment mailbox to process it automatically, finally.

    Users can see free/busy information when they try to book resource. there is a security group made to handle bookings, so everyone in that group can access resources calendars (inherited from exchange 2003). I would like to add new resources created in Exchange 2007 to share their calendar with users in that group.

    I tried to use the command Set-MailboxfolderPermission, but the Exchnage 2007 Shell prompts a message warning this is not a recognaised cmdlet. Set-MailboxCalendarSettings is welol recognaised.

    Thank you very much.

    Best Regards.

    David.

    Thursday, July 5, 2012 8:09 AM
  • Sorry, I ignored you are using Exchange 2007, this command will not work in Exchange 2007, it only supported for Exchange 2010.

    In Exchange 2007, you can configure that resource mailbox in Outlook, then go to change Default permission on Calendar.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Friday, July 6, 2012 2:09 AM
  • Hi,

    Ok then I have to enable the resource mailbox user, give that permissions and disable it again.

    Thank you all of you.

    Kind regards.

    Friday, July 6, 2012 12:47 PM