locked
App-v 5.0 client can't sync to publishing server RRS feed

  • Question

  • Server 2008 r2 with all updates is installed on both client and server (management, publishing and reporting components on one machine) vms in the same AD domain. I have revisited the Trial Guide and Administrators Guide as well as read every post that seemed remotely relevant, including the one on troubleshooting syncing problems. I've reinstalled the app-v components including SQL and even rebuilt the VMs. Management console seems to operate perfectly, able to add packages and connection groups and enable AD group access to both. Html page initiated from client to publishing server presents the correctly formatted xml file with the package included. Package executes as an msi install on client in standalone mode.

    However, Powershell sync-appvpublishingserver returns:

    CoCreateInstance() failed. The Microsoft Application Virtualization Service may not have been started. Please verify that the service is running.

    There is no corresponding event log entry.

    Restarting Microsoft App-V Client service is successful and throws:

    Log Name:      Microsoft-AppV-Client/Admin
    Source:        Microsoft-AppV-Client
    Date:          3/1/2013 2:40:16 PM
    Event ID:      15002
    Task Category: Connect to AppV Client Service
    Level:         Error
    Keywords:      Client Streaming UX
    User:          Domainname\administrator
    Computer:      FQDN
    Description:
    The AppVStreamingUX application experienced a COM error while attempting to connect to the AppVClient service. The AppVStreamingUX process will now exit. HResult: -2147024891
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-AppV-Client" Guid="{Guid#}" />
        <EventID>15002</EventID>
        <Version>1</Version>
        <Level>2</Level>
        <Task>29</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000080000</Keywords>
        <TimeCreated SystemTime="2013-03-01T21:40:16.578697700Z" />
        <EventRecordID>182</EventRecordID>
        <Correlation />
        <Execution ProcessID="1028" ThreadID="2956" />
        <Channel>Microsoft-AppV-Client/Admin</Channel>
        <Computer>FQDN</Computer>
        <Security UserID="admin SID" />
      </System>
      <EventData>
        <Data Name="HResult">-2147024891</Data>
      </EventData>
    </Event>

    Must be something basic I've overlooked. Any help appreciated.

    Thanks,

    Friday, March 1, 2013 10:09 PM

Answers

  • Hello,

    I suggest you reinstall the client. Something has gone awry during your initial install


    Nicke Källén | The Knack| Twitter: @Znackattack

    • Marked as answer by lloydswylie Tuesday, March 5, 2013 11:33 PM
    Sunday, March 3, 2013 8:32 PM

All replies

  • Hello,

    Have you installed all the prerequisites for the App-V Client?

    See this list;

    http://technet.microsoft.com/en-us/library/jj713458.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, March 3, 2013 9:45 AM
  • Thanks for responding. I reviewed the prerequisites again and have done them all except the KB2533623 update. Both server and client reject the update with "this update is not applicable to your computer".

    Thanks,

     
    Sunday, March 3, 2013 6:34 PM
  • Hello,

    Do you really have .NET Framework 4.0 (full) profile installed?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, March 3, 2013 6:57 PM
  • Yes, I downloaded it via the link in the App-V 5.0 Prerequisites guide. I had previously installed the 4.5 version but then uninstalled that and installed the 4.0 version.

    Thanks,

    Sunday, March 3, 2013 8:04 PM
  • Hello,

    I suggest you reinstall the client. Something has gone awry during your initial install


    Nicke Källén | The Knack| Twitter: @Znackattack

    • Marked as answer by lloydswylie Tuesday, March 5, 2013 11:33 PM
    Sunday, March 3, 2013 8:32 PM
  • I set up a new VM and added .net 4.0 full and Powershell 3.0. However, I still can't install KB2533623. It's rejected with "the update is not applicable to your computer". This is a windows 2008 R2 SP1 VM fully updated. Is it possible KB2533623 is superceded by another update? Is this update absolutely necessary?

    Thanks,

    Monday, March 4, 2013 6:36 PM
  • Hello,

    Did you download the right architecture? x64 for x64...


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, March 4, 2013 7:52 PM
  • Yes. I even tried running the x86 version when x64 didn't work.
    Monday, March 4, 2013 11:03 PM
  • This time I recreated the vm template I had been using to build the app-v clients and that solved the problem. I'm wondering if that template had had a version of app-v 4 on it at one time that didn't get completely uninstalled. Anyway thanks for your help.
    Tuesday, March 5, 2013 11:32 PM
  • I also am getting this error when trying to install KB2533623 while using a vm template that has been fully updated. It's never had a previous version of App-V on it, so it's not that.

    I suspct one of the existing updates is preventing/has presented it.

    Unfortunately building a new template isn't an option for me, so it's back to the drawing board.

    Monday, March 11, 2013 8:10 AM
  • Hi All,

    I also faced the same  issue CoCreateInstance() failed while installing a app-v 5.0 package during two scenarios . Below is the procedure I followed which resolved the issue.

    Scenario 1 : In this case the client machine is not pingabale from the other machines eventhough SCCM push , RDP everything is working as normal .  starting NlaSvc  and netprofm services make the machine pingable and solved the issue

    Scenario 2: Uninstalling Previous version of App-V 5.0 and then installing the setup.exe without restarting the macihne resulted in above issue .

    • Proposed as answer by znack Tuesday, January 21, 2014 8:39 AM
    Tuesday, January 21, 2014 7:55 AM
  • Hi Guys,

    although it's an old thread, first of all the KB2533623 was superseded a while ago. don't remember which one replaced it but that's the reason why you get the "Not Applicable" error. because you already have the newer one installed, which is totally fine for App-V.

    I have the same problem of Remove-AppVClientPackage : CoCreateInstance() failed.

    it actually happens when I run the command Get-AppVClientPackage -All | Remove-AppVClientPackage and that's after I made sure all the packages are stopped.

    If I restarts App-V Client Service the action can continue but it can happen again ( I have like 40 packages on the client by default on my machines so it can happen after every 10 packages or so)

    I have App-V 5.0 SP3 installed on the client and both of the services NlaSvc  and netprofm are running.

    any ideas what else I can do ? :/

    thanks


    Tamir Levy

    Sunday, July 19, 2015 6:34 AM