locked
Processor swap = Vista insanity. RRS feed

  • Question

  • I built a system in December 2007 entirely on the new AMD Spider platform. Specs as follows:

    Processor: Phenom 9600
    Motherboard: GA-MA790FX-DS5
    RAM: Mushkin HP2-8500 2x1gb (x2) total 4x1gb in system.
    Video Card: Radeon 3870 512mb
    Power Supply: Zalman 500W modular power supply
    Hard Drive: 250GB Seagate SATA 3gb
    Audio Card: Auzentech X-Plosion 5.1
    OS: Windows Vista Ultimate x64

    Initially there were stability issues and the machine was no where near guaranteed stable at gaming or even general use and idle time. Because of this, I had the motherboard replaced almost immediately by NewEgg and received a new retail box. The system continued to exhibit the same exact behaviors. The behavior being a complete lockup of the system with no other recourse but to do a cold boot. No blue screen, no error messages, no logs.

    Some time later in the chain, I determined that a set of the ram was defective and also had that RMA'd to NewEgg and replaced with a new set that then passed the Windows Memory Diagnostics test in full.

    After all of that, the behavior still existed so I called AMD and they decided to RMA the processor. This is where the REAL fun begins.

    A system that, despite stability concerns, was fully functional and booting is now a block of never ending frustration. The only thing that was done to the system at this point is that the Phenom 9600 B2 processor was swapped for another Phenom 9600 B2 processor. The results have been less than pleasing.

    Vista will now only boot when it wants to. That's the only way I can describe it as there is no rhyme or reason as to why it refuses to most of the time. The majority of the time, the OS will continue through the boot cycle until storport.sys and then hang. No hard drive activity, no blue screen, no crash, no screen blank out, no reboot. It just stops. Every once in a while I can get into Safe Mode or Regular mode but nothing I've done creates a reproducible environment. Remove all USB devices. Disconnect all drives. 1 stick of ram, 2, 3, or 4. Single monitor, dual monitors, sound card in or out. Any of those changes does not make the system any more or less bootable. Once the system is bootable it appears to function normally.

    So naturally one would then go back to base and attempt to install from fresh. The system will not boot at all into the installer from the Vista Ultimate DVD. It will load to "Windows is loading setup files" and as soon as the screen switches to the green bar + microsoft corporation lettering, the system just stops. Again, no crash, no blue screen, no reboot, no hard drive activity.

    Ready for the part that really drives me up a wall? Windows XP Professional 32-bit will work just fine with no problems what so ever. I can run off of it all I want and there are no issues.

    I need assistance. I have no idea where to go or what to try next. Almost every component in the system has been replaced. Its not a hardware issue because an OS works fine on it without a problem (XP) but its not a software problem because the Vista DVD won't load on a system in which it previously did.

    I've been in IT for quite some time now and I have never had a problem as infuriating as this. It defies all logical convention and I'm desperately hoping that someone has a "oh, its that setting" fix.

    Desperate,

    -TorchDragon
    Wednesday, March 19, 2008 7:27 PM

Answers

  • Hi TorchDragon,

     

    It seems your scenario met the symptom in KB930261:

     

    You randomly receive a "Stop 0000000xA" error in Storport.sys when you start Windows Vista
    http://support.microsoft.com/kb/930261/en-us

     

    I would like to suggest that you apply the hotfix which is refered in the KB article as a test.

     

    Hope it helps.

    Friday, March 21, 2008 5:49 AM

All replies

  • Hi TorchDragon,

     

    It seems your scenario met the symptom in KB930261:

     

    You randomly receive a "Stop 0000000xA" error in Storport.sys when you start Windows Vista
    http://support.microsoft.com/kb/930261/en-us

     

    I would like to suggest that you apply the hotfix which is refered in the KB article as a test.

     

    Hope it helps.

    Friday, March 21, 2008 5:49 AM
  • Thanks for the suggestion.

    Unfortunately the hotfix doesn't actually cover the problem that I was having nor does it explain why changing the processor would cause any problems.

    For the record,

    There is never a blue screen.
    I'm on the ATI 790FX chipset.
    And the problem occurs with 1, 2, 3, or 4gb of ram.

    I have since gotten a Vista SP1 disk and have been able to boot from that. There are still errors that are happening with the system including random reboots, loss of OS response (though programs continue to run in the background like WinAMP streaming a radio station), and complete system locks.

    I appreciate the assitance though.
    Tuesday, March 25, 2008 11:14 PM
  • Hi,

     

    Considering the KB article have refered to Storport.sys which you mentioned in your description, so I think it worth a try as a test.

     

    Also let's perform a Clean Boot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

     

    1) Run the command: MSCONFIG.EXE.

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Hope it helps.

    Wednesday, March 26, 2008 8:09 AM


  • I wish I could get Vista x64 to install so that I could try this.

    I am having a very similar problem with my system and Vistax64 Ultimate. I practically have the same system as TorchDragon.

    I boot from the installation DVD and "windows is loading files..." completes and the screen is just black - nothing happens. I press delete for the "any key to boot from dvd...." and boot into safe mode. It then hangs on disk.sys

    Core specs:
       AMD Phenom 9600 Agena 2.3GHz Socket AM2+
       MSI K9A2 CF-F AM2+/AM2 AMD 790X ATX AMD - latest BIOS version
       1x2GB Gskill DDR2 8500  F2-8500CL5D-4GBPK
       IAMOND Viper 3870PE4512SB Radeon HD 3870 512MB 256-bit GDDR4 PCI Express 2.0 x16
       Seagate Barracuda ES.2 ST3250310NS 250GB OEM
       CORSAIR CMPSU-620HX ATX12V v2.2
       Vista Ultimate 64 OEM

       no other devices other than various SATA and IDE HDDs and DVD drives

    I have tried several combinations of sata and ide (all sata, all ide, no sata, no ide (no hdd sometimes)) and it still will not boot. I have gone through the bios disabling and enabling about everything and the DVD installation does not get any farther. What irrates me is that the dvd will install on an older system into my newer SATA drive with an Athlon64 3000 ,1gb of ddr 400 in a Soltek mobo. I do the thing MS probably doesn't like you doing and moved HDD with vista installed successfully on it and try to boot up in the new machine - exact same black screen that sits there without the green loading squares. However booting into safe mode gets past disk.sys, loads CLASSPNP.sys and then hangs at crcdisk.sys in that order. Which tells me that the DVD installation hangs while loading CLASSPNP.sys.
    I have a re-installation disk of Vista 32 from my laptop which loads just fine in the new machine.

    Persistent google searching and forum reading is pointing me towards severe incompatibility of the Phenom processor  and Vista 64 but I am still optimistic.

    Let me know and I will create a new thread with my problem if needed. TorchDragon gets priority here.
      


    Sunday, April 6, 2008 2:16 AM
  • Hi,

     

    I would like to suggest that you try the following methods as a test:

     

    1. Remove unnecessary hardware devices such as sound card, printer, TV card and network card from the system. Unplug and re-plug the USB mouse and keyboard.

     

    2. Install with one RAM only.

     

    3. If possible, format the hard drive then try to reinstall again.

     

    Hope it helps.

     

    By the way, your issue is a little different with the orginal poster. We'd recommend that you start up a new thread for it. We generally focus on one topic in one thread because in this way it will be better for other community members to participate in the discussion, and to search/find specific answers more efficiently in the future.

     

     

    Monday, April 7, 2008 8:27 AM
  • I am having the same problem (I think). I have a 2 month old system:

    Gigabyte GA-78MA78GM-S2H (1.0)
    AMD 4850e
    4GB Ballistix DDR2 800
    RAID1 2x750GB SAMSUNG
    Vista Home Premium

    I had my system up and running for about 2 months when one day I came upon a black screen. Unable to CtrlAltDel I rebooted. Since then I've tried to boot in Safe Mode and it hangs at the Storport.sys driver install...it then reboots. Trying to boot off the Install DVD I get through the loading files stage and then to the WIndows logo with green progress bar and then to either a blue screen or a sometimes a blue screen with a pointer (that I can move with the mouse) or sometimes just a black screen. Nothing ever happens from here. I am not given any repair or install options. I randomly got it in once by trying Start Windows Normally once and everything worked perfectly fine from Windows. Again today I came back to a computer that won't let me in. Why can't I get in from the install DVD?
    Sunday, June 22, 2008 2:26 AM
  • I had the same problem.

    Processor: AMD X2 6400+ (3,2 GHz , 14x200MHz)
    Motherboard: GA-MA78G-DS3H
    RAM: 2x GeIL DDR-800 2 GB (Total 4 GB)
    Video Card: Nvidida GeForce 880 GTS (320 MB)
    Power Supply: Zalman 500W modular power supply
    Hard Drives:
    1000GB Samsung HD103UJ (SATA)
    250GB Samsung SP2504C (SATA)
    80 GB Excelstor J880 (IDE)
    OS: Windows Vista Business x64

    A manual reducing of CPU-Takt per multiplier change (to 2,8 GHZ, 12x200 MHz) solved it. The processor had never any temperuture-related problems - neither before, nor after this change.

    I hope, it helps.

    Dmitrij Rodionov
    Thursday, July 9, 2009 7:01 PM