locked
How to disable hardware virtualization? RRS feed

  • Question

  • In VPC 2007 there was an option to disable hardware virtualization, but I can't find it in the Windows 7 version?

     

    I need to disable it as otherwise I can't run a VMWare VM at the same time.

     

    Thanks

    Dave

    Sunday, July 4, 2010 5:55 PM

Answers

  • That was my only idea unfortunately -- if that didn't work I don't think there's a way other than to turn HW Virtualization totally off in your BIOS, that way nothing can use it.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    • Marked as answer by djeyewater Tuesday, July 6, 2010 1:11 PM
    Sunday, July 4, 2010 9:51 PM
  • Hardware virtualisation is a BIOS setting.

    Find and disable it in your BIOS.

    • Marked as answer by djeyewater Tuesday, July 6, 2010 1:11 PM
    Sunday, July 4, 2010 10:00 PM
  • Hi,

     

    Since different motherboards use the different BIOS configurations, Please follow the motherboard guide to disable hardware-assisted virtualization (HAV) in BIOS.

     

    Here is an example of my HP Compaq dc5850 Microtower PC:

     

    1.    Enter into BIOS settings by pressing F10 when starting.

    2.    Navigate to Security\System Security\Virtualization Technology and disable it.

    3.    Press F10 to accept and expand File menu and select Save Changes and Exit.

     

    Hope it can inspire you!

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by djeyewater Tuesday, July 6, 2010 1:11 PM
    Tuesday, July 6, 2010 2:19 AM

All replies

  • Hi,

    This might help, please try

    Typing in search bar   Turn Windows features on or off

    Look for VPC 2007 folder and untick it.


    Please bear in mind, that my answer is based on the details given in your post. The more I get the better the answer, Slan go foill, Paul
    Sunday, July 4, 2010 8:08 PM
  • That wont help at all, it has nothing to do with what he is asking about.  First off he's asking about Windows VPC and secondly, VPC 2007 isn't a Windows feature, and lastly, that's just software, not hardware virtualization.
     
    There's really no easy way to disable hardware virtualization on a VM.  I think you'd need to download the update that allows Windows VPC to run without virtualization, and then just maybe (I've never tried it!) adding or changing this section of the the .vmc file will do it:
     
    <virtual_machines>
      <hw_assist>
       <enable_hw_assist type="boolean">true</enable_hw_assist>
      </hw_ assist>
      </virtual_machines>

     

    Bob Comer - Microsoft MVP Virtual Machine
    Sunday, July 4, 2010 8:26 PM
  • Hi Bob,

    I stand corrected. I did say it might help.

     


    Please bear in mind, that my answer is based on the details given in your post. The more I get the better the answer, Slan go foill, Paul
    Sunday, July 4, 2010 9:21 PM
  • Hi Bob

    Thanks for the advice.

    I added the hw_assist tag to the .vmc file for the virtual machine, so the virtual_machines section looked like this:

    <virtual_machines>
    		<allow_packet_filtering type="boolean">false</allow_packet_filtering>
    		<allow_promiscuous_mode type="boolean">false</allow_promiscuous_mode>
    		<hw_assist>
    			<enable_hw_assist type="boolean">true</enable_hw_assist>
    		</hw_assist>
    	</virtual_machines>

    I tried values of both true and false, but I couldn't start my VMWare VM when the VPC VM was running with either setting (indicating that hardware virtualization was being used whether the tag was set to true or false). I already have the update installed. This was with a VPC VM with no OS installed (so it was just trying to do a network boot), but I don't think that should make any difference as to whether hardware virtualization is used or not.

    Any ideas?

    Thanks

    Dave

    Sunday, July 4, 2010 9:24 PM
  • That was my only idea unfortunately -- if that didn't work I don't think there's a way other than to turn HW Virtualization totally off in your BIOS, that way nothing can use it.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    • Marked as answer by djeyewater Tuesday, July 6, 2010 1:11 PM
    Sunday, July 4, 2010 9:51 PM
  • Sorry for my harsh tone...
     
     
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Sunday, July 4, 2010 9:55 PM
  • Hi,

     

    Since different motherboards use the different BIOS configurations, Please follow the motherboard guide to disable hardware-assisted virtualization (HAV) in BIOS.

     

    Here is an example of my HP Compaq dc5850 Microtower PC:

     

    1.    Enter into BIOS settings by pressing F10 when starting.

    2.    Navigate to Security\System Security\Virtualization Technology and disable it.

    3.    Press F10 to accept and expand File menu and select Save Changes and Exit.

     

    Hope it can inspire you!

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by djeyewater Tuesday, July 6, 2010 1:11 PM
    Tuesday, July 6, 2010 2:19 AM
  • Thanks for the help. I have now disabled it in my BIOS (Asus P5B - the setting was 'Vanderpool technology') and can now run VMWare and VPC at the same time. It's a shame that MS has now decided to force you to turn it off in the BIOS instead of just having the option like they did in VPC 2007.

    Dave

    Tuesday, July 6, 2010 1:10 PM
  • I understand your frustration.  Originally Windows VPC required  hardware virtualization, and when they issued the fix, they didn't include a way to control it by VM like VPC2007 had, I wish they did as it would make it easier to use multiple VM solutions.  (I also use WVPC with VMWare, though intentionally not at the same time)
     
    To be fair though, VMWare doesn't have a way to turn it off by VM either, it uses it if it's there with no option.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Tuesday, July 6, 2010 2:06 PM