none
NCSI taskbar icon may report "no internet" on Windows 10 2004 devices that DO have internet access RRS feed

  • General discussion

  • Symptom:

    Customers are reporting "no internet" access in the Network Connectivity Status Indicator (NCSI) on Windows 10 2004 devices on devices that in fact can ping internet resources or browse web sites with internet browsers. 

    Current situation:

    Microsoft has known about this issue but haven’t resolved it yet.

    It is being investigated by Microsoft currently.



    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Friday, July 17, 2020 6:46 AM

All replies

  • yes... i have the same issue but even more complicated. when i dc my vpn my internet get dc and i need to enable it manually. i reinstall 2004 and 1909 4.5 time with windows update or iso... i updated all my driver to lastest ver ... but my issue only appear on windows 2004... 
    Sunday, July 19, 2020 7:21 AM
  • أواجه المشكلة منذ مدة طويلة و كنت أظن أن المشكلة من شركة الاتصالات و أزعجتهم بكثرة الشكاوى ، لم يخطر ببالي أبدا أن المشكلة من مايكروسوفت . ارجو أن تهتموا بحل المشكلة قريبا أرجوكم و شكرا لخدماتكم 
    Monday, July 20, 2020 12:59 PM
  • This has been going on for many years and I believe it was in 8.X, too.

    I have an HTPC running 1909 Pro where this happens most every day, however, I can reliably get it to happen. My HTPC connects to my network and the internet through an Ethernet adapter.

    Here is the scenario where it happens:

    1. I power down my internet gateway at night say at, say, 23:00 hours via remote connection from my HTPC.

    2. My HTPC is set to hibernate after 30-minutes. After powering down the internet gateway, I then leave the HTPC idle, and let it hibernate.

    2. My HTPC is set to come out of hibernation the following morning at 03:00 hours to reboot; it comes out of hibernation at the scheduled time and ireboots while the internet gateway is powered down.

    3. My HTPC then hibernates again.

    3. My internet gateway is then powered back on at 06:00 hours and left powered on.

    4. At 13:00 hours, I manually bring my HTPC out of hibernation.

    5. I open the Netflix app on the HTPC and it cannot connect.

    6. I look at the network status icon in the system tray and it says "No internet access"

    7. While the network status icon says "no internet access," I then open up Waterfox and can browse the internet, including the Netflix site, to my heart's content.

    As a work-around, I have found that disabling the Ethernet adapter, waiting around a minute or so, then re-enabling the Ethernet adapter seems to force Windows to check internet access and finally discover that it really does have internet access.

    Wednesday, July 22, 2020 4:01 AM
  • I have the same issue but only when I'm connected to my corporate network via the Pulse Secure VPN client.

    When I reset the VPN by choosing Suspend followed by Resume everything is fine again. When I just disconnect the VPN it is fine too.

    Wednesday, July 22, 2020 5:55 AM
  • I have this issue on my work machine only. Full access to all network services except Microsoft Office applications fail to load the O365 log-in pop-up boxes while Windows reports 'no internet'. This means Office apps are useless.

    It occurred occasionally before 2004 update but is all the time now on any non-company domain connection (Ethernet or Wi-Fi). Doesn't occur when on-site at work (work domain).

    Issue also occurs when in Safe Mode with Networking. No issue with personal windows machines.

    Using VPN to connect to company domain remotely also does not resolve.

    Issue is on Surface Book 2 with latest drivers (inc. dock driver).

    Wednesday, July 22, 2020 8:24 AM
  • Been having this problem for a week now.  Started intermittently but is now all the time.  MS Office is unusable.   All other machines on network are fine.  Tried everything found online. from group policy changes, network driver reinstalls (occasionally work) and various registry setting  - short of reinstalling windows, which is not a good option.  Could MSFT just please release a fix or a way to hardwire the status to "Connected" via a registry override please.
    Saturday, July 25, 2020 4:34 AM
  • Same issue here.

    Windows update can't connect

    Report feedback can't connect

    Office won't load

    Interestingly, Adobe Creative Cloud won't download.

    No internet connection reported by Windows despite valid Ethernet line, valid Wifi (tried turning each off in turn).  Chrome works fine.

    Perhaps interestingly, toggling EnableActiveProbing briefly had an effect last night, but now no joy.

    Windows has been messing with me for decades.

    Tuesday, July 28, 2020 12:19 PM
  • I have this issue when I use proxy server and it appeared right after update to 2004. I can browse web sites, windows update also works, but for example Adobe Creative Cloud won't work because no internet connecion... And it is very big problem for me.
    Wednesday, July 29, 2020 3:08 PM
  • had this for a few weeks, post Windows 10 2004, but only became an issue when attempting to run python from the command prompt and being redirected to the Microsoft Store only to be told I don't have an internet connection (when I clearly did/do). Started assuming it was my custom DNS (https://pi-hole.net/) and began whitelisting the domains under Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet in the registry to see if that worked (it didn't) when someone from the pi-hole discourse directed me to this issue.

    This issue is relegated to my wireless connection, Ethernet seems to work fine, was able to access the Windows Store and download the most recent Windows 10 updates.

    Looking forward to a fix, definitely willing to support troubleshooting if asked.

    Sunday, August 2, 2020 5:13 PM