locked
Exchange 2010 SP1 and ProcessExternalMeetingMessages RRS feed

  • Question

  • We have to Exchange Organizations with Exchange 2010 SP1 Rollup 5 installed. We want to share meeting rooms between these two Exchange organizations. Free/busy is set up with the Availability Service and works fine. GAL sync is done with a PowerShell script.

    The meeting rooms have this configuration:

    AutomateProcessing                  : AutoAccept

    AllowConflicts                      : False

    BookingWindowInDays                 : 420

    ScheduleOnlyDuringWorkHours         : False

    ConflictPercentageAllowed           : 0

    MaximumConflictInstances            : 0

    ForwardRequestsToDelegates          : True

    DeleteAttachments                   : True

    DeleteComments                      : True

    RemovePrivateProperty               : True
    MaximumDurationInMinutes            : 0

    AllowRecurringMeetings              : True

    EnforceSchedulingHorizon            : True

    DeleteSubject                       : False

    AddOrganizerToSubject               : False

    DeleteNonCalendarItems              : True

    TentativePendingApproval            : True

    EnableResponseDetails               : True

    OrganizerInfo                       : True

    ResourceDelegates                   : {}

    RequestOutOfPolicy                  : {}

    AllRequestOutOfPolicy               : False

    BookInPolicy                        : {}

    AllBookInPolicy                     : True

    RequestInPolicy                     : {}

    AllRequestInPolicy                  : False

    AddAdditionalResponse               : False

    AdditionalResponse                  :

    RemoveOldMeetingMessages            : True

    AddNewRequestsTentatively           : True

    ProcessExternalMeetingMessages      : True

    RemoveForwardedMeetingNotifications : False

     

    The meeting request from external sender (the other Exchange org) is added to calendar folder as Tentative.

    If the parameter ProcessExternalMeetingMessages is set to true, then the calendar assistant should the process the meeting request and set meeting request status to Busy????

    All my external booked meeting get the status of Tentative in the meeting room calendar and this can result in overbooking of the meeting rooms.

    How can this be solved?


    Morten
    Thursday, October 13, 2011 11:37 AM

Answers

  • Sounds similar problem to whats mentioned here http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/06ff49f0-9b6e-4c24-81f7-01167e0d2c61/ 

    This is waht they did

    1. Create a mail contact in the local org that corresponds to the person in the remote organization who is booking the room.
    2. Create a receive connector in your organization specific to the remote organization. This receive connector needs to be built with the following settings:
      a. On the network tab, the ‘receive mail from remote servers that have these IP addresses’ should contain the IP of the remote exchange server
      b. On the Authentication tab, select TLS (top box only) and Externally Secured
      c. On the permissions tab, select Exchange Servers only.

    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    Thursday, October 13, 2011 12:19 PM
  • Hi Mortop,

     

    Per my Research, this problem occurs due to a known issue in the way Exchange processes meeting invites from external users that cannot be validated as a user in Active Directory (AD). If meeting organizer cannot be located in any context in AD, the meeting invite is processed tentatively and then deleted.

     

    The workaround I found is create a contact in AD and having the contact submit the message via an authenticated connection (configure external secure receive connectors on both orgs).

     

    Now I know you have tried the workaround, could you paste what you have done in detail, that I can help you to troubleshoot for the issue.

     

    When you try to create external secure receive connector, here is a related document for you:

     

    Allowing application servers to relay off Exchange Server 2007

    http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

     

    I also suggest you check whether you have checked “Allow automatic replies” under remote domain.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Friday, October 14, 2011 5:18 AM
    Moderator

All replies

  • Hi,

    Have you set in the outlook resource scheduling to auto-accept & reject the conflict. 

    Thanks, 


    Ripu Daman Mina | MCSE 2003 & MCSA Messaging | MCC
    Thursday, October 13, 2011 11:55 AM
  • The meeting rooms have been set to (set-calendarprocessing):

    AutomateProcessing         : AutoAccept

    AllowConflicts                      : False


    Morten
    Thursday, October 13, 2011 12:16 PM
  • Sounds similar problem to whats mentioned here http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/06ff49f0-9b6e-4c24-81f7-01167e0d2c61/ 

    This is waht they did

    1. Create a mail contact in the local org that corresponds to the person in the remote organization who is booking the room.
    2. Create a receive connector in your organization specific to the remote organization. This receive connector needs to be built with the following settings:
      a. On the network tab, the ‘receive mail from remote servers that have these IP addresses’ should contain the IP of the remote exchange server
      b. On the Authentication tab, select TLS (top box only) and Externally Secured
      c. On the permissions tab, select Exchange Servers only.

    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    Thursday, October 13, 2011 12:19 PM
  • I have tried this, but with the same result.


    Morten
    Thursday, October 13, 2011 12:41 PM
  • Hi Mortop,

     

    Per my Research, this problem occurs due to a known issue in the way Exchange processes meeting invites from external users that cannot be validated as a user in Active Directory (AD). If meeting organizer cannot be located in any context in AD, the meeting invite is processed tentatively and then deleted.

     

    The workaround I found is create a contact in AD and having the contact submit the message via an authenticated connection (configure external secure receive connectors on both orgs).

     

    Now I know you have tried the workaround, could you paste what you have done in detail, that I can help you to troubleshoot for the issue.

     

    When you try to create external secure receive connector, here is a related document for you:

     

    Allowing application servers to relay off Exchange Server 2007

    http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

     

    I also suggest you check whether you have checked “Allow automatic replies” under remote domain.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Friday, October 14, 2011 5:18 AM
    Moderator
  • I also suspected the same but ,I guess he already tried that option as suggest in my previous reply.
    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security | MCP
    Friday, October 14, 2011 5:22 AM
  • First time we tried it, we set up only one receive connector. Now we have set up receive connector in both Exchange Orgs and it works :)

    Now only one thing is missing the receipt for booking the resource.

     


    Morten
    Tuesday, October 18, 2011 7:57 AM
  • Hi Morten,

     

    Do you mean that users (in external) didn’t receive the accepted message form resource mailbox?

     

    If so, did you check the outbox of resource mailbox?

     

    If the resource mailbox has sent the message, you can use message tracking to help you troubleshoot why you didn’t receive the message.

     

    If I misunderstand on you, please feel free to let me know.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Wednesday, October 19, 2011 6:32 AM
    Moderator
  • Hi Morten,

     

    Any updates on this issue?

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Monday, October 24, 2011 1:16 AM
    Moderator