locked
Email time in Message Preview and in the Message top header different RRS feed

  • Question

  • So I can not find a reason why the time for an email is off an hour between the Message Preview ( which has the correct time ) and then the email itself.

    Here is the background.  I am sending the email through a process via SMTP. I have checked the time on that server and the PC that I have outlook installed.

    List of checks that I have done:

    1. Put a Yahoo email as a CC on the email.  Yahoo displays the correct time for the email.  Original one sent to me doesnt.
    2. Put another office365 email as a CC on the email.  That email has the correct time.  Original one sent to me doesnt.
    3. Added a coworker to the email.  His Outllook client shows the incorrect time as well.
    4. Checked to see if all emails in outlook were having the issue.  They were not, just the ones that sent via SMTP from server.
    5. If SMTP server had issues, then all emails should have issues I would think.
    6. Since it is off an hour, I am thinking it must be timezone setting or a bug with it?
    7. I've tried turning off daylight savings time just to be sure it wasn't an issue.

    Is there anything else I can test?  Anyone seen this issue before???

    **  Edit - Windows 10 Enterprise running Outlook 2016 as a part of Office Pro Plus 2016.



    • Moved by Perry-Pan Wednesday, May 1, 2019 5:28 AM
    • Edited by mr_vodka Wednesday, May 1, 2019 1:36 PM Windows 10 Enterprise running Outlook 2016 as a part of Office Pro Plus 2016
    Tuesday, April 30, 2019 8:35 PM

All replies

  • Just tested this out to make sure I was correct. Make sure you set both the computer time zone and outlook time zone. Since I do not know your OS this will be on you. 

    Though since you are in 2016, 2019 forums it would the same. File > options > calendar > time zones > time zone: 

    These are playing conflicts with each other.


    • Edited by PK_colorado Tuesday, April 30, 2019 8:47 PM misspelled
    Tuesday, April 30, 2019 8:46 PM
  • Hi,

    Have you changed time zone information mentioned by PK_colorado? Does it work for you?

    What's your account type? POP or IMAP?

    From the description, error only occurs on your Outlook client. If the steps above don't help, we can run Outlook with \cleanviews switch in case the view for Reading Panel was corrupted.

    To do this, please exit Outlook, press Win key + R to open the Run command, type outlook.exe /cleanviews and then press Enter.

    If you have further questions, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 1, 2019 5:29 AM
  • Just tested this out to make sure I was correct. Make sure you set both the computer time zone and outlook time zone. Since I do not know your OS this will be on you. 

    Though since you are in 2016, 2019 forums it would the same. File > options > calendar > time zones > time zone: 

    These are playing conflicts with each other.


    Hi PK_colorado

    Sorry I neglected to mention this earlier.  I had already checked to see if both the system time zone on my box running Windows 10 Enterprise and the outlook calendar time where the same.  They are both the same.  Just in case, I checked again.  I had even tried changing to set the timezone automatically. 

    Also the Outlook Version is a part of Office Pro Plus 2016.


    • Edited by mr_vodka Wednesday, May 1, 2019 1:19 PM
    Wednesday, May 1, 2019 1:15 PM
  • Hi Perry.

    The account type is Exchange.  I tried what you suggested in cleanview and it still shows the same hour difference.  Also I added someone else within my same office and they are seeing the same issue. He is running the same version of office as I am. 

    So when the email is outside of the office, it is the correct time.  Within the same office, incorrect time in outlook.  This is all on the SAME email.

    Wednesday, May 1, 2019 1:27 PM
  • So it only happens inside the LAN at the office?

    Do you have any other offices? Do they experience issues? 

    Does this happen within office.com? You mentioned this is a O365 user.

    Do you have exchange online?

    When you talked about the server is this the exchange server? 

    Another thought is a GPO but unlikely. 

    Going to think about this a little more and get back to you if something pops into my head before you answer. 

    Wednesday, May 1, 2019 9:07 PM
  • Well that was a quicker thought then expected though about to go home for the day. 

    Office.com > outlook > setting > search "language and time zone" 

    Is it correct here? 

    I believe this is the same as you stated it works outside the office. But just a thought.

    Wednesday, May 1, 2019 9:16 PM
  • >>So when the email is outside of the office, it is the correct time.  Within the same office, incorrect time in outlook.  

    Do you mean this occurs to all outlook clients in the Office?

    Does all received time have one-hour difference? 

    I've noticed that you selected "Adjust for daylight saving time automatically". This is also called as summer time which will adjust one hour later.

    Please uncheck the option to test the result.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Perry-Pan Thursday, May 2, 2019 5:28 AM
    Thursday, May 2, 2019 5:27 AM
  • >>So when the email is outside of the office, it is the correct time.  Within the same office, incorrect time in outlook.  

    Do you mean this occurs to all outlook clients in the Office?

    Does all received time have one-hour difference? 

    I've noticed that you selected "Adjust for daylight saving time automatically". This is also called as summer time which will adjust one hour later.

    Please uncheck the option to test the result.

    Any updates, please feel free to post back.

    Regards,

    Perry

    Already tried as stated in the original post.  Yes everyone who I checked with in the office shows the same incorrect time.


    • Edited by mr_vodka Thursday, May 2, 2019 7:17 AM
    Thursday, May 2, 2019 7:00 AM
  • Well that was a quicker thought then expected though about to go home for the day. 

    Office.com > outlook > setting > search "language and time zone" 

    Is it correct here? 

    I believe this is the same as you stated it works outside the office. But just a thought.

    Yes if I use the online version of outlook, it shows the correct time in both the message preview pane and the message.  The SAME EXACT message in client is incorrect in the message but correct in the preview pane.

    Thursday, May 2, 2019 7:14 AM
  • So it only happens inside the LAN at the office?

    Do you have any other offices? Do they experience issues? 

    Does this happen within office.com? You mentioned this is a O365 user.

    Do you have exchange online?

    When you talked about the server is this the exchange server? 

    Another thought is a GPO but unlikely. 

    Going to think about this a little more and get back to you if something pops into my head before you answer. 

    So there is an application server on the LAN that sends emails out.  That application sends an email to the SMTP server using the protocol.  It is a simple process.  I haven't tried to ask someone from another office or region.  This company is a large corporation with many world wide offices.  I feel like it has to be something with the Outlook client as the emails all show the correct time everywhere else.  If I send it to my yahoo address, or another company with different domain, viewing it online with office web, it all works.  It is just weird as hell that it shows the incorrect time in the client within the email top portion but CORRECT even in the preview pane... So confusing and frustrating.

    Thursday, May 2, 2019 7:25 AM
  • Are you using a VPN at all? I don't think this will do anything but it affected our computers when set up wrong. It seems like you know what you are doing so unlikely.

    I think you did this but the co-worker was on a different computer with the account? 

    Sorry if this is redundant and you already answered. 

    Just if it is just a local issue then something is messing with the settings on a network or server level. This seems to be the case. Though since you checked the SMTP server using the protocol and nothing is wrong there. It can't be a GPO since I looked more into that. 

    Is a DC causing problems? 

    Could a router be causing a problem?

    Just a thought but I am going to look up where else something could effect the time in the SMTP server. I agree this is confusing.

    Thursday, May 2, 2019 2:41 PM
  • Are you using a VPN at all? I don't think this will do anything but it affected our computers when set up wrong. It seems like you know what you are doing so unlikely.

    I think you did this but the co-worker was on a different computer with the account? 

    Sorry if this is redundant and you already answered. 

    Just if it is just a local issue then something is messing with the settings on a network or server level. This seems to be the case. Though since you checked the SMTP server using the protocol and nothing is wrong there. It can't be a GPO since I looked more into that. 

    Is a DC causing problems? 

    Could a router be causing a problem?

    Just a thought but I am going to look up where else something could effect the time in the SMTP server. I agree this is confusing.

    • Not on the VPN when the messages were generated and received.
    • No I had added the co-coworker on the same email and the time was offset on his outlook as well.
    • If it is an issue with the DC, wouldn't all emails being having the issue?
    • Not sure about the router since I do not have access to that

    Thank you for your kindly assistance and patience.

    Friday, May 3, 2019 3:11 PM
  • Hi,

    I've done lots of research these days. Some similar threads reported this could be related with DST. Sorry that I may double confirm with you whether you restart computer after turning off DST. 

    As PK_colorado mentioned the network issue, I’m wondering if we can change the network on one problematic client to see if there are any difference.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Perry-Pan Monday, May 6, 2019 4:51 AM
    Monday, May 6, 2019 4:51 AM