locked
CPU Percentage Utilization comes not into critical state RRS feed

  • Question

  • Hi all

    I try to make my first override concerning the CPU Percentage Utilization.
    I've changed the "Generates Alert" to "True" and I've run a stress test tool, that take cpu to 100%, but the system doesn't comes into critical state and no alert will generated. There are now 5 measure points, that shows cpu on 100%. After the fifth sample it should generate an alert, or do I anything misunderstood? And where could change the number of samples?

    I've got also a problem with the view Processor Performance (Monitoring - Win Server - Performance) - it 
    will actualize just hourly. Can I change this view to actualize more often?

    Thanks for your suggestions.

    Monday, December 7, 2009 12:22 PM

Answers

  • Windows Server 200x Processor object discovery is disabled by default. Check if you see any Windows Server 200x Processors in the Discovered Inventory view.
    http://OpsMgr.ru/
    Wednesday, December 9, 2009 10:28 AM

All replies

  • Hi!

    As you can see in the monitor- description, both criterias - cpu time and queue length too - must be met:
    Monitors the total CPU utilization of this server by correlating the Processor\% Processor Time\_Total and the System\Processor Queue Length performance counters.

    Cheers,
    Patrick
    Monday, December 7, 2009 1:22 PM
  • Hi

    The queue length has just met with the cpu time in the win server 200x. But in the Win Server 200x Processor is the queue length not available. Right?

    Could you tell me where can I read more about queue length?

    Thanks
    kammlu
    Monday, December 7, 2009 3:09 PM
  • kammlu,

    you're right - within the CPU Utilization Monitor targeted to Windows Server 200x Processor the queue length will not be checked!

    So, if the value is above configured threshold (95% default) and longer than 5 samples (default) with a frequency of 120sec (also default) I would expect an alert if override is set to true (default false, as you said right).

    Does the state changes to critical after met all criterias?

    Further, the data for perf.view will be collected with rules, not with monitors. So take a look at the rules Processor % Processor Time 200x targeted on Windows Server 200x Processor and Processor % Processor Time Total 200x targeted on Windows Server 200x Operating System.

    What does the perf.views say?

    Regards,
    Patrick

    Monday, December 7, 2009 3:22 PM
  • Hi Patrick

    Thanks for your suggestions!

    I changed the rule you mentioned above. So the view is actualize more often. Now I'm testing about the alerting, I found a misconfigure again. After correcting this I hope I'll get an alert.

    I'll keep you informed.

    Regards,
    kammlu
    Tuesday, December 8, 2009 9:53 AM
  • Patrick,

    Now the view shows me a critical state, but I get no alert anyway.

    In the monitors is the option 'generate alert' on true, also in the rule. Do I have to change anything else?
    Tuesday, December 8, 2009 1:33 PM
  • when you look at the overrides, the effective configuration for "generate alert" is set to "true"?
    Rob Korving
    http://jama00.wordpress.com/
    Wednesday, December 9, 2009 9:13 AM
  • Yes, it's set to true...

    In the meanwhile I have also set the 'generate alert' to 'true' from the Win OS - Performance, and this one generates an alert. But I also expect an alert from the CPU monitor, and this still doesn't generate one.

    I just change the monitor 'Memory available' and also this one is generating an alert. Aaarg so what have I do wrong with the CPU monitor?
    Wednesday, December 9, 2009 9:37 AM
  • Windows Server 200x Processor object discovery is disabled by default. Check if you see any Windows Server 200x Processors in the Discovered Inventory view.
    http://OpsMgr.ru/
    Wednesday, December 9, 2009 10:28 AM
  • YES! :-)

    The Processor object discovery was really disabled. After enabling it the alerts were generated! Thank you very much!

    Regards
    kammlu
    Wednesday, December 9, 2009 2:10 PM