locked
Cannot book meeting after workhour RRS feed

  • Question

  • Hi all,

    have co-existence environment with Exchange 2010 ( 2 cas server and 2 mailbox server,so total of 4 servers) and Exchange 2013 (2 servers with both cas and mailbox,so total of 2 servers).

    Not sure when problem started,but when try to book meeting after workhours we get error message that we dont have any permission.During workhour it works fine.When book via OWA it works.

    We then moved room mailbox from 2010 (the one that didnt work) to exchange 2013 mailbox,and it works.

    Why do i get error message/cant book after working hour on the old exchange server?

    Have also set work hour start midnight and ends 23.00,but still no help.

    There are no check mark for disabling booking after work hours on the room mailbox.

    Did the following test: Test-OutlookWebServices -ClientAccessServer "CASServer01",but all was successful.arbitration mailbox for 2010 environment is still on 2010 mailbox.

    Our final solution would be to move all room.mailbox to 2013 environment,but would be nice if we could solve this without moving.

    Any tips?

    Thanks!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Monday, February 3, 2014 8:50 PM

Answers

  • Did you also try Calcheck as well?

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    • Marked as answer by Off2work Thursday, February 6, 2014 8:37 AM
    Thursday, February 6, 2014 3:41 AM

All replies

  • Let's check to see if there are any legacy settings that are still set on the room mailboxes.  See this link for an example - http://social.technet.microsoft.com/Forums/exchange/es-ES/107d50a0-0f43-4ed4-a4cc-e9a0219b67b3/you-cannot-schedule-a-meeting-with-resource-name-because-you-do-not-have-the-appropriate?forum=exchangesvrclientslegacy  You want to see if it has any of those setting configured on the mailboxes in Exchange 2010.

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Monday, February 3, 2014 10:13 PM
  • Hi,

    According to your description, meeting can be booked with Outlook and OWA during work hour. And during non-work hour, Outlook cannot book meeting.
    If in this case, to narrow down the cause, I’d like to recommend the following troubleshooting:
    1. Change another Outlook client to have a test and check if it’s caused by the client application.
    2. Check if the issue is related to all room mailboxes.
    3. Check the room mailbox configuration: get-calendarprocessing |fl
    Please especially check the property ScheduleOnlyDuringWorkHours

    Hope it helps.
    Thanks,

     


    Angela Shi
    TechNet Community Support

    Tuesday, February 4, 2014 3:17 PM
  • Hi all thanks for your replies.

    Have now tried it with multiple outlook clients (2010 and 2013) both with latest updates,but same result.

    Have also change workhour so it last from midnight to 23.00. THis is related to all rooms aswell.

    Scheduleonlyworkhours is false.Default permission set on default  user is author on every room mailboxes.

    All room mailboxes are spread over 11 databases over Dagnetwork.

    This happens to every user we tested so far (over 10 users)

    Creating new profile in Outlook 2010 and 2013 did not help.

    Tools->Preferences tab->Calendar Options->Resource Scheduling not selected.

    Regarding legacy settings im not sure what you mean by that,read your forum twice but couldnt find any info regarding that part.

    Might there be some setting on mailbox/cas server side instead of database or room mailbox?

    Thanks so far allmlooking forward for more tips!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, February 5, 2014 6:14 PM
  • By legacy, I mean these settings - Automatically accept meeting requests and process cancellations, Automatically decline conflicting meting requests and Automatically decline recurring meeting requests

    Try the CalCheck tool - https://blogs.technet.com/b/exchange/archive/2012/02/22/calcheck-the-outlook-calendar-checking-tool.aspx and d/l here - http://www.microsoft.com/en-us/download/details.aspx?id=28786.  Make sure to run with the -v switch and dump it to a CSV file.

    Lastly, have you tried to move the resource to Exchange 2013 and then back to 2010 to see if anything resets?  Yes, I realize this is tedious, but it might be worth trying.

    Also, what are the results of 'get-mailbox <room> | get-calendarprocessing |fl' ?


    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Wednesday, February 5, 2014 7:30 PM
  • Not sure whether you tried this once

    Set-CalendarProcessing MailboxName -ScheduleOnlyDuringWorkHours $false

    Wednesday, February 5, 2014 8:30 PM
  • Not sure whether you tried this once

    Set-CalendarProcessing MailboxName -ScheduleOnlyDuringWorkHours $false


    Yes, he already has it set - "Scheduleonlyworkhours is false" from his earlier post.

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Wednesday, February 5, 2014 8:31 PM
  • Hi again JAUCG,

    moved back and forth the room mailbox but still same problem.

    This is what i get when run your command:

    thanks again!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, February 5, 2014 9:44 PM
  • Did you also try Calcheck as well?

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    • Marked as answer by Off2work Thursday, February 6, 2014 8:37 AM
    Thursday, February 6, 2014 3:41 AM
  • Hi JAUCG,

    did run the calcheck now and it only showed my calendar.Testet With switch -a aswell.

    What i saw was that my personal work hour was set to 08-16.

    I changed it to 00.00-23.00 and now im able to book those rooms !

    We never experienced this issue when only using Exchange 2010.

    Can this be a bug or can someone confirm that not only us experiencing this issue?

    thanks,will mark this post as solved.Thanks again JAUCG!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, February 6, 2014 8:36 AM