none
DPM 2012 File server dedup volume backup problem RRS feed

  • Question

  • Hi all,

     

    We have a DPM 2012 R2 server (version: 4.2.1273.0) installed on a Windows Server 2012 Standard (not R2). We try to backup our virtual file server which is also a Windows Server 2012 Standard (not R2).

    This file server has a local C: and D: drive and an E: drive connected from SAN with Windows deduplication turned on.

    We can backup everything on this server (System State, Bare metal, C: and D: drives) except the E: drive.

    The problem is, when we create a protection group and add this server to it, the first replica is successful for all components (even E: drive) but the following synchronizations failing for the deduplicated E: drive. If i run a consistency check, it seems it’s backing up, because ont he Monitoring tab I can see that there is a data transfer. But it always ends up with replica inconsistent.

    I have this alert in DPM console:

    DESCRIPTION:

    The replica of Volume E:\ on FILESERVER.COMPANY.LOCAL is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent.

     

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)

    RECOMMENDED ACTION:

    Review the failure errors for individual files from the log file \\?\Volume{ebad65e7-fcf2-13e4-962d-001ec9ee5638}\e3866ced-d582-263a-a326-a6aabdc8f361\FailedFilesLog.txt and take appropriate action. If some files fail consistently, you can exclude the folders containing these files by modifying the protection group or moving the files to another location.

     

    I’ve tried to access FailedFilesLog.txt but I got „Access Denied” error. I’ve tried to open it by mounting the volume. I was able to browse the System Volume Information, but when I try to navigate into the replica folder the comes the „Access Denied” error message. (I ran command prompt as an administrator)

    Thanks for any help.

    Kind regards,

    Dvijne

    Tuesday, May 19, 2015 8:42 AM

All replies

  • One more thing. In the DPM logs, I see a lot of errors like this:

    04C0    22D4    05/18    19:33:53.453    18    fsutils.cpp(4055)        B7B3AED9-B086-41CA-8A1D-D78A001E79F0    WARNING    Failed: Hr: = [0x80070002] : GetFileAttributes failed for \\?\Volume{ebad65e7-fcf2-13e4-962d-001ec9ee5638}\e3866ced-d582-263a-a326-a6aabdc8f361\Full\System Volume Information\Dedup\ChunkStore\{5C7B17E9-1BA0-4C52-B83C-62C474A15721}.ddp\Stream\00180000.00040000.01.cd

    Tuesday, May 19, 2015 8:57 AM
  • Hi Dvijne,

    Sorry for the delay in reply.

    First let's try to get the file failedfileslog.txt open.

    By default the folder System Volume Information is not available for Administrators group. So you will need to take ownership before accessing files inside.

    The same as its subfolders, if you cannot open it, take ownership first and see if you can get to the file and open it for further information.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 21, 2015 3:27 AM
    Moderator
  • Hi Shaon,

    I'm able to browse System Volume Information folder, but there is a replica folder in the mountd volume, which name is something like: e2343acd255affe4667. And tha FailedFilesLog.txt is in this folder.

    So can I take ownership of this folder safely?

    However when I create a consistency check, I get the following warning message:

    An unexpected error occurred while the job was running. (ID 104 Details: Cannot create a file when that file already exists (0x800700B7))

    I was looking after this error and I found that this could be caused by Sophos, but we don't have Sophos.

    I really don't know what to do now. I have recreated the protection group and deleted the previous replica, but everytime the first recovery point is successful, but after that replica is inconsistent.

    Kind regards,

    Dvijne

    Thursday, May 21, 2015 8:32 AM
  • I just saw that I also have this warning when the scheduled recovery point creations are completed:

    Recovery point for Volume E:\ was created when the replica was inconsistent. Some data from this recovery point may contain partially synchronized data. (ID 30188)

    Thursday, May 21, 2015 10:32 PM
  • Hi,

    Could anyone help me with this?

    Kind regards,

    Dvijne

    Wednesday, May 27, 2015 7:18 AM
  • Hi Dvijne,

    Take ownership of that folder is OK. You can assign ownership back to SYSTEM after finish your job.

    Let's see if any error occursin that file. 


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, June 3, 2015 8:30 AM
    Moderator