locked
Copy of Large Files from Vista to XP Fails RRS feed

  • Question

  • I have a Windows Vista Home PC connected to a Windows XP Professional system by a gigabit switch. When I copy large files from the Vista system to the a share on the XP system they mostly fail. The failures occur at random points in the file. The copy occasionally succeeds. When a fail occurs a dialogue box offers to allow me to try again or cancel.

    Both systems are fully updated. The XP system is running Norton Internet Security 2009. The Vista system uses only the Windows firewall and no Antivirus or Spyware software. I have tried disabling Norton on the XP system, but is makes no difference.

    If I do the copy the other way, i.e. by logging into the XP system and pulling the files from a share on the Vista system, it not only works, but races along - I copied over 9GB in less than 5 mins, so I know there is nothing wrong with the switch.

    Can anyone help?
    Monday, June 22, 2009 7:30 AM

Answers

  • Hi Dave,

    Try this configuration:

    In Local Area Conection Propertiers | Internet Protocol (TCP/IP) | Propertiers

    In Advanced Button | In WINS Tab | ENABLE NETBIOS OVER TCP/IP

    In Options Tab | Select TCP/IP Filtering | In Propertiers Button

    Clear: Enable TCP/IP Filtering (All Adapters)

    Restart computer
    Tuesday, June 23, 2009 12:44 PM

All replies

  • Hi "DaveWatts",


    start | control panel | Program and features | Turn Windows features on or off

    Clear:  "Remote Differential Compression"

    Restart computer
    Monday, June 22, 2009 3:39 PM
  • Hi Ricardo

    Thanks for the suggestion, however I just tried it and it made no difference.

    Interestingly I just noticed that the error message in the dialogue box actually refers to the source file (on the Vista system). The full message is:

    There is a problem accessing source-file-name

    Make sure you are connected to the network & try again.

    It then shows the source file details, and offers me the choice to try again or cancel.

    In this case, the source file was on a second partition (D:) of the same physical disk on the Vista system. For good measure I tried a couple more tests:

    - Copied 9 1GB files from the D: partition to the C: partition - No problem.
    - Tried copying one of the files to the XP system (over the network, Remote Differential Compression still off) - Failed with the same error as usual.

    Are there any receive buffers on the XP system that I should increase in size?

    Dave.
    Tuesday, June 23, 2009 1:38 AM
  • A few more test results after connecting a laptop PC running Vista Ultimate to the same switch.

    - It shows the same problem when copying large files to the same XP system as mentioned above.
    - The laptop and the original Vista system have no problems copying files to each other.
    - Both the laptop and the original Vista system are able to copy large files to a second XP system that is connected to the same switch.

    This all suggests that something needs changing on the first XP system. Perhaps some TCP parameter?

    Dave.
    Tuesday, June 23, 2009 4:50 AM
  • Hi Dave,

    Try this configuration:

    In Local Area Conection Propertiers | Internet Protocol (TCP/IP) | Propertiers

    In Advanced Button | In WINS Tab | ENABLE NETBIOS OVER TCP/IP

    In Options Tab | Select TCP/IP Filtering | In Propertiers Button

    Clear: Enable TCP/IP Filtering (All Adapters)

    Restart computer
    Tuesday, June 23, 2009 12:44 PM
  • Hi Ricardo

    Are you referring to the XP (receiving) system or the Vista (sending) system or both? Should I set a static IP address on each? Using DHCP at present (just lazy).

    Dave.
    Tuesday, June 23, 2009 2:20 PM
  • Try this configuration in Windows Xp.

    Both, with a static IP address.

    The problem persists, apply in Windows Vista too.
    Tuesday, June 23, 2009 3:00 PM
  • Was there ever a solution to this?   I am experiencing the same symptoms between my Vista Home Premium 64-bit machine and my XP machine.   I've tried all of the things listed in this thread and many others culled from various forums and from a Microsoft support engineer - I logged a retail case a few weeks ago and nothing he has had me try has solved the problem.  The key coincidence for me is that my file copying across my wired network was fine until a few weeks ago when Microsoft sent out something like 15 updates at one time.   One of those updates appears to have "broken" my ability to backup large files over the network.
    • Proposed as answer by MilpitasFred Friday, November 6, 2009 5:36 AM
    Friday, October 30, 2009 5:06 AM
  • TCP/IP Filtering is no longer configured in Network settings; this type of control is now exercised by the Windows Firewall.
    Friday, October 30, 2009 8:05 PM
  • The answer, from Bill Yuan, an Escalation Engineer at MS is this: on the Vista machine, at an Administrator's command prompt: netsh interface tcp set global autotuninglevel=disabled

    It seemed to work fine!  Now I can backup my large files successfully! 
    • Proposed as answer by MilpitasFred Friday, November 6, 2009 5:41 AM
    Friday, November 6, 2009 5:41 AM