locked
Enable MAPI for mailbox need to wait 1 day? RRS feed

  • Question

  • Sometimes, if we disable user MAPI function and reenable it, it will take a day to let user open mailbox by outlook

    Any setting can speed up it or our Exchange 2007 have issue? Thx

    Friday, February 17, 2012 3:43 AM

Answers

  • Check your cache settings to see if it's set to something other than 2hrs. Then time it using a test account, I'm sure it will work by 2hrs.

    Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time

    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Marked as answer by Rowen-Xu Monday, March 5, 2012 7:20 AM
    Saturday, February 25, 2012 4:50 PM
  • On Sat, 25 Feb 2012 16:50:12 +0000, Jamestechman wrote:
     
    >
    >
    >Check your cache settings to see if it's set to something other than 2hrs. Then time it using a test account, I'm sure it will work by 2hrs.
    >
    >
    >
    >Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time
    >
    >http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx
     
    Moving the mailbox to a different server or database will also make
    the change effective immediately (or as soon as the move finishes).
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by Rowen-Xu Monday, March 5, 2012 7:20 AM
    Saturday, February 25, 2012 6:29 PM

All replies

  • Hi,

    what about the Active Directory infrastructure? The workstation where a userer authenticates is it in the sasme Active Directory site as the Exchange Servers? If not please have a look at the site replicationconfiguration.


    regards Thomas Paetzold visit my blog on: http://sus42.wordpress.com

    Friday, February 17, 2012 10:00 PM
  • The AD Infrastructure hold on another site. So it need to wait AD Infrastructure  to login MAPI? is that mean if AD Infrastructure  down cannot login MAPI?

    Thanks

    Friday, February 24, 2012 8:17 AM
  •  

    Try the below link out and see if it resolve your problem.

    http://technet.microsoft.com/en-us/library/cc540464(v=exchg.80).aspx

    When you disable user MAPI function and reenable it, at same time check the network connectivity between user pc and exchange server

    Check exchange server performance by monitoring CPU utilization memory utilization

    Try to update exchange server with latest services pack also update outlook with latest patches

    Try to configure user profile on another machine see the performance 

    Check RPC Averaged Latency on Exchange 2007 server

    Girishp

    Friday, February 24, 2012 10:15 AM
  • Those settings are cached, you have to wait (or restart IS store). With 2010 you can refresh the cache per user but not with 2007.

    "As with others mailbox properties stored in the DS, ProtocolSettings are cached in the MBICache (default TTL = 2hrs) and in DSAccess (default TTL = 15 min). These caches may delay the time it takes for a change in the ProtocolSettings to become effective"

    Enabling and disabling MAPI and/or non-Cached access per user in Exchange 2003 SP2

    http://blogs.technet.com/b/exchange/archive/2005/07/27/408274.aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, February 24, 2012 4:09 PM
  • Hi Girish,

    OutLook is SP3

    Hi James,

    I think It takes more than 2 hours?

    Anyway, Thanks a lot

    Saturday, February 25, 2012 2:07 AM
  • Check your cache settings to see if it's set to something other than 2hrs. Then time it using a test account, I'm sure it will work by 2hrs.

    Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time

    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Marked as answer by Rowen-Xu Monday, March 5, 2012 7:20 AM
    Saturday, February 25, 2012 4:50 PM
  • On Sat, 25 Feb 2012 16:50:12 +0000, Jamestechman wrote:
     
    >
    >
    >Check your cache settings to see if it's set to something other than 2hrs. Then time it using a test account, I'm sure it will work by 2hrs.
    >
    >
    >
    >Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time
    >
    >http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx
     
    Moving the mailbox to a different server or database will also make
    the change effective immediately (or as soon as the move finishes).
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by Rowen-Xu Monday, March 5, 2012 7:20 AM
    Saturday, February 25, 2012 6:29 PM