Send As vs. Send On Behalf with Public Folders RRS feed

  • Question

  • Hi

    We have a mail-enabled public folder with our company e-mail (info@company.com) and some other relevant addresses. I was looking at how I could allow 2 of our users to reply to mails from that public folders with Send As or Send on Behalf permissions.

    I know how Send on Behalf is managed both on users and public folders but I don't have much experience with Send As on Public Folders, so I tried it out :-)
    I select "Manage Send As Permission..." in the PB Management Console and add the relevant users, but I still can't send a mail From the Public Folder directly from the users mailbox, shouldn't that be possible?

    Hopefully someone can explain it :-)


    • Edited by LasseF Friday, November 4, 2011 10:09 AM
    Friday, November 4, 2011 10:08 AM


All replies

  • How long did you wait? Exchange permissions cache, therefore setting a permission and attempting to use it immediately will usually fail.
    What you did was correct - granting a user Send As permissions will allow you to send email as the public folder address. You just need to be patient.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    • Marked as answer by LasseF Monday, November 7, 2011 8:57 AM
    Saturday, November 5, 2011 1:42 AM
  • Hi
    Long story short: Send On Behalf says who sent the e-mail and on behalf of whom it was done. Send As looks like e-mail sent by that person or object and there is no information about the real sender.

    Since mail-enabled public folders are used for communication between a requestor and group of people (technicians, service desk, etc), Send As is a better approach if we need to reply to the e-mail came into public folder

      You can read these KB about your issue and check your step.
    How to Grant the Send As Permission for a Mail-Enabled Public Folder

    Users Cannot Send Messages as a Public Folder After You Grant "Send As" Permissions

    How to Send as a Public Folder

    • Marked as answer by LasseF Monday, November 7, 2011 8:57 AM
    Monday, November 7, 2011 2:38 AM
  • I know that it might take several minutes to sync the change I made, and my problem might be caused by my impatience, but felt I waited long enough :-)
    At least I waited around the same when I change the Send on Behaft, and it worked.

    Monday, November 7, 2011 8:58 AM