none
DPM 2010 not applying Tlogs after SQL recovery point creation RRS feed

  • Question

  • Dear all,

     

    I'm new with DPM and I was traying to free space on sharepoint tlog by creating a recovery point but I realice that Tlog was not comited to the Database and finally I have the tlog with same space at befoure the backup. Should I live the tlog to the 3GB as it is now? or should I run a tlog backup rutine on SQL management studio to apply transaction and free space? I'm trying to fine tune SQL and sharepoint to speed it up.

    Thanks in advance !!!

    Friday, September 16, 2011 4:25 PM

Answers

  • Hi Elsaxo,

     

    DPM 2010 does clear the SQL transaction logs after backup. Are your SQL databases in full or simple recovery mode? Here is a blog post with more information on DPM 2010 clearing the SQL transaction logs: http://www.ms4u.info/2011/01/does-dpm-clear-transaction-log-when.html. Follow that to make sure you are setup correctly. 

     

    If you need to here are steps for manually clearing out the transaction log:

     

    ·         Right click on db name, click properties, click options, change from full recovery model to simple recovery model

    ·         Open new query window and type in: DBCC SHRINKFILE (DATABASENAME, 300) where 300 is the new size

    ·         Right click on db name, click properties, click options, change from simple to full recovery model.

     

    That should help.

     

     


    My Blog | www.buchatech.com | www.dpm2010.com
    • Proposed as answer by BuchatechMVP, Moderator Friday, September 16, 2011 9:21 PM
    • Marked as answer by elsaxo Saturday, September 24, 2011 2:33 PM
    Friday, September 16, 2011 9:20 PM
    Moderator

All replies

  • Hi Elsaxo,

     

    DPM 2010 does clear the SQL transaction logs after backup. Are your SQL databases in full or simple recovery mode? Here is a blog post with more information on DPM 2010 clearing the SQL transaction logs: http://www.ms4u.info/2011/01/does-dpm-clear-transaction-log-when.html. Follow that to make sure you are setup correctly. 

     

    If you need to here are steps for manually clearing out the transaction log:

     

    ·         Right click on db name, click properties, click options, change from full recovery model to simple recovery model

    ·         Open new query window and type in: DBCC SHRINKFILE (DATABASENAME, 300) where 300 is the new size

    ·         Right click on db name, click properties, click options, change from simple to full recovery model.

     

    That should help.

     

     


    My Blog | www.buchatech.com | www.dpm2010.com
    • Proposed as answer by BuchatechMVP, Moderator Friday, September 16, 2011 9:21 PM
    • Marked as answer by elsaxo Saturday, September 24, 2011 2:33 PM
    Friday, September 16, 2011 9:20 PM
    Moderator
  • You was right, I was missinn the shrink part.

    Thanks again !

    Saturday, September 24, 2011 2:33 PM