Cluster Shared Volume Permissions Broken


  • Hi all,

    Came into work this morning to find the VM's on one of our CSVs had all failed in our 2008 R2 cluster. The CSV was showing as being online but was not available at C:\ClusterStorage\volumes so I tried to take if offline but received a message that I was unable to stop the volume as a backup was in progress. We use DPM 2012 for our backing up and there was no backup happening.

    After looking around online, I read of a similar issue caused by Backup Exec and they suggesting running the powershell commandlet Test-ClusterResourceFailure "Volume". This caused the volume to go into a failed state, which in turn allowed me to bring the CSV back online. Now the directory is available at C:\ClusterStorage\volume, but the NTFS permission structure has broken on the directory C:\ClusterStorage\Volume and I get an access denied error when trying to browse to the folder and the VMs dependant on the volume still wont start.

    I have tried to manually rebuild the permissions by comparing it to our other CSVs without any luck. Also oddly, I can access the directory by using DOS so I have manually copied a few of the VHDs that I was concerned about losing.

    I also removed it as a resource and re-added it hoping it would rebuild the permissions, but it did not.

    I'd rather not blow the volume away and rebuild it if it can be avoided. We are weeks away from going to new hardware and hyper-v 2012 so even bandaid fixes are welcomed.

    Any idea's greatly appreciated!


    Monday, September 30, 2013 3:05 AM


  • Run this from an Admin Command Prompt:

    icacls C:\ClusterStorage\Volume1 /save c:\acls.txt


    edit c:\acls.txt and change first line from "Volume1" to the volume you have issue with and save


    icacls c:\ClusterStorage\ /restore c:\acls.txt

    This will reset the permissions as per the other shared volumes and you will be able to access the folder structure again!


    Monday, September 30, 2013 4:41 AM