none
DPM 2012 sp1 restore issue RRS feed

  • Question

  • Here is my error

    The recovery jobs for Volume E:\ that started at Friday, May 3, 2013 9:32:14 AM, with the destination of DPM0.abc.forest.org, have completed. Most or all jobs failed to recover the requested data. (ID 3111)

    DPM is attempting to backup or restore deduped files, which requires target to be a NTFS volume and deduplication should be disabled for that volume;. (ID 30242 Details: Internal error code: 0x80990AD2)

    I might be nitpicking here but... My volume is NTFS and it says deduplication "should" be disabled which indicates that it doesnt have to be.

    Why can i not restore to a location with deduplication turned on? What does it even care my dedupe job should be fully independent of putting data on the drive.

    My biggest grip is i just have not other place to restore this data to. Its about 15TB worth of data and the drive has plenty of space to restore. 

    Friday, May 3, 2013 2:42 PM

Answers

  • HI,

    It sounds like you are attempting to restore the entire deduped volume, and not just a selected set of folders.  Under that condition, we're wanting to restore the entire volume in an optimized state, meaning the files will be in a deduped state after recovery.  For that to happen, you must either restore to another volume that has dedupe disabled, or reformat the original volume and disable dedupe on that volume before recovery is attempted..

    Alternately, you can restore by mult-selecting all the subfolders under the root and restore them in an un-optimized state.

    Please see this new blog on the subject.

    SC 2012 SP1 – DPM: Efficient Protection of Windows 2012 Dedup Volume
    http://blogs.technet.com/b/dpm/archive/2013/04/29/sc-2012-sp1-dpm-efficient-protection-of-windows-2012-dedup-volume.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.



    Friday, May 3, 2013 6:45 PM
    Moderator

All replies

  • HI,

    It sounds like you are attempting to restore the entire deduped volume, and not just a selected set of folders.  Under that condition, we're wanting to restore the entire volume in an optimized state, meaning the files will be in a deduped state after recovery.  For that to happen, you must either restore to another volume that has dedupe disabled, or reformat the original volume and disable dedupe on that volume before recovery is attempted..

    Alternately, you can restore by mult-selecting all the subfolders under the root and restore them in an un-optimized state.

    Please see this new blog on the subject.

    SC 2012 SP1 – DPM: Efficient Protection of Windows 2012 Dedup Volume
    http://blogs.technet.com/b/dpm/archive/2013/04/29/sc-2012-sp1-dpm-efficient-protection-of-windows-2012-dedup-volume.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.



    Friday, May 3, 2013 6:45 PM
    Moderator
  • Oh great that will work fine for me.

    Thank you.

    • Edited by JustusIV Monday, May 6, 2013 12:28 PM
    Monday, May 6, 2013 12:28 PM