none
IE11 not saving cookies on exit (Windows 10 1803) RRS feed

  • Question

  • The issue is that if I go to a site that authenticates with SSO I am able to get in without needing to re-enter credentials.  But if I get a link in Outlook and I have signed into SSO but have closed IE, then IE doesn't authenticate me with my already entered credentials and asks me to do it again.  If IE is open and the link will work.

    If I sign into SSO with Chrome, Firefox or Edge and close the browser then click the link it will open successfully in those browsers without requesting a new sign in.  On IE11 this fails.  It worked on build 1709.

    Does anyone know what changed?  Is this something that we can work around?  We still have two products that require IE11 and they are about 1-2 years away from having a non-IE compatible version so I need to extend IE's life a little more.

    Tuesday, September 18, 2018 5:19 PM

Answers

  • Yes.  We had to run the commands below, which we put in a script.

    net stop COMSysApp
    taskkill /F /IM dllhost.exe
    taskkill /F /IM taskhost.exe
    taskkill /F /IM taskhostw.exe
    taskkill /F /IM taskhostex.exe
    del /Q %LocalAppData%\Microsoft\Windows\WebCache\*.*
    net start COMSysApp

    Tuesday, May 7, 2019 7:06 PM

All replies

  • Hi,

    Tools>Internet Options>Advanced tab, uncheck "Empty temporary internet files folder on exit".

    or

    you may be running IE in an InPrivate window (no cookie data is saved or history data is saved while using IE in InPrivate mode.)

    or

    You have not checked options on the login page of a website that offers to "Keep me logged in" or "Remember me"

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Tuesday, September 18, 2018 10:45 PM
  • We don’t delete cookies or temporary files on exit. This is set via group policy. Again this changed with the rollout of build 1803 not group policy. We aren’t running inPrivate Keep me logged in or remember me aren’t available as sso auto authenticates the user when they access the page It also works in every other browser, just not IE
    Tuesday, September 18, 2018 11:38 PM
  • In Private mode does not persist the cookie crumbs. It runs in a sandbox. It does not read the authentication hosts cookie that has the persistent crumb. InPrivate mode (by default) does not use password autocomplete or third party toolbars or bho's. Does the issue disappear if you test in normal mode?

    Do you mean Outlook desktop or online?

    Are the email embedded links to external sites or intranet sites. By default outlook desktop versions open embeded links in emails in the Internet Zone in normal mode IE. Are the email links click-through? eg. https://analytics.google.com/?url=foobar.com/?auth=xxxxxx xxxx

    or

    are they attachment links. What is the mime-type of the attachments?

    IE has security zones, the other web browsers don't.

    All Update versions of IE11 have been critical security updates. You can find out the Version number and Update version number (KB...…) from the Help>About Internet Explorer. Click the Update version number (KB....) to view the KB article that describes the security patches applied.

    https://support.microsoft.com/en-us/help/4457426/cumulative-security-update-for-internet-explorer

    https://portal.msrc.microsoft.com/en-US/security-guidance/

    It could be that your email embed links are to mht or atom feeds. You can still access mht resources from your machine's hard drive using MS Word. Like all other web browsers you mentioned IE now will not open mht files.

    The Other web browsers you mentioned have default mime-type handlers that are different to windows settings. You should use portable versions of chrome and FX for testing purposes or concurrent use on managed networks (see enterprise.google.com). If your current versions have been set to "Always check if xxxxx is the default web browser", they will over-ride the windows/IE settings each time you open them. Configure your other web browsers to not to prompt if they are not the default web browser. On Windows 10 use the Default Programs applet to change your default web browser, or you can click on desktop or .url links and choose a browser from the 'Open With' menu.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^



    Wednesday, September 19, 2018 6:58 PM
  • Hi Daniel, have you ever found the solution, we are having the same issue.

    Thank you
    Jerome

    Tuesday, May 7, 2019 6:30 PM
  • Yes.  We had to run the commands below, which we put in a script.

    net stop COMSysApp
    taskkill /F /IM dllhost.exe
    taskkill /F /IM taskhost.exe
    taskkill /F /IM taskhostw.exe
    taskkill /F /IM taskhostex.exe
    del /Q %LocalAppData%\Microsoft\Windows\WebCache\*.*
    net start COMSysApp

    Tuesday, May 7, 2019 7:06 PM
  • Yes.  We had to run the commands below, which we put in a script.

    net stop COMSysApp
    taskkill /F /IM dllhost.exe
    taskkill /F /IM taskhost.exe
    taskkill /F /IM taskhostw.exe
    taskkill /F /IM taskhostex.exe
    del /Q %LocalAppData%\Microsoft\Windows\WebCache\*.*
    net start COMSysApp

    Thank you!

    I added a deletion of C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache\*.* to avoid the issue on new profile users.

    Jerome


    Tuesday, May 7, 2019 9:14 PM