locked
Field is empty in edit form RRS feed

  • Question

  • Hi All,

    I have add a new Content Type to a list and iterated through all items added values from the old fields (which had created from the old content type) to the new fields (which created when I added the our new content type to the list). I can see in the view and in display item form that the new fields got right values. However when I go to edit an item the some of the fields (dropdown fields) are empty. They don't get their values. They have their options but I am expecting when I edit an item the value of the drop down field was chosen.

    Saturday, October 10, 2015 11:33 AM

Answers

  • Hi,

    How did you iterate through all items added values from the old fields to the new fields?

    The two content types need to have the same site column, then the value of the site column will maintain if you change content type for list items.

    Thanks,

    Dean Wang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, October 12, 2015 8:26 AM

All replies

  • Hi,

    How did you iterate through all items added values from the old fields to the new fields?

    The two content types need to have the same site column, then the value of the site column will maintain if you change content type for list items.

    Thanks,

    Dean Wang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, October 12, 2015 8:26 AM
  • Thanks, 

    The reason was very obvious. The value from the old field was copied to the new field but the choices (options) was missing. When I added the options it solved the problem. 

    Monday, October 12, 2015 11:56 AM
  • Hi Medes,

    Glad to hear your issue is resolved.

    If my reply is helpful to you, you can mark as answer.

    Thanks,

    Dean Wang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, October 12, 2015 12:11 PM