Invisible Sections resetting page numbering unintentionally? RRS feed

  • Question

  • I have a document which has multiple sections, but which is meant to have continuous page numbering (not reset for every section).  
    I understand the philosophy of going through the sections and making sure that each "links to previous" and is "continuous."  I have done so for all the sections I can see.  The footer of every page reads "Footer Section X - Same as Previous" 
    I've also read through the Big Ideas (http://word.mvps.org/FAQs/Numbering/PageNumbering.htm), and through many of the questions/answers posted here.
    Here's an example of the issue which occurs multiple times in the doc:
    Page 24 is correctly displaying "24" and its footer says, "Section 6 - Same as Previous."  
    The following page's footer reads, "Section 9 - Same as Previous," and is numbered page 3. 
    When I go into Draft mode, I can see that page 24 has 3 sections due to a columnar formatting, but each section is set to "Continuous" and has "Different First Page" UNchecked.  However the next page begins anew at page 3.
    And this continues to happen throughout the document, every few pages, resetting to page 3.  I've removed the header/footers, and reinserted the page numbers, made them continous, NOT first pages, updated them and even made sure that there was nothing funky with an ALT F9 (just { PAGE } ).  So I'm stumped.
    The only thing I can say is that I'm working within a group/office scenario, and the document may have had something strange done to it between employees, but we don't have the option of starting over.  I should probably note that we're using Word 2007.
    Any ideas?
    Thank you SO much in advance.
    Tuesday, June 14, 2011 11:04 PM


  • You can use the following macro to quickly set continuous page numbering throughout the active document:

    Sub SetContinuousPageNumberingInDoc()
    Dim s As Section
    For Each s In ActiveDocument.Sections
    s.Headers(wdHeaderFooterPrimary) _
    .PageNumbers.RestartNumberingAtSection = False
    Next s
    End Sub

    For assistance, see http://www.gmayor.com/installing_macro.htm.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Harry Yuan Friday, June 17, 2011 6:39 AM
    Wednesday, June 15, 2011 9:51 AM