none
DPM 2010 - Tape Library Issue - Second Tape spans to 3 tapes. RRS feed

  • Question

  • Dear all,

    Greetings.  I hope someone can be able to assist.

    Scenario :

    • DPM 2010 is configured to backup Exchange 2010
    • A Tape Library consist of 2 drives.  
    • A single protection group consist of MAILBOX1, MAILBOX2 & MAILBOX3
    • After the full backup to disk, the backup to 1st tape is okay.  It tapes only a single tape.
    • However, as for the second tape (which is suppose to be a duplicate of the 1st tape), spans into 3 tapes.  
    • The end result should be only 2 full backup tapes and not span into 3 tapes.

    Thank you.


    Wednesday, June 29, 2011 3:30 AM

Answers

  • Hi,

     

    Yes, we have seen the registry setting fix non-HP devices as well.

    DPM processes an IO error as an end of media, and just graps another tape, so you most likely won't see a failure. 

    To see if you are getting IO errors under the covers, open a command prompt and navigate to the c:\program files\microsoft dpm\dpm\temp folder, then run:

        Find "0x8007045D" msdpm*.errlog

    The goal is to eliminate the errors.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 9, 2011 2:51 PM
    Moderator

All replies

  • Hi,

    Please make the following changes and see if they correct the problem.

    Save the below in notepad then save as BufferQ.REG on the DPM server.
    Right-click BufferQ.REG and choose the "merge" or open with.. registry editor option.


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
    "BufferQueueSize"=dword:00000002

     


    The fix that has worked for other customers (regardless of the tape drive menufacturer) in the past is to add the BusyRetryCount DWord to the Storport key for the Tape device. In your case do both tape devices.

    HP SUPPORT ARTICLE
    =================

    http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=254838&prodTypeId=12169&prodSeriesId=254838&objectID=c01655150

    Note: (The Storport key does not exist by default)

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\SCSI\<DEVICEID>\<INSTANCE>\DeviceParameters\Storport\
    Value - BusyRetryCount
    Type - DWORD
    Data - 20 Decimal (default) <---- Change to 250dec (0XFA)

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 29, 2011 10:57 AM
    Moderator
  • Dear Mike,

    Greetings.  Thank you very much for the reply.  

    The user is having IBM Tape Library with 2 drives.  Does the second portion apply ?

     

    Thank you,

    Bernard.

    Tuesday, August 9, 2011 7:51 AM
  • Hi,

     

    Yes, we have seen the registry setting fix non-HP devices as well.

    DPM processes an IO error as an end of media, and just graps another tape, so you most likely won't see a failure. 

    To see if you are getting IO errors under the covers, open a command prompt and navigate to the c:\program files\microsoft dpm\dpm\temp folder, then run:

        Find "0x8007045D" msdpm*.errlog

    The goal is to eliminate the errors.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 9, 2011 2:51 PM
    Moderator