locked
Can you get DelegateSentItemsStyle to work in Outlook 2010? RRS feed

  • Question

  • I am testing Outlook 2010 for our organization, and we use shared mailboxes extensively.

    As you might know, there has always been an issue that if you added a second mailbox to a particular exchange server account, and you sent messages using the identity of that second mailbox, the sent items would still end up in your primary mailbox.  Luckily a patch finally came out for 2003 and 2007, so that if you set a registry value, DelegateSentItemsStyle, to 1, the sent items will be deposited into the correct mailbox based on the From address of the message.

    So now I'm using 2010, and put the same registry entry in the HKCU\SW\MS\Office\14.0\Outlook\Preferences key, but when I send a message, they now go back into my own sent items folder... I've taken a step back.

    Now I see references to this working correctly if you use the new 2010 feature to open up multiple mailboxes as separate accounts (I haven't tested this, but sounds nice!!), but a user that gets an existing profile upgraded will still have the additional mailbox added the old way!  Was this functionality removed??

    Joel
    Wednesday, January 27, 2010 8:18 PM

Answers

  • Install this HotFix http://support.microsoft.com/kb/2459115/en-us on Outllok 2010 (This functionality was not implemented in the RTM release version of Outlook 2010)

    and after setting this registry key http://support.microsoft.com/kb/950794/en-us  resolved the issue. The article is for Outlook 2007, so you have to create the entry in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0 instead of 12.0 

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    DWORD: delegatesentitemsstyle
    Value: 1

    • Proposed as answer by fgeo-ch Friday, February 25, 2011 9:07 AM
    • Marked as answer by David Wolters Tuesday, March 8, 2011 4:14 PM
    Wednesday, February 16, 2011 2:26 PM

All replies

  • Is any solution exists?
    http://kf.lj.ru
    Thursday, May 13, 2010 8:02 AM
  • I also share 5 mailboxes.  In outlook 2010, I went into Control Pandel, Mail, email accounts, and added in the mailbox(es) as new accounts. When I go into outlook 2010, the additional mailboxes are there, and items I send from those mailboxes go into the appropriate Sent items.
    Tuesday, August 31, 2010 7:41 PM
  • I also share 5 mailboxes.  In outlook 2010, I went into Control Pandel, Mail, email accounts, and added in the mailbox(es) as new accounts. When I go into outlook 2010, the additional mailboxes are there, and items I send from those mailboxes go into the appropriate Sent items.


    This is a different way of looking at these boxes, but not necessarily the most desirable.  To make things more confusing, they look pretty similar in the interface once they are configured.

    When you open a mailbox as a secondary box, it is not your main box.  If you connect to multiple boxes separately as you describe, they all behave as main boxes.  Specifically, you receive new mail notifications, which is not really desirable for something that may be shared. If there was a way to turn that off by mailbox, it might not be as bad.

    Also, if you have a clients upgrading from previous versions of Outlook, they are going to have the delegate configuration, and the functionality is being changed.  There really shouldn't be a reason that they would need to change this just because they upgraded Outlook, especially if your profile may roam back to a previous version.

    Tuesday, September 21, 2010 1:19 AM
  • As MS registry tweak "DelegateSentItemsStyle" is not working in Outlook 2010, you should use third-party utilities like UniSent, Lucatec Mask etc.

    Regards,

    Victor Ivanidze

     

    Thursday, October 21, 2010 2:17 PM
  • Install this HotFix http://support.microsoft.com/kb/2459115/en-us on Outllok 2010 (This functionality was not implemented in the RTM release version of Outlook 2010)

    and after setting this registry key http://support.microsoft.com/kb/950794/en-us  resolved the issue. The article is for Outlook 2007, so you have to create the entry in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0 instead of 12.0 

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    DWORD: delegatesentitemsstyle
    Value: 1

    • Proposed as answer by fgeo-ch Friday, February 25, 2011 9:07 AM
    • Marked as answer by David Wolters Tuesday, March 8, 2011 4:14 PM
    Wednesday, February 16, 2011 2:26 PM
  • I have the same problem and unfortunately your solution doesn't work. I installed the hotfix on a x64 Windows 7 PC that has Outlook 14.0.5128.5000 (32Bit) installed. Installation runs without any problems. Restarted the machine afterwards but sent items are still not moved to the sent items folder of the connected mailbox.

    I can move items manually to the sent items folder with no problems.

    My customer wants to sent as another user but should not have the permission to delete items from inbox or sent items. I spent many hours on this and couldn't find any solution.

    I tried two approaches.

    1. Giving the permissions on Exchange
      Granting FullAcces with Add-MailboxPermission and then removing the right to delete with Add-MailboxPermission ... -AccessRights DeleteItem -deny. Then opening the postbox as an additional postbox
      This does not work because the DeleteItem permission with the -deny flag does not take precedence over the FullAccess permission
    2. Giving Permissions in Outlook
      Granted AccessRights as mentioned in this article. But then I have the problem that sent items are not moved to the sent items folder of the connected postbox.

    Are there any others approaches? We don't want to use third party solutions...

    Thursday, February 17, 2011 10:19 AM
  • Steps to reproduce.

    1. Create two mailboxes User AAA & User BBB
    2. Create a MAPI profile for User AAA and log on
    3. Give delegate permissions to User BBB and set at least reviewer permission on the Mailbox for UserBBB as well as at least Author permission on Sent Items folder to UserBBB
    4. Create a MAPI profile for user BBB
    5. Log on with User BBB and add User AAA as an additional mailbox
    6. Create a new email message and configure the From field as UserAAA
    7. Send the message
    8. Look in Sent Items folder of User AAA


    Expected Results:
    The message should be in the Sent Items folder of User BBB.

    Thursday, March 3, 2011 1:36 PM
  • After installing the hotfix package for Outlook 2010 http://support.microsoft.com/kb/2459115/en-us and setting the DelegateSentItemsStyle registry value to 1, the functionality is only available when the Exchange account is set to Use Cached Exchange Mode. The DelegateSentItemsStyle registry value has no effect on an Exchange account that is configured in Online mode.

    Tuesday, March 8, 2011 9:40 AM
  • Install this HotFix http://support.microsoft.com/kb/2459115/en-us on Outllok 2010 (This functionality was not implemented in the RTM release version of Outlook 2010)

    and after setting this registry key http://support.microsoft.com/kb/950794/en-us  resolved the issue. The article is for Outlook 2007, so you have to create the entry in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0 instead of 12.0 

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    DWORD: delegatesentitemsstyle
    Value: 1

    This is the answer.  I wasn't sure it would be the fix as the problem isn't mentioned in the description of the hotfix, but another trusted source concurred, and I took the time to confirm the fix in my lab.  

    http://cryptojoe.blogspot.com/2011/03/outlook-2010-shared-mailbox-sent-items.html

    J


    Joseph M. Durnal MCITP: Enterprise Messaging Administrator
    Tuesday, March 8, 2011 1:42 PM
  • Strange thing. I was able to make this work on some of the computers using Vista and Outlook 2010 but not on other computers.

    The hotfix : http://support.microsoft.com/kb/2459115/en-us  prompts that is fails to install. (For some users)

    Also, I just happen to find out that some Outlook 2010 user's registry do not have the HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

    The 14.0 is missing and what I did was I readded it and complete the registry entry.

    Still, does not solve my issue. Please help.

     

    Friday, March 18, 2011 2:34 AM
  • Strange thing. I was able to make this work on some of the computers using Vista and Outlook 2010 but not on other computers.

    The hotfix : http://support.microsoft.com/kb/2459115/en-us  prompts that is fails to install. (For some users)

    Also, I just happen to find out that some Outlook 2010 user's registry do not have the HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

    The 14.0 is missing and what I did was I readded it and complete the registry entry.

    Still, does not solve my issue. Please help.

     


    By the way, we are using Outlook 2010/Windows vista 32bit SP1/
    Thursday, March 24, 2011 6:43 AM
  • Sorry to bother you all, but I think you are all adding additional mailboxes, instead of using the new, and supported (autodiscovering) additional account features. As a lot of people are experencing this problem, i would like to suggest an article I wrote about this. Please read it carefully, and find my mail address in one of the pictures if you have any comments on it. (After testing and aprove, I will add them into the article, referring to you. Have fun, using Outlook 2010 !!!
    http://www.oostdam.info/index.php/sectie-blog/28-office-vragen/278-outlook-2010-sent-items-in-owners-mailbox
    Regards,
    Ben

    www.oostdam.info


    Wednesday, May 18, 2011 6:38 PM
  • I'm not sure that this is true.  We've been using online mode forever with this setting.  I installed the hotfix and we have it essentially working the same in Outlook 2010 as it does in Outlook 2007.

    Unfortunately, when we upgraded the Exchange server to 2010 SP1, it seems that this functionality broke regardless of the version of the client.   We can send messages, but the copy of the message that is supposed to go into the delegate Sent Item folder instead gets stuck in the Outbox.  (It doesn't go into the senders Sent Items folder, either.)

    Joel

    Wednesday, May 18, 2011 7:48 PM
  • We are running 2010 SP1 on the server side, and we have experienced flakiness with the results in testing the "SEND AS" process.  While as an administrator, my results have been inconsistent, I had the previously mentioned HOTFIX and the REGISTRY setting change placed on my machine and another user's system.  The results were the same.  Inconsistent, and almost never for the other user.

    So, like Joel, I would agree that there appears to be something wrong here that Microsoft needs to address.  For up to date environments, this issue does not appear to be addressed.

    Jerry

    Wednesday, August 10, 2011 8:15 PM
  • Could you name a few of these companies?  Since this is supposed to work, it should still be a MS responsibility to resolve the problem.

    Monday, August 15, 2011 6:19 PM
  • Ok, since SP1, there does seem to be a fix, though doesn't appear to come with MS's blessing.

    http://cryptojoe.blogspot.com/2011/03/outlook-2010-shared-mailbox-sent-items.html

     I have found that we need to ensure the other mailbox is added as an additional mailbox in the profile + also Publishing editor for inbox, Sent items.

     


    Until later .... Brett
    Tuesday, August 30, 2011 5:43 AM
  • What we experience with Exchange 2010 SP1 on the backend is more like what Joel is experiencing... strange issues where sometimes the messages will be stuck in the Outbox, and other times when it will go to the Sent Items folder of the profile being used, still other times where it works as desired. This is with the registry change and the hotfix. But we have not yet rolled out Office 2010 SP1, which possibly could provide an appropriate fix. - Jerry
    Tuesday, September 6, 2011 2:19 PM
  • FYI - I didn't see any change using Outlook 2010 SP1.

    Joel

    Tuesday, September 6, 2011 2:22 PM
  • I was able to make it work already.

     

    After installing the hotfix, the registry must be still be set and it is not located on HKEY_Current_User...

     

    It's here:  HKEY_Users\S-1-5-21XXXXXXXXXXXXXXXXXXXXXXXXXXXX\Software\Microsoft\Office\14.0\Outlook\Preferences

    Create: DWORD: delegatesentitemsstyle
    Value: 1

     

    This should fix the issue :) By the way, the shared mailbox must be added correctly : 

     
    1 - Open Outlook, and click File - > Info -> Account Settings
    2 - In the E-mail tab, highlight your account and click Change
    3 - Click More Settings
    4 - Click the Advanced tab, and then click Add
    5 - Write the full name of the shared mailbox you wish to add: "shared mailbox" 
    6- Click OK to save, then Next, then Finish, and Close.

    • Proposed as answer by Joe20_1979 Friday, September 9, 2011 5:23 AM
    • Unproposed as answer by Joel D Kraft Friday, September 9, 2011 12:32 PM
    • Proposed as answer by Joe20_1979 Monday, September 12, 2011 5:09 AM
    • Unproposed as answer by Joel D Kraft Monday, September 12, 2011 11:18 AM
    Friday, September 9, 2011 5:22 AM
  • This above solution works for others?

    Tuesday, October 18, 2011 6:26 AM
  •  Well for us still using Exchange 2003, once SP1 for Office 2010 came out the regular way of the reg hack Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    DWORD: delegatesentitemsstyle
    Value: 1

     Seems to work now, none of the other stuff is required, though as mentioned, you still need proper permissions set on the othe mailbox as you did previously anyways. Now works in Outlook 2003/07/10. I can import the reg hack via script at log on.

     


    Until later .... Brett
    • Edited by Poomba1 Monday, October 24, 2011 1:45 PM
    Tuesday, October 18, 2011 1:41 PM
  •  Works in cached mode. I am doing it.
    Until later .... Brett
    Monday, October 24, 2011 1:45 PM
  •  Well by MS's own KB article, the bottom reads....

    Note This feature only works consistenly in Outlook Cached Mode.

     I would suspect that although it refers to OL2K3 & OL2K7, no reason to not assume the general rule applies in OL2K10SP1.

     

     


    Until later .... Brett
    Tuesday, October 25, 2011 1:46 PM
  • Running into the same issue here.  Although I've gotten the hotfix / reg change combination working elsewhere, I can't get it to work on one machine running Win 7 Pro and Outlook 2010 (14.0.6112.5000).  Both are X64, and running in Cached Exchange Mode.  Any other suggestions?
    Tuesday, January 3, 2012 8:42 PM
  •  Well other htan the obvious, review the permissions (Mailbox visible @ miniumum) + Sent Items Publishing Editor + conirm Send on Behalf is set in AD. Both joined to same domain I assume, if group permissions (via DL) is set, assign individual permissions to those areas above.
    Until later .... Brett
    Tuesday, January 3, 2012 8:54 PM
  • Mailbox is visible, send as functions properly, send on behalf is set, both are on the same domain, but the permissions are done by list rather than individually.  I'll try that.
    Tuesday, January 3, 2012 9:26 PM
  • Same issue - added explicit permissions for the user, rather than doing them via DL, with no change.  Why is this such an ordeal?  This was so easy in 07.
    Tuesday, January 3, 2012 11:05 PM
  •  I'd remove the enforce encryption option from client to server as well, sometimes that adds odd behaviour. Go right down to basics, find a 2010 that is working as it should, then recreate this profile, use the same GC/DNS server, FQDN to server for server setup, if using  RPC over HTTPS, take of the NTLM and go with basic, in advnaced options disable requirment to encrypt the traffic, that as I mentioned above is a new feature in Outlook 2010 and we turn it off mor eoften than not in LAN environments + if on a laptop, you have https to go with anyways, a real annoying feature.
    Until later .... Brett
    Wednesday, January 4, 2012 1:47 AM
  • I did everything on this page and only this work ok so i guess we need to add new mail box as new and it will work. thanks.
    Thursday, February 9, 2012 6:00 PM
  • i have gotten two out of the three working with using cached mode on and  going through the registry ... /outlook/12.0... but once i hit the 12.0 in the registry it stops and i cannot see preferences and it appears that there are a bunch of registry files either missing or invisible. any suggestions on that?
    Wednesday, July 11, 2012 9:05 PM
  •  You mean 14 / not twelve right for 2010 right? Also, you need SP1, so ensure they are all updated to the latest builds of Outlook 2010.

    Until later .... Brett

    Wednesday, July 11, 2012 9:09 PM
  • Worked great thanks!

    Implemented on Windows XP SP3 running Outlook 2010 on Office 365 Exchange

    • Edited by TechRobSay Tuesday, August 28, 2012 11:20 AM
    Tuesday, August 28, 2012 11:19 AM
  • FYI:

    Email remains in the Outbox when you use the DelegateSentItemsStyle registry value

    http://support.microsoft.com/kb/2703723

    (You cannot use DelegateSentItemsStyle in online mode)



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, September 27, 2012 5:20 PM
  •  I know, odd but does anyone do strictly online mode now anyways? We all have multi GB, search indexed mailboxes, if they were all just online we'd be hurting, especially the indexing crawls. Aside from the usual nuances (ie sending a email with a large attachment and then closing beofre it completes), when would there be a real need to not allow cached mode & force online only mode in htis era (I assume someone does has a valid reason)??


    Until later .... Brett

    Thursday, September 27, 2012 7:10 PM
  • Personally I use and advocate cached mode, but I can see some advantages to online mode:

    • Terminal server scenarios
    • users with poorly performing, or limited hard drive space (this becomes a real issue with very large mailboxes)
    • users who perceive cached mode as "slow" (go ahead and laugh, but sometimes perception is reality.  I've done migrations from "other" email systems that users claim were "faster")
    • kiosk machines / or other instances where someone is opening outlook and doesn't want to wait for a full sync)


    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, September 27, 2012 7:35 PM
  •  Good points, odd the old versions of Office you had to use a custom MST file that forced the disablement of Cached Mode in TS, now in Office 2010 & Windows 2008 R2 RDP services, we were caught with it being enabled and now a concern if we have to many Outlook users that use the service, already looking to best throw non roaming RDP profiles to a dump volume to protect the OS volume from all the OST files.


    Until later .... Brett

    Thursday, September 27, 2012 10:18 PM
  • This issue has been resolved with Exchange 2010 SP2 Rollup 4v2.

    Refer to this KB2632409 http://support.microsoft.com/kb/2632409.

    Now it will work of online mode also.

    Please refer to this KB2703723 also http://support.microsoft.com/kb/2703723


    With Regards, M S Ali


    • Edited by MS Ali Wednesday, December 12, 2012 4:10 PM Addition
    Wednesday, December 12, 2012 4:06 PM
  • Hi! Victor,

    Now you don't have to configure the outlook. From the Exchagne Backend we can selected where the message goes. Each Shared Mailbox can be configured with Set-MailboxSentItemsConfiguration and you can choose whether the message go to the senders Sent Items or  to the Sent Items folder of both the sender and shared mailbox.

    This works on the Outlook online mode also. Only thing you need to ensure is that on the outlook client you should disable the DelegateSentItemsStyle by setting it to 0.


    With Regards, M S Ali

    Friday, December 21, 2012 3:32 PM
  • Old post I know, but, do you know if this option is exposed as a checkbox within the 2010 GUI or not?
    Tuesday, October 14, 2014 11:40 AM