none
Exchange 2010 unable to access EMC or EMS

    Question

  • Windows PowerShell Event Log contains the error presented when attempting to access Exchange Management.

    Log Name:      Microsoft-Windows-PowerShell/Operational
    Source:        Microsoft-Windows-PowerShell
    Date:          1/8/2010 3:22:29 PM
    Event ID:      32784
    Task Category: None
    Level:         Error
    Keywords:      PowerShell remoting transport
    User:          domain\user
    Computer:      exchsvr.***.local
    Description:
    Runspace Id: 2801cb15-e2f9-4049-9d32-5a26ad67f49a Pipeline Id: 00000000-0000-0000-0000-000000000000. WSMan reported an error with error code: -2144108120.
     Error message: Connecting to remote server failed with the following error message : The WS-Management service cannot process the request. The system load quota of 1000 requests per 2 seconds has been exceeded. Send future requests at a slower rate or raise the system quota. The next request from this user will not be approved for at least 1795919616 milliseconds. For more information, see the about_Remote_Troubleshooting Help topic.
     StackTrace: <null>
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-PowerShell" Guid="{A0C1853B-5C40-4B15-8766-3CF1C58F985A}" />
        <EventID>32784</EventID>
        <Version>1</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>10</Opcode>
        <Keywords>0x8000000000000008</Keywords>
        <TimeCreated SystemTime="2010-01-08T20:22:29.460074600Z" />
        <EventRecordID>8064</EventRecordID>
        <Correlation ActivityID="{00000100-0000-0001-44C0-65C29E79CA01}" />
        <Execution ProcessID="7832" ThreadID="6488" />
        <Channel>Microsoft-Windows-PowerShell/Operational</Channel>
        <Computer>exchsvr.***.local</Computer>
        <Security UserID="S-1-5-21-74992946-2007069462-960320790-2193" />
      </System>
      <EventData>
        <Data Name="SessionId">2801cb15-e2f9-4049-9d32-5a26ad67f49a</Data>
        <Data Name="PipelineId">00000000-0000-0000-0000-000000000000</Data>
        <Data Name="ErrorCode">-2144108120</Data>
        <Data Name="ErrorMessage">Connecting to remote server failed with the following error message : The WS-Management service cannot process the request. The system load quota of 1000 requests per 2 seconds has been exceeded. Send future requests at a slower rate or raise the system quota. The next request from this user will not be approved for at least 1795919616 milliseconds. For more information, see the about_Remote_Troubleshooting Help topic.</Data>
        <Data Name="StackTrace">&lt;null&gt;</Data>
      </EventData>
    </Event>
    Friday, January 8, 2010 8:42 PM

Answers

  • Hi,

    Similar thread share with you:

    cant open EMC or EMS for exchange 2010 from local machine
    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/1cc17514-44dc-41d9-b319-3232107490c0

    1. make sure IIS WinRM extension is installed
    2. open powershell and run command : WinRM Quickconfig
    3. Open IIS go to Powershell virtual directory and check that SSL in disabled and authentification is set only to Anonymous
    4. Open Windows powershell modules
    5. run Remove-PowershellVirtualDirectory command
    6. run New-PowershellVirtuallirectory command
    7. IISreset

    Regards,
    Xiu
    Monday, January 18, 2010 6:18 AM
    Moderator
  • Can you check and see if the "Default web site" is set to use Host Header and to use the IP address?

    If that is the case, then set the "Default website" to All Unassigned and also remove the Host Header.

    Let us know if this works.
    - Nagesh
    Saturday, January 16, 2010 9:55 PM
  • Hi,
    For access to the tools urgently, please install the 32 bit management tools in a 32 bit machine.

    In regards to the actual issue, can you check and see if the values are present in the registry???

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\Cmdlet\ProvisioningCache.

    Check for the "BulkThresholdCount" value and it should be 5 (Decimal).

    Let me know if it is there. If there is no registry key, then add it.

    Thanks,
    Nagesh
    Thursday, January 14, 2010 9:45 PM

All replies

  • Hi,

    Do you try to open EMC or EMS from remote client computer? Or just want to access from machine which has exchange installed?

    What account do you use to open?

    Please try to use get-roleassignement -roleassigneed user to check if this user has previlige to open EMC or EMS.

    Regards,
    Xiu
    Monday, January 11, 2010 8:34 AM
    Moderator
  • Hi,

    I have the same error, and I'm now locked out of the Exchange administration. I'm trying to connect on the Exchange server directly, through a remote desktop session. I'm using the exchange admiinstration account (which was able to connect to the console previously).

    Any idea ?

    Thanks
    JP
    Tuesday, January 12, 2010 1:58 PM
  • I also got this error today. After rebooting the server I was able to use EMC/EMS again.

    Where can I see where all these requests came from?
    I've looked in the Exchange logs, and also the IIS logs without finding anything remarkable.

    Regards
    Kristoffer
    Tuesday, January 12, 2010 8:31 PM
  • I Also got this error today. It was also fixed by a restart of Windows.
    wefwe
    Tuesday, January 12, 2010 10:19 PM
  • Have you change the Throttling Policy for this logged in user, or changed the default Throttling Policy (Set-ThrottlingPolicy). Specifically have you change the policy for the number of PowerShellMaxCmdlets you can run from $null to 1000 and the PowerShellMaxCmdletTimePeriod from $null to 2.

    If so see http://www.c7solutions.com/blog/2010/01/restrictive-throttling-policies-in.aspx which I posted yesterday on fixing a bad throttling policy by modifying Exchange settings directly in the Configuration partition of the Active Directory.

    Brian
    Brainier
    Thursday, January 14, 2010 11:39 AM
  • The throttling policy has not been changed. For me, I enountered this problem on a vanilla install of Exchange 2010 in a brand new Windows 2008 R2 AD environment.
    wefwe
    Thursday, January 14, 2010 8:45 PM
  • Hi,
    For access to the tools urgently, please install the 32 bit management tools in a 32 bit machine.

    In regards to the actual issue, can you check and see if the values are present in the registry???

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\Cmdlet\ProvisioningCache.

    Check for the "BulkThresholdCount" value and it should be 5 (Decimal).

    Let me know if it is there. If there is no registry key, then add it.

    Thanks,
    Nagesh
    Thursday, January 14, 2010 9:45 PM
  • BulkThresholdCount value exisits and is set to 5 (Decimal).

    Thanks,

    Adin

    wefwe
    Friday, January 15, 2010 4:54 AM
  • BulkThresholdCount is set to 5, and no other settings have been changed.

    Thanks,
    Kristoffer
    Friday, January 15, 2010 4:16 PM
  • Can you check and see if the "Default web site" is set to use Host Header and to use the IP address?

    If that is the case, then set the "Default website" to All Unassigned and also remove the Host Header.

    Let us know if this works.
    - Nagesh
    Saturday, January 16, 2010 9:55 PM
  • Hi,

    Similar thread share with you:

    cant open EMC or EMS for exchange 2010 from local machine
    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/1cc17514-44dc-41d9-b319-3232107490c0

    1. make sure IIS WinRM extension is installed
    2. open powershell and run command : WinRM Quickconfig
    3. Open IIS go to Powershell virtual directory and check that SSL in disabled and authentification is set only to Anonymous
    4. Open Windows powershell modules
    5. run Remove-PowershellVirtualDirectory command
    6. run New-PowershellVirtuallirectory command
    7. IISreset

    Regards,
    Xiu
    Monday, January 18, 2010 6:18 AM
    Moderator
  • I tried running "winrm qucikconfig" in the powershell but that didnt seem to work. However, restarting IIS seemed to fix the problem. For now.

    • Proposed as answer by Earl Marinus Monday, October 22, 2012 5:12 PM
    Wednesday, April 28, 2010 2:53 AM
  • Uninstalling the WinRM Extensions and re-installing them fixed the problem for us.
    Karl
    Friday, June 18, 2010 8:14 PM
  • Running an "iisreset" as administrator from the command line fixed it for me. The only change i had was config a time server on a domain controller, but not sure that realy had anything to do wiith it.  
    • Proposed as answer by roverchips Wednesday, November 16, 2011 1:46 AM
    Tuesday, December 7, 2010 1:41 PM
  • Yep, Good old IISRESET fixed it on my box without step 1-6 being run but very annoying with this supposed 22 Day lockout (!).  Not good program Microsoft.

     

    • Proposed as answer by roverchips Wednesday, November 16, 2011 1:46 AM
    Friday, December 10, 2010 11:49 PM
  • We had the same issue and resetting the WWW service fixed the issue.
    Thursday, January 27, 2011 6:32 PM
  • iisreset did the job
    • Proposed as answer by roverchips Wednesday, November 16, 2011 1:46 AM
    Tuesday, March 22, 2011 6:46 PM
  • iisreset fixed the issue, bella Pacho!
    Monday, April 11, 2011 2:23 PM
  • yep, IISRESET and Exchange console is working again.
    • Proposed as answer by vladakole Wednesday, October 31, 2012 8:52 AM
    Wednesday, May 11, 2011 2:57 PM
  • Yes it worked!! But I have to Execute twice the command i the fisrt time I had receive an error about try to start the services in time fashonily....

     

    IISRESET /NOFORCE (TWICE I HAVE WAITED 1 MIN BETWIN THEM)

    Sunday, July 10, 2011 4:15 PM
  • Hello,

    we have the same Problem on all our Exchange 2010 SP1 UR3v3 (14.1.289.7) machines in testing and production environment.

    The default throttling policy has not been touched.

    A simple iisreset /noforce resolves the problem until the next time.

    Clearly the configuration cannot be faulty if iisreset fixes the problem. Also I find the proposal of recreating the virtual directory to risky.

    Please, there has to be a permanent fix to this issue. We have a large environment and resetting iis all the time is not an option.

    Has anyone tried to set the lockout time to a much lower value?

     

    Best regards,

    Alexander

    • Proposed as answer by DwayneAir Wednesday, April 22, 2015 2:18 PM
    Wednesday, September 21, 2011 8:26 AM
  • Hi,

    We have also seen the same issue as per Nextracom above, Win 2008 R2 SP1 with E2010 SP1 UR3v3.

    Installed and configured two servers part of a DAG Back in July.  Left them to bed in.  Returned today, and both servers could not load EMS or EMC with the "system load quota of 1000 requests per 2 seconds" errors.

    'IISReset /Noforce' indeed resolves the issue, but clearly there is a fundamental problem here that needs a fix?

    Best Regards

    Thursday, September 29, 2011 9:05 AM
  • We had the same problem and just tried an IIS reset as suggested - it worked, thanks! I agree with others that an IISReset is not a proper solution and this issue needs fixing properly.

    If it helps we are also running Win Server 2008 R2 with Exch 2010 SP1 but with update rollup 4-v1. We have yet to install the newer rollup update 4-v2.

    Furthermore my boss kept his remote server session open to the Exchange Management Console overnight. I don't know if this is relevant or not!

    Thursday, September 29, 2011 9:59 AM
  • After a day of research and some heavy thinking, I ran: 

    (From within powershell as admin)

    WinRM Quickconfig

    iisrestart

    And viola, it works.

    Monday, October 10, 2011 2:13 PM
  • Same problem here. My solution:

     

    - kill powershell process
    - reset IIS ( IISRESET )

     

    I can login again.

    • Proposed as answer by vladakole Wednesday, October 31, 2012 8:53 AM
    Tuesday, November 8, 2011 2:20 PM
  • yep, just the IISRESET fixed it for me.  strange one, hadnt seen this before.
    Stew
    Wednesday, November 9, 2011 12:10 AM
  • This error appears to be coming from WS-Man, and the query count might be affected by monitoring tools you have in place such as SCOM.

    Sure, whenever you do an iisreset, that will lower the value, but it's not a permanent fix.  A better option is to lower the frequency of whatever is polling your host, or to increase your query count.

    More information can be found here:

    http://serverfault.com/q/339769/51457 

    Saturday, December 10, 2011 7:33 PM
  • Hi.

     

    A colleague of mine found this - and it works. Solves the problem permanently.

     

    http://www.c7solutions.com/blog/2010/01/restrictive-throttling-policies-in.aspx

    Wednesday, January 4, 2012 10:04 AM
  • Would you have another link for this, as it seems to have expired?

    www.c7solutions.com/blog/2010/01/restrictive-throttling-policies-in.aspx

    Wednesday, February 1, 2012 7:11 PM
  • Would you have another link for this, as it seems to have expired?

    www.c7solutions.com/blog/2010/01/restrictive-throttling-policies-in.aspx

    No, but google does:

    http://webcache.googleusercontent.com/search?q=cache:JBQpCKXNb0oJ:www.c7solutions.com/blog/2010/01/restrictive-throttling-policies-in.aspx+&cd=1&hl=en&ct=clnk&gl=us

    However, this "fix" is if you edited your throttling policy.  I have not and still get this issue.  IISRESET is a workaround, not a fix.  I would love to see a permanent fix to this issue.

    Wednesday, February 8, 2012 7:46 PM
  • Rather than using IISReset as many have suggested - recycle the MSExchangePowerShellAppPool

    Either right click and select Recycle in the IIS manager or ...

    $ServerName = hostname
    $ApplicationPool = [ADSI]"IIS://$ServerName/W3SVC/AppPools/MSExchangePowerShellAppPool"
    $ApplicationPool.psbase.invoke("recycle")

    Monday, February 20, 2012 5:39 AM
  • iis reset /noforce worked for me too!!!!!
    Monday, April 30, 2012 3:15 PM
  • Confirmed - Recycling the worker pool works.
    Monday, April 30, 2012 8:24 PM
  • A quick "IISRESET" on the server resulted in my fix.
    • Proposed as answer by Asif Bhatti Monday, March 18, 2013 1:11 PM
    Monday, May 21, 2012 7:16 AM
  • I forget exactly how I fixed it, but this got me going in the right place.  Just type "winrm" and you will have a new command prompt.

    winrm set winrm/config/winrs @{MaxShellsPerUser="50"}

    or

    Get-WSManInstance -ConnectionURI http://myserver.contoso.com:5985/wsman shell -Enumerate

    Monday, May 21, 2012 10:21 PM
  • Same here.
    Restarting the IIS service (running on Exchange machine) fixed the problem.

    Btw, the server has then become realy slow, so I decided to restart Windows 2008 Server.
    So, imhao, in case you would experience this issue, I really suggest you to reboot the machine (obviously, if you can disconnect all the sessions and put all the services unavailable for a while).
    It is definitely be the best way to quickly solve the problem and "refresh" the system.

    Wednesday, December 12, 2012 9:22 AM
  • This did the trick for me as well!
    • Proposed as answer by Amit Tank Monday, December 22, 2014 2:20 PM
    • Unproposed as answer by Amit Tank Monday, December 22, 2014 2:20 PM
    Wednesday, March 6, 2013 9:15 PM
  • Running an "iisreset" as administrator from the command line fixed it for me. The only change i had was config a time server on a domain controller, but not sure that realy had anything to do wiith it.  

    iisreset in command prompt fixed issue for me. Thank you!
    Tuesday, May 14, 2013 4:06 PM
  • I see plenty of "solutions" offered in this thread to resolve the issue, but no RCA on why this issue is occurring.

    I did see the suggestion that SCOM may affect this, but we do not use this in this particular environment in which I'm seeing this error.

    Could someone from Microsoft or otherwise, offer some possible suggestions as to -why- this error is occurring? What is causing that many requests to come in so quickly? Or, is this just an ISS "glitch".

    In any case, any root cause information would be helpful in taking preventative steps against this error in the future.

    Wednesday, May 15, 2013 3:37 PM
  • 'iisreset' also worked for me, but I still don't know why this quota of 1000 requests per 2 seconds was exceeded. That seems abnormally high for our environment of 100 mailbox users.
    • Edited by SoylentRed Thursday, May 30, 2013 2:13 PM
    Thursday, May 30, 2013 2:13 PM
  • Hi,

    Similar thread share with you:

    cant open EMC or EMS for exchange 2010 from local machine
    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/1cc17514-44dc-41d9-b319-3232107490c0

    1. make sure IIS WinRM extension is installed
    2. open powershell and run command : WinRM Quickconfig
    3. Open IIS go to Powershell virtual directory and check that SSL in disabled and authentification is set only to Anonymous
    4. Open Windows powershell modules
    5. run Remove-PowershellVirtualDirectory command
    6. run New-PowershellVirtuallirectory command
    7. IISreset

    Regards,
    Xiu

    I have been fighting this issue for the last 2 weeks on and off, and I have my own thread open on the same exact issue. I want everyone to know that the above worked for me; very specifically step #3, as I skipped step #2. Somehow the authentication for the powershell directory in 'default web site' had been changed to where only "ASP.NET Impersonation" was set to 'enabled." All other auth methods were disabled. I followed Xiu's recommendation stated here, stopped and restarted the powershell app pool and the EMS and EMC tools work again. Thank you, thank you, thank you!!! Still relevant info in June 2013.
    • Proposed as answer by B0ndoo7 Thursday, June 13, 2013 3:09 PM
    Thursday, June 13, 2013 3:08 PM
  • Hello,

    Had the same issue.

    iisreset from elevated mode in command prompt worked for we. Can someone please help to understand why this error just appear suddenly?

    Thank you all for your contributions.

    Regerads

    Raymond TODO

    Thursday, August 1, 2013 10:52 AM
  • I did some very minor troubleshooting of this, and you will get it working again just by recycling the powershell  application pool, so i would say that is the exact point of the problem. also i note that once i have done that, i get an application event log entry saying that activesync had changed the web.config to change the invalid value of Null to 1000 for the maxnoofitemsmove. this also sounds like its part of the problem. But that's as far as i got, someone else can look into what IIS is up to.

    maybe the cheap solution would involve using the recycle settings on that powerhshell app pool to just schedule a daily recycle or something.

    Thursday, September 5, 2013 6:14 PM
  • Simple iisreset from command line made my day.
    Tuesday, October 15, 2013 8:50 AM
  • Recycling just the powershell app. pool also resolved the issue on my test environment...

    Jason Meyer

    Tuesday, January 21, 2014 6:36 PM
  • I took a look at the IIS gui to see where you were making changes and decided to try an equivilent manual/gui  change, by navigating to the Application Pool "MSExchangePowerShellPool" and selecting "Recycle".

    I then restarted EMC and it initialized correctly.

    I don't know if this is just a 1st time/initialization problem, but perhaps, if the problem recurs, it would help to "Edit the Application Pool" "Recyclying" settings - either to some "regular time interval" or "fixed number of requests".

    Thanks!

    Tom

    Wednesday, February 26, 2014 5:46 PM
  • Just doing an IIsreset worked with no changes. However I'm sure the issue will reoccur without some config change some where.
    • Edited by jeff68 Tuesday, June 10, 2014 4:42 PM
    • Proposed as answer by Zaza Abramov Thursday, August 7, 2014 9:18 AM
    Tuesday, June 10, 2014 4:41 PM
  • Restarting IIS worked for me also...
    Tuesday, September 2, 2014 2:54 PM
  • This worked for me (-;"

    Airport Network Administrator

    Wednesday, April 22, 2015 2:19 PM
  • Thanks, restarting World Wide Web Publishing Service worked for me too
    Monday, May 18, 2015 9:28 AM
  • Log onto the Exchange Server, go to Control Panel, Credential Manager, Windows Vault, Remove All Accounts from Windows Credentials 

    Tuesday, July 28, 2015 5:42 PM
  • that works fine, thank you
    Wednesday, August 26, 2015 1:17 PM
  • IISReset fixed in my setup but I will keep a watch on it.

    Regards, Prabhat Nigam XHG and AD Architect and DR Expert Website: msexchangeguru.com VBC: https://www.mcpvirtualbusinesscard.com/VBCServer/wizkid/card

    Wednesday, September 30, 2015 11:49 PM
  • iisreset did the job
    Tuesday, January 19, 2016 2:14 AM
  • Recycle the powershell app pool if anyone comes across this.
    Monday, August 1, 2016 10:06 PM
  • Open an elevated prompt (as administrator) and execute IISRESET
    Wednesday, December 14, 2016 4:48 AM
  • This worked for me as well
    Tuesday, March 21, 2017 5:40 PM
  • WWW Service restart worked for me too.

    Additional data:

    Couldn't get Connection from my PC with my (Domain admin rights) log on, neither directly on Server with Domain admin log on.

    Server Uptime: 396 Days, Memory freed up with WWW restart approx 2 GB.
    Physical Mem Free before restart approx 100 MB. (12 GB Total)

    For sure no Change in Registry or elsewhere. Can't figure out where the 1000 requests come from, no such Changes in our Domain. Maybe i had 1000 Requests since Server start ;-)

    Is there any possibility to read the value from the "request Counter"? Would be interesting what it Counts and if it is being resetted as supposed.

    Tuesday, August 22, 2017 2:53 PM
  • iisreset did the job
    et moi aussi ;-))
    Friday, July 13, 2018 11:27 AM