locked
SharePoint 2013 workflow elevated permissions RRS feed

  • Question

  • I have made a SharePoint 2013 workflow for a list in which users have read permission only. I want to give the user rights to kick off the workflow through the Custom List Action. But i get this error everytime: "Unfortunately, this site has not been shared with you." How can i solve this? I have already created the workflow using the msdn article(creating a workflow with elevated permissions). But this does not seem to help in my case.
    Wednesday, May 6, 2015 9:13 AM

Answers

  • Hi,

    Based on your description, my understanding is that you want to allow users with read-only access to execute workflows.

    If you look at a workflow's properties you can see there's a checkbox for "Allow this workflow to be manually started by an authenticated user with Edit Item permissions". So obviously users with "edit item permissions" can start a workflow.

    I recommend to use Impersonation Step in SharePoint 2010 workflow platform instead. Impersonation steps run with the permissions of the person who last saved the workflow– typically the workflow template author.

    Refer to the following blog about SharePoint 2010 Impersonation Workflow:

    http://blogs.sharepoint911.com/blogs/jennifer/Lists/Posts/Post.aspx?ID=91 

    http://www.learningsharepoint.com/2010/07/31/impersonation-in-sharepoint-designer-2010-workflow/

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Eric Tao Monday, May 25, 2015 2:35 AM
    • Marked as answer by Eric Tao Wednesday, May 27, 2015 5:35 AM
    Thursday, May 7, 2015 9:39 AM

All replies