locked
Gadgets RRS feed

  • Question

  • I tried to get the gadgets on my Desktop and every time I click add it does nothing. Any fix?
    • Moved by Ronnie VernonMVP Tuesday, January 13, 2009 4:56 AM (Moved from Windows 7 Miscellaneous to Windows 7 User Interface)
    Sunday, January 11, 2009 7:27 AM

Answers

  • I've heard it has to do w/ uac.  Apparently if you set uac to the default setting (notify & dim screen) and reboot gadgets work again.  Haven't had a chance to try it out yet.  Let me know how it goes.
    • Marked as answer by Jaredh_d2012 Sunday, January 11, 2009 8:58 PM
    Sunday, January 11, 2009 9:45 AM
  • I have found a fix that has at least worked for me to have gadgets run w/ UAC turned off.  The direction w/ a link to the original post are below.

     

    Run Gadgets In Windows 7 With Disabled UAC

    The Windows 7 Sidebar and Gadgets do not work correctly if a user disables the User Account Control in Windows 7. There is however an easy way to make the gadgets and sidebar work again without having to replace system files (that was the way suggested in many forums).

    All that needs to be done is to change one value of a parameter in the Windows 7 Registry to make the sidebar and gadgets work even with UAC disabled.

    Open the Windows 7 Registry by pressing [Windows R], typing [regedit] and hitting [enter]. Now navigate to the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Setting and change the value of AllowElevatedProcess to 1.

    Restart the computer or logout and login again to see if the changes work as intended. The Registry setting ensures that the gadgets and the sidebar are working in Windows 7 properly even if UAC is disabled.

     

    http://windows7news.com/2009/01/22/run-gadgets-in-windows-7-with-disabled-uac/

     

    I hope that helps.

    Moderator Edit:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Proposed as answer by Seth [MSFT] Saturday, January 24, 2009 9:42 PM
    • Edited by Alex T Jr Monday, January 26, 2009 8:55 PM Added Registry Warning
    • Marked as answer by Alex T Jr Monday, January 26, 2009 8:56 PM
    Saturday, January 24, 2009 9:42 PM
  • There is a FIX!!!

    If you have Windows 7 Beta installed with UAC disabled you might run into problems while trying to load gadgets onto your desktop.You can enable the UAC in order to use Sidebar.But if you don't wanna turn on that nagging UAC and still love those tiny useful gadgets you can bring them aboard by following these steps:

    * Click on Start button, type regedit in the search box and hit enter.
    * In regedit, go to :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Sidebar\Settings

    * In the right pane,right-click and select DWORD Value from the New menu.
    * If you don't already have the DWORD Value to AllowElevatedProcess, right click & add a new DWORD called "AllowElevatedProcess".  Double-click on it and type 1 in the Value data field.

    Image


    * Close Registry Editor, disable UAC and reboot. The Gadgets should now work.

    Moderator Edit:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Proposed as answer by alan52 Sunday, January 25, 2009 8:56 PM
    • Edited by Alex T Jr Monday, January 26, 2009 8:57 PM Added Registry Edit Notice
    • Marked as answer by Alex T Jr Monday, January 26, 2009 8:58 PM
    Sunday, January 25, 2009 8:23 PM

All replies

  • I've heard it has to do w/ uac.  Apparently if you set uac to the default setting (notify & dim screen) and reboot gadgets work again.  Haven't had a chance to try it out yet.  Let me know how it goes.
    • Marked as answer by Jaredh_d2012 Sunday, January 11, 2009 8:58 PM
    Sunday, January 11, 2009 9:45 AM
  • I have not encountered this issue. Have you tried dragging the gadget to the desktop?
    This is how I got my gadgets before I realised you could right-click and ADD them ;)
    Sunday, January 11, 2009 11:00 AM
  • FYI, UAC is set at the lowest setting on my PC and the desktop gadgets still work.

    Just out if interest, is the Aero desktop working/enabled ?

    Asrock K8NF6P, 1.5GB RAM, 500GB Maxtor SataII ,Asus 1814BLT optical
    Sunday, January 11, 2009 1:28 PM
  • Setting UAC out, I lost my gadgets, setting again on first level, after restart I got them back.

    Sunday, January 11, 2009 3:14 PM
  • Right click on the desktop.  There select View.  In there make sure that the show desktop icons is ON.  If that is unchecked no matter what the UAC setting is at the Gadgets will not show.
    ~Alex T.~Windows Desktop Experience MVP~
    Sunday, January 11, 2009 6:46 PM
  • My gadgets worked when i first installed win7 64 bit.  After changing uac my gadgets wouldn't work no matter what i did.  Putting my uac settings back to the default value and then rebooting fixed the problem and gadgets not work.  So apparently on some systems gadgets don't work under certain uac settings, but on others it does???  I will try putting my uac settings back to none now, restart, and see if they stop working again.  This is odd.  
    Monday, January 12, 2009 12:22 AM
  • For whatever reason my gadgets only can run if my uac settings are set to the default settings.
    Monday, January 12, 2009 12:47 AM
  • Can that be remedied as I like to hide my desktop icons and just have the background. Also, does that impact the functioning of icons on the taskbar and the start menu icons?
    Monday, January 12, 2009 8:53 PM
  • hiding the desktop icons hides all the icons on you desktop and your gadgets.  It does not effect you taskbar or start menu icons.  As far as I know there is no way to hid desktop icons while still showing desktop gadgets.  Your best bet is probably to make a folder on your desktop and put all your current desktop icons in there... I hope that helps.
    Monday, January 12, 2009 11:55 PM
  • thanks I guess I will do that. I just hate clutter Same with the Start Menu- Like making folders to place 'like' programs or unused Clutter, clutter, clutter
    Tuesday, January 13, 2009 2:39 AM
  • slyfoxlp said:

    hiding the desktop icons hides all the icons on you desktop and your gadgets.  It does not effect you taskbar or start menu icons.  As far as I know there is no way to hid desktop icons while still showing desktop gadgets.  Your best bet is probably to make a folder on your desktop and put all your current desktop icons in there... I hope that helps.



    If you look a little more closely, the choice is "Show Desktop Items" in Win7 instead of "Show Desktop Icons" in Vista.  Like lonewolf, I prefer to clear out the clutter by hiding the desktop icons and using the "Desktop" toolbar on the Taskbar.  In Vista, that allowed me to arrange my gadgets any way I wanted and did not need to worry about being able to access the icons.

    Since we know that it can be done, I vote we put it back.  Who's with me??!
    Bill Weimer
    Monday, January 19, 2009 11:18 PM
  • I am with you all the way, I hate the clutter on the desktop, what is the purpose of having a great looking background if you can't see it because of the clutter.  However I do like the idea of useful gadgets.
    Tuesday, January 20, 2009 1:22 AM
  • I turned UAC off and now gadgets don't work at all.

    I right-click desktop and click Gadgets and the HD spins for a second but nothing, no window, no gadgets.
    Tuesday, January 20, 2009 2:45 AM
  • I believe it was determined earlier in the post that UAC must be on for Gadgets to work.  Whether that is a bug or an "undocumented design feature", I haven't heard.
    Bill Weimer
    Tuesday, January 20, 2009 10:04 AM
  • I have found a fix that has at least worked for me to have gadgets run w/ UAC turned off.  The direction w/ a link to the original post are below.

     

    Run Gadgets In Windows 7 With Disabled UAC

    The Windows 7 Sidebar and Gadgets do not work correctly if a user disables the User Account Control in Windows 7. There is however an easy way to make the gadgets and sidebar work again without having to replace system files (that was the way suggested in many forums).

    All that needs to be done is to change one value of a parameter in the Windows 7 Registry to make the sidebar and gadgets work even with UAC disabled.

    Open the Windows 7 Registry by pressing [Windows R], typing [regedit] and hitting [enter]. Now navigate to the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Setting and change the value of AllowElevatedProcess to 1.

    Restart the computer or logout and login again to see if the changes work as intended. The Registry setting ensures that the gadgets and the sidebar are working in Windows 7 properly even if UAC is disabled.

     

    http://windows7news.com/2009/01/22/run-gadgets-in-windows-7-with-disabled-uac/

     

    I hope that helps.

    Moderator Edit:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Proposed as answer by Seth [MSFT] Saturday, January 24, 2009 9:42 PM
    • Edited by Alex T Jr Monday, January 26, 2009 8:55 PM Added Registry Warning
    • Marked as answer by Alex T Jr Monday, January 26, 2009 8:56 PM
    Saturday, January 24, 2009 9:42 PM
  • slyfoxlp said:

    I have found a fix that has at least worked for me to have gadgets run w/ UAC turned off.  The direction w/ a link to the original post are below.

    (some text removed)

    Open the Windows 7 Registry by pressing [Windows R], typing [regedit] and hitting [enter]. Now navigate to the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Setting and change the value of AllowElevatedProcess to 1.

    Restart the computer or logout and login again to see if the changes work as intended. The Registry setting ensures that the gadgets and the sidebar are working in Windows 7 properly even if UAC is disabled.

     I hope that helps.



    so when I go there, I don't have a string called AllowElevatedProcess to change the value of. As hacking the reg is always a bit dicey, I am hoping for a better fix (or clearer instructions given my issue; like is this a string, binary, DWORD or what?). did anyone else get there and find the same lack of string value?

    I am pretty much done adding programs at the moment, so I guess I could allow UAC back on, but this is definately something MS should fix for RC1.

    Sunday, January 25, 2009 8:21 AM
  • I am totally with you Bill, I wish I could just turn off my icons...MS! are you listening?
    Sunday, January 25, 2009 9:06 AM
  • REAustin said:

    I am with you all the way, I hate the clutter on the desktop, what is the purpose of having a great looking background if you can't see it because of the clutter.  However I do like the idea of useful gadgets.


    I have an ugly solution to the icons vs. gadgets problem (at least until MS separates them in the menu):

    Rclick desktop>View>un-check align to grid. >>>Select all icons and drag them off of the screen. To access them, just use the Desktop tool bar (it seems to be the last thing to render at start up). I have a few stray letter bits on the extreme left edge of my desktop, but my picture is basically unaffected.

    If you need them back on the Desktop, just check 'Align to grid' and back they will pop - sort as you please.

    Andy

    Sunday, January 25, 2009 9:42 AM
  • I re-adjusted UAC to the middle position (I had it all the way off) and rebooted.

     

    My gadgets (Weather and Calendar) magically appeared again. Thanks for the tip!
    • Proposed as answer by prs1016 Sunday, January 25, 2009 2:36 PM
    Sunday, January 25, 2009 10:05 AM
  • Hey All, Sorry in advance if I'm not replying correctly, but I've found that I had an issue with my gadgets disappearing after disabling the UAC. Well I followed the instructions from "slyfoxlp" and found I didn't have the "AllowElevatedProcess" as stated by "stonecutter12002" so I went to the original article, found a reply by another user and created the string and now I have my gadgets back with no problems and UAC turned down to the lowest setting. 

    Hope this helps and it would be nice to have this addressed before the final build.

    Sunday, January 25, 2009 2:45 PM
  • There is a FIX!!!

    If you have Windows 7 Beta installed with UAC disabled you might run into problems while trying to load gadgets onto your desktop.You can enable the UAC in order to use Sidebar.But if you don't wanna turn on that nagging UAC and still love those tiny useful gadgets you can bring them aboard by following these steps:

    * Click on Start button, type regedit in the search box and hit enter.
    * In regedit, go to :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Sidebar\Settings

    * In the right pane,right-click and select DWORD Value from the New menu.
    * If you don't already have the DWORD Value to AllowElevatedProcess, right click & add a new DWORD called "AllowElevatedProcess".  Double-click on it and type 1 in the Value data field.

    Image


    * Close Registry Editor, disable UAC and reboot. The Gadgets should now work.

    Moderator Edit:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Proposed as answer by alan52 Sunday, January 25, 2009 8:56 PM
    • Edited by Alex T Jr Monday, January 26, 2009 8:57 PM Added Registry Edit Notice
    • Marked as answer by Alex T Jr Monday, January 26, 2009 8:58 PM
    Sunday, January 25, 2009 8:23 PM
  • Thank you! Had the same problem and your solution worked for me.
    Sunday, January 25, 2009 10:34 PM
  • Glad it helped!! :-)
    Sunday, January 25, 2009 11:28 PM
  • Just want to clarify this registry fix as I don't have that particular value:

    -When I make a new DWORD, I have the option of 32-bit or 64-bit value.  Which?
    -Once I make the new DWORD, and go to add the value of 1, do I make the base Hexadecimal or Decimal?

    I can do trial and error, but this needs to be clear for other users too.
    Monday, January 26, 2009 1:45 AM
  • If you are using 32 bit Windows 7, use 32 bit.  If you have 64 bit Windows, I'd try that first... Hexadecimal or Decimal, 1 is still 1, either will work.  Hopefully my answer is correct... if someone more knowledgeable has a better answer, please speak up and correct me!!
    Monday, January 26, 2009 1:54 AM
  • It's a 32 bit dword value for either version of win7.  After adding this reg key and rebooting gadgets work w/ uac disabled although i am getting some odd visibility behavior w/ the gadgets.  Anyone else getting their gadgets to either hide completely for a while or stay on top of all other windows for a while?
    • Proposed as answer by barth2k Monday, January 26, 2009 8:33 AM
    Monday, January 26, 2009 2:40 AM
  • alan52 said:

    If you are using 32 bit Windows 7, use 32 bit.  If you have 64 bit Windows, I'd try that first... Hexadecimal or Decimal, 1 is still 1, either will work.  Hopefully my answer is correct... if someone more knowledgeable has a better answer, please speak up and correct me!!



    I haven't had that problem at all, although I did have a problem with the weather gadget included with Vista and Windows 7.. it was very buggy... I found a better one that is much more reliable and is much more informative as well.. http://www.greycastle.com/gadgets/weatherman/
    Monday, January 26, 2009 2:49 AM
  • Does Windows have gadgets?

    Saturday, December 1, 2012 3:41 AM