locked
WSUS - Automatic Install and Reboot when a local administrator logs on and off a server? RRS feed

  • Question

  • Good Morning,

    We have an issue whereby some of our servers notify us that they need a reboot when WSUS has installed updates, we click postpone but upon logoff the server restarts itself automatically.  This leads me to believe the following:

    1. The 'Postpone' button only postpones the notification, it does not postpone the install of the update.

    2. When the last local administrator of the server logs off the automatic reboot occurs.

    3. Windows Update installs updates when a local administrator logs on to a server despite the GPO stating to only download the updates and notify the local administrator they are ready to install.

    Please can someone verify that my assumptions are correct?




    • Edited by Swatto Monday, May 8, 2017 9:58 AM
    Monday, May 8, 2017 9:47 AM

All replies

  • Hi,
    According to your description, I would suggest you take a look if you have enabled “No auto-restart with logged on users for scheduled automatic updates installations” policy.
    As far as I know, if you enable this policy, Automatic Updates will not restart a computer automatically during a scheduled installation if a user is logged in to the computer. Instead, Automatic Updates will notify the user to restart the computer.
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Wendy Jiang Friday, May 19, 2017 11:16 AM
    Tuesday, May 9, 2017 3:03 AM
  • Good Morning Wendy,

    Thanks for your reply.  We do have that policy enabled but the problem is when the last administrative user logs off the computer automatically restarts itself, we do not want this as we RDP to servers regularly and then subsequently log off from them causing an automatic reboot.

    Is there any way to stop this?

    Thanks for any further help you can provide.

    Tuesday, May 9, 2017 8:17 AM
  • Hi,
    Maybe, you could have a try to disable that policy, by then, the updates will be installed and computers are rebooted in the period which you have set in the AU settings of group policy.
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Wendy Jiang Friday, May 19, 2017 11:16 AM
    Monday, May 15, 2017 2:32 AM
  • Hi,

    Was your issue resolved? If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions. If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, May 19, 2017 11:17 AM