MMC could not create the snap-in. The snap-in might not have been installed correctly. RRS feed

  • General discussion

  • Whenever I run the Event Viewer, the Task Scheduler, or Windows Firewall with Advanced Security, I receive the ff. error message.

    MMC could not create the snap-in. The snap-in might not have been installed correctly.

    followed by the CLSID.

    Also, some programs that require .NET Framework v2.0.50727 in Framework64 don't run.

    I tried DotNETFx Cleanup to remove and reinstall everything, renamed the machine.config files to .old (and also made a copy of the default configs and used them) for both System32 and SysWOW64, used a new account, and used safe mode and the problems remained.

    I did a repair install and reports no errors. The problems remain.

    I also ran DotNETFx Cleanup tool to remove everything, then let Windows update install the latest .NET Framework with security updates, but no go.

    I re-ran sfc /scannow and it still reported no errors.

    I'd like to do a system recovery but the only system image I have was made yesterday, which means it might contain the same problems.

    I made a system image of the hard drive so that at least all of the data is backed up, but if I can't fix this, I will have to do a clean install, which I'd like to avoid.

    I don't know if this is a good guess, but if sfc /scannow reports no errors, and given a repair install, then there aren't any corrupt files. And given the clean-up tool and Windows Update, then .NET Framework is running correctly. Does this mean that the problem lies with registry settings?

    Wednesday, August 22, 2012 2:39 PM

All replies

  • Hi,

    The very important thing you didn’t mention at the thread is that what’s the edition of your operation system? Windows XP, Windows Server or Windows 7?

    If you get this error message under Windows XP. Please check the issue referring to the methods in the following Knowledge Base article:

    Error message when you try to open some MMC 3.0 snap-ins in a localized version of Windows XP Service Pack 3: "MMC could not create the snap-in. The snap-in might not have been installed correctly."


    if the issue occurred under Windows Server, please check the issue refers to the below link:


    In addition, please take a look at the following link. Also, if you install .NET 3.5 does it correct the issue?http://blogs.technet.com/b/asiasupp/archive/2011/03/11/mmc-could-not-create-the-snap-in-18ea3f92-d6aa-41d9-a205-2023400c8fbb.aspx

    If the issue happened under Windows 7 or Windows Vista, I would like suggest you try the following steps:

    Step 1: To turn on the Microsoft .net Framework, do the following:

    a. Click start-Control Panel > Programs and Features.
    b. Click Turn Windows features on or off.
    c. Now select “Microsoft .net Framework x.x.x"(currently edition). You have to expand each component and check the ones you want.
    d. Restart the computer and check if the issue is fixed.

    Step 2: You may run the system file checker tool once again. It might fix the issue.

    Let us know the error message you got when running the system file checker tool before.

    Check the article http://support.microsoft.com/kb/929833  “How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7”

    Finally, please search if there is a file named “mmc.exe.config”, delete it if it exists

    Your Name

    TechNet Community Support

    Thursday, August 23, 2012 9:22 AM
  • Sorry about that. It's Win 7 HP 64-bit. I tried that and many other options, but nothing worked (even a repair install), so I had no choice but to back up data and do a clean install.

    Monday, January 14, 2013 3:56 PM
  • Hi,

    Sorry for this inconvenience, I hope your issue would be sovled soon.


    TechNet Community Support

    Tuesday, January 15, 2013 5:58 AM