none
Updating Resource Pool 2013 RRS feed

  • Question

  • When opening enterprise resource pool in MSP from PWA there seems to be a limit of 133 records, after this number no data is returned to MS Project

    Mike


    Mike Mahoney

    Wednesday, November 21, 2012 1:19 PM

Answers

  • Hi Mike,

    I do repro with IE 9 at 119 resources - fewer than you because I'm guessing my URL is longer.  It appear that in IE 9 with 119 resources, the request to open Project Professional is greater than 512 characters.  With IE 10 it looks like the same problem occurs at 2048 characters (520 resources for me).

    Chrome also fails at 502 resource.  Chrome was useful to test as it exposes the URL in the message dialog asking if you want to open the application.

    Firefox doesn't give the same behavior - it opens Pro even when 1000+ resources are selected, but only loads around the same limit of 500+.

    Thanks again for bringing this to our attention.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    • Marked as answer by Sleekstone Thursday, January 24, 2013 10:22 AM
    Wednesday, January 23, 2013 7:30 PM
    Owner

All replies

  • Hi Mike - I didn't see this limit.  Does this still repro as an issue for you?

    Best regards,

    Brian Smith


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Friday, January 4, 2013 10:16 PM
    Owner
  • Hi Brian

    Sorry for the delay in getting back to you

    This problem showed itself with Preview version of of project with resources pool created via "Datapump". 

    I have now built a clean environment and used RTM version of project professional. I was able to create 150 resources (R001,2,3) in excel, paste them into project and update resource pool. When I try to re-open to edit in project, PWA responds by showing About:blank page and project does not respond.

    Reduce the selection to 133 records and project happily opens and allows them to be edited and saved.

    rgds

    Mike


    Mike Mahoney

    Tuesday, January 15, 2013 9:00 PM
  • Hi Mike,

    Thanks for getting back to me.  Again I couldn't repro at those levels but I was sure you were seeing something so I pushed the limits a bit.  I added 1000 resources, but couldn't open them again...  Saw slight variation between my on-premise installation of 2013 and the online Preview - but at around 510-520 resources I do see the issue.  It seems to be some payload limit with the call to open Project Professional and probably depends on the exact contents of the resources.

    Also my tests are both with IE10 on Windows 8 and Windows Server 2012 - and x86 and x64 Project appears to respond the same, but perhaps the IE or OS might make a difference.

    I'll do more digging and find out what this limit is.

    Best regards,

    Brian.

    Marking as the answer for now - so others can trust the information - there appears to be a payload limit somewhere behind the Open Project button - if you run into this and just see a dead button then try reducing the number of resources you wish to open.

    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page


    Tuesday, January 15, 2013 11:19 PM
    Owner
  • Hi Brian

    I carried out a little more investigation.

    The problem definitely occurs with IE9 and 32bit Project (not sure about 64bit) with 133 resources. 

    When connecting to the same PWA instance with IE10 Client, 64bit Project, on Server 2012 there is no problem (checked for 150 resources).

    So it seems to me to be an IE9 issue.

    rgds

    Mike


    Mike Mahoney

    Wednesday, January 23, 2013 12:21 PM
  • Thanks Mike - I'll take a look with IE 9, and the other supported browsers.  As I mentioned above it does also hit the same problem with IE 10, but at around 520 resources, and I certainly wasn't doubting that you see the problem at 133 resource.  We are investigating, but I'll probably do a blog post just to bring the issue to peoples attention.

    I thought it added value marking my previous post as the answer by the way - I guess you didn't agree? 

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Wednesday, January 23, 2013 3:46 PM
    Owner
  • Hi Mike,

    I do repro with IE 9 at 119 resources - fewer than you because I'm guessing my URL is longer.  It appear that in IE 9 with 119 resources, the request to open Project Professional is greater than 512 characters.  With IE 10 it looks like the same problem occurs at 2048 characters (520 resources for me).

    Chrome also fails at 502 resource.  Chrome was useful to test as it exposes the URL in the message dialog asking if you want to open the application.

    Firefox doesn't give the same behavior - it opens Pro even when 1000+ resources are selected, but only loads around the same limit of 500+.

    Thanks again for bringing this to our attention.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    • Marked as answer by Sleekstone Thursday, January 24, 2013 10:22 AM
    Wednesday, January 23, 2013 7:30 PM
    Owner