none
Turning off display resizes open windows

    Question

  • This happens through power settings, or manually using the monitor power button. Does not happen if restarting with open windows.
    Something is also turning off the sceen saver from time to time. Happens with corded or wireless mouse. Using corded USB keyboard.
    No problems at all in this area with Vista.
    I have tried every setting I can think of; and have'nt yet found any help through web searches. 


    Gigabyte GA-P35-DS3L Mainboard; NVIDIA Geforce 7600GT Video; Envision G218a1 LCD Monitor
    Windows 7 (clean install); newest compatible BIOS, chipset, video, and audio drivers.
      
    • Edited by DSNBLD Thursday, December 10, 2009 3:59 AM
    Friday, December 04, 2009 9:37 PM

Answers

  • Hi,

     

    According to your feedback, your another monitor works fine with Windows 7. It appears to be a hardware compatibility issue between the LCD monitor and the display card.

     

    I recommend you contact the hardware manufacturer for further assistance.

     

    Good luck!


    Arthur Li - MSFT
    Friday, December 11, 2009 3:05 AM
    Moderator

All replies

  • Hi DSNBLD,

     

    Would you please describe the symptom in detail? Do you mean turn off the monitor the display screen resizes?

     

    I would like to suggest you update the BIOS and the display card driver to check the issue.

     

    Note: The third-party products discussed here are manufactured by companies that are independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.

     

    What’s the result?


    Arthur Li - MSFT
    Wednesday, December 09, 2009 5:25 AM
    Moderator
  • Arthur_Li

    I checked this post occasionally, but did not get an alert when someone did respond.

    When turning of the display/monitor, through power settings, or just manually turning off the monitor, Windows will upon resume resize all open windows to the same size and stack them all in the same spot at the top left of the screen. It does it right out of the box- clean install, before I've touched anything. It does it after I've updated everything. 
    I have systimatically turned off every setting and service that remotely relates to graphics (desktop compostion etc.), including even Aero Peek, Aero Snap- anything I can find. I do not use the Auto-Hide Taskbar. The only time I can get it to stop is to disable the graphics driver directly, or by booting into safe mode. I've run Process Monitor and see re-writing of registry entries, but what could I do to prevent it?
    My screensaver is also sluggish when the computer is locked (only when it's locked), but I don't know for sure if that's related, although I feel it is- indirectly.
    The screensaver getting turned off is unrelated. I finally noticed that whenever I modified my theme the screensaver would get turned off.   

    As you can see in my initial post, everything is already updated. System AND Graphics BIOS are the latest. I've checked and rechecked BIOS settings. I've tried three different versions of the graphics drivers. I uninstall current driver then reboot and install another version from safe mode. I also installed by just letting the driver install without removing the old one first.
    When I installed the NVIDIA driver in Vista with this system, it resized open windows (I had Windows Explorer open) and put them in the top left of the screen- right at the end of the install- But it won't happen again after that. In Win7, it persists.    

    Thanks
    Thursday, December 10, 2009 4:54 AM
  • Hi DSNBLD,

     

    Do you have another monitor to test the issue?

     

    It should be a hardware driver compatibility issue. As you said, it works in Safe Mode or after disabling the graphics driver.

     

    I would like to suggest you uninstall the current installed display card driver and restart Windows 7 twice to check if it will install the Windows 7 built-in driver.

     

    If the Windows 7 built-in driver also cannot fix the issue, you may also try to run Windows Update to update the display card driver to check the issue.

     

    If the issue persists, I recommend you contact NVIDIS Support to develop a new driver as soon as possible to fix this issue.

     

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    Good luck!


    Arthur Li - MSFT
    Thursday, December 10, 2009 8:30 AM
    Moderator
  • I dragged my 1000 pound 19" CRT from the closet and gave it a go. The procees of turning the monitor off then back on behaved as it should- no problems.
    I ran Process Monitor and it showed 153 lines in the process; versus 1113 lines with the LCD monitor.


    LCD is displayed at 1680x1050. Windows are being reduced to 1024x768.
    Friday, December 11, 2009 2:20 AM
  • Hi,

     

    According to your feedback, your another monitor works fine with Windows 7. It appears to be a hardware compatibility issue between the LCD monitor and the display card.

     

    I recommend you contact the hardware manufacturer for further assistance.

     

    Good luck!


    Arthur Li - MSFT
    Friday, December 11, 2009 3:05 AM
    Moderator
  • This happened to me also on a Win7/64 Ultimate Install.  My power settings run the screen saver for 5 minutes, then the monitor shuts off.  My issue is, when I turn the monitor back on via shaking the mouse, all open windows are resized to the upper left corner in about a 1024x768 "boundry".

    The initial hardware was an LG W2453 1920x1080 LCD hooked to an nVidia 9400GT card via HDMI.

    I did DISTINCTLY remember this functioning correctly (open windows did not change size) after the build.  Then, something changed right after I installed an additional 1TB Seagate HDD.  Was it directly related?  I can't say that, but I recall it being a "coincidence".  That makes me think that it IS Windows 7 related!!

    Then I upgraded the video card to an ATI 5570 HD.  I pulled the nVidia drivers, swapped the cards & installed the latest ATI Catalyst drivers.  Same thing....., windows resize to the upper left corner in about a 1024x768 "boundary".

    Then I found this thread & went to Device Manager to see the monitor driver.  It was calling it a "Generic PnP Monitor".  I then go to the LG website & see that they have a Win7 driver, so I download that.  Back in Device Manager, I go to "upgrade driver" & install it.  I've got my finger crossed 'cause this HAS to fix it......., but, SAME THING......., resized windows after it comes out of monitor off!!!

    I then have a flash........, MAYBE it's the HDMI connection?  Fortunately, I have two DVI to HDMI adapters "in stock", so I attach those to the DVI ports on the vid card & the monitor & connect using the HDMI cable.

    BOOM........, that FIXES the ISSUE!!!  Windows unaltered when the monitor comes back on!!!

    Friday, April 23, 2010 3:26 PM
  • I have this exact same problem: after mointor is turned off (manually or by power saving) all windows resize to 1024x768 and position themselves in the top left corner of the screen. Also power saving turns off monitor only for a second, and then the monitor wakes up again. I experience this on DisplayPort, DVI connection doesn't have this issue. (All drivers are up do date, my Win7/64 is up to date too.)

    So it happens with:

    NVIDIA Geforce 7600GT Video and Envision G218a1 LCD Monitor

    nVidia 9400GT and LG W2453 LCD via HDMI (although initially worked fine)

    ATI 5570 HD and LG W2453 LCD via DVI (but not HDMI)

    ATI 5570 HD and HP ZR24w LCD via DisplayPort (but not DVI)

     

    Looks like a Win7 problem after all!

    Thursday, January 06, 2011 9:10 AM
  • I have the same issue.  Win7 64bit.  Windows resize themselves when monitor goes into power down.  This is LG monitor with ATI graphics driving via HDMI port.  My son's PC with Nvidia graphics card does the same.  So this is certainly a windows bug.

    I also find that I must turn on the monitor before I boot windows otherwise windows will not drive the HDMI port but instead only drives the VGA.  If I turn on the monitor after windows starts then the LG monitor comes up with HDMI power saving and nothing will make it work.  I have connected the vga cable to the monitor as well now and I can switch the monitor to vga but even asking the ATI driver to redetect displays does not enable the HMDI.

    I wonder if the 2 are related.  That is windows enables VGA after power save at some default size, then resizes all the windows to fit it, then finally works out that HDMI or a larger monitor is available and resizes the display to the correct size.

    It's a right pain!  So much for 7 being better than XP!

    Sunday, January 09, 2011 7:27 PM
  • Me too, Dell monitor, Intel IGP and started as soon as I switched to a HDMI cable. Real pain, and surprised that no one in Microsoft has picked this up as the inconsistent hardware involved above doesn't suggest it's a device issue.
    Tuesday, January 25, 2011 4:40 PM
  • I have the same problem under Windows 7 Enterprise.

    PC: HP dc7900 with display adapter "Intel Q45/Q43 Express Chipset"

    Monitor: HP LA2405wg (24")

    I updated to latest drivers, but windows are still resized after power down of the monitor (manually or via power settings).

    BTW: I used another HP-monitor (L1910 - 19") before without any problems.

    HP is not a small third party company, they should have good drivers; so for me too, as Zbyl wrote => it's a Windows 7 bug.

    Any MSFT-statement?

     

    Thursday, February 03, 2011 8:32 AM
  • Me too, Dell monitor, Intel IGP and started as soon as I switched to a HDMI cable. Real pain, and surprised that no one in Microsoft has picked this up as the inconsistent hardware involved above doesn't suggest it's a device issue.
    Same problem here. It's very irritating. Viewsonic VX2739 via HDMA to Win7/64b Home Premium, Intel HD Chipset on MB. Didn't have the problem when I first got the box. However, somewhere between "just out of the box" and now, during all that patching and app installing, something got hosed. I've scrubbed and reinstalled the video drivers, went registry spelunking but only found a few things to poke at, but nothing so compelling I'm willing to risk a weekend of un-mucking my install for. -DT
    Saturday, February 05, 2011 2:28 AM
  • I know this is old, but I have the same problem.  A workaround I just figured out is to "never turn display off" in Power Options and just use a Blank screensaver.   It might use a tad more power, but the windows don't change sizes.  Windows 7 Ultimate 64 bit, Dell workstation, NVIDIA Quadro FX 4800 display card, LCD display.
    Monday, February 14, 2011 5:39 PM
  • Yes, this thread is OLD, but I have the same problem since spring 2011 or before.  Not turning off the monitor and using 'blank' screen saver avoids issue.  Dipslay power off (manual or power mgt) will cause all open windows to be resized the same size, stacked,etc.

    I have Viewsonic vx2240 lcd monitor(1.5.0.0 dated 6/15/09) , MSI mb with Intel HD drivers (8.15.10.2509 dated 8/31/11).  all drivers are up to date as well as Win7 64 Home Prem.

    • Proposed as answer by GeneK Thursday, December 22, 2011 1:16 AM
    Tuesday, November 29, 2011 4:12 PM
  • Problem turned out to the the Viewsonic vx2240 monitor.  With latest drivers for monitor and Intel HD inbuilt controller, problem still existed.  Switched to an Acer LCD monitor with associated monitor driver and the resizing of open windows stopped.  Viewsonic support was unable to help as viewsonic monitor was out of warrantly - but monitor or Viewsonic monitor driver is BAD/.
    Thursday, December 22, 2011 1:19 AM
  • There's much more information in the giant thread "Disable 'Monitor Off' detection, how?" (tip: be signed out to read it, otherwise firefox hangs). However none of the workarounds there worked for me. What works for me is switching to a different driver but making sure to get rid of the previous driver first.

    The system: Windows 7 x64 on a Dell desktop with its optional DVI card to drive a Dell monitor over a DVI cable (monitor is a bit older and doesn't have DisplayPort). Everything worked well until I decided to spruce up my system and install Dell's latest drivers and BIOS (all many months old).

    The problem: when you turn off the monitor or let the power scheme turn it off, a "unplug" sound is heard and when you wake up the screen, Windows 7 has squashed all windows in the left upper corner.

    The solution: in Screen resolution, link Advanced settings, button Properties, tab Driver, button Update Driver..., button "Browser my computer for driver software", button "Let me pick from a list...". 3 drivers are listed. The first one is the latest and active. Switch to the last one (Standard VGA), reboot, then switch to the second driver, reboot again. These are the 3 drivers on my system:

        Intel 4 Series Internal Chipset
        Intel Q45/Q43 Express Chipset (Microsoft Corporation - WDDM 1.1)
        Standard VGA Graphics Adapter

    Switching directly from the first to the second driver does not cure the problem. Switching from the good situation to the first driver brings the problem back.
    • Proposed as answer by ExWoomera Thursday, July 03, 2014 12:38 PM
    Friday, January 06, 2012 5:38 PM
  • Here is a solution that created a solution for me, with extra directions at the end since only doing what MichealAtOz states didn't solve the problem for me:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa

    "I have found a work-around.
    Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path;
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    My system had three entries;
    DELF003YY7707BR0MUL_30_07D7_6A^9A3774EB79DEE3E3E38496CC7DF4D936
    QHD32000001_31_07D6_D5^63E1ABDD175E7871DCAEB710418A0F75
    SIMULATED_8086_2A42_00000000_00020000_1010100^CDE365D1B3F0942F0CF38BFB8E127AB4

    Under each is a tree called "00" two of the keys are
    PrimSurfSize.cx
    PrimSurfSize.cy

    Under "00" was another branch also called "00" two of the keys are;
    ActiveSize.cx
    ActiveSize.cy

    The first two of the configs (ie DELF00... & QHD3...) the above keys were 1440x900,
    so they were not involved.

    The third (SIMULATED...) were set to 1024x768.

    I changed these to 1600x900 and the problem was solved.

    Further I changed resolution (via control panel) to 1920x1080, the moving/resize issue returned,
    but the lower right corner was set to 1600x900, ie the SIMULATED... settings."

    Use MichealAtOz's advice but within all the folders that are labeled "00" or "01", (etc, I had 00 and 01) look for any settings that contain 1024, 768, or I 4096 in the data values at the end in parenthesis. Change the 1024 to the x resolution of your desktop (the first number in resolutions) and the 768 to the y resolution of your desktop. Change the 4096 number of "Stride" to whatever number there already is in a "00" or similar titled folder that already has (without you changing them) the desired desktop resolution numbers in primsurfsize.cx and ...y. Right click the name and choose modify, then select binary as the base to enter correct resolution values.

    Hopefully this makes sense - it solved the issue for me.

    • Proposed as answer by faulks30 Friday, September 07, 2012 10:51 PM
    Saturday, June 16, 2012 5:41 AM
  • Don't you just wish someone at least semi-knowledgeable at Microsoft listened to this problem and fixed it?  I have the same thing with dual monitors.  The problem did not occur until I connected HDCP capable monitors.  Now when I turn monitors off - everything from second monitor moves to the first.  If I have an RDP session on the second - it'll have to be closed and reconnected.
    Monday, August 06, 2012 11:16 AM
  • Here is a solution that created a solution for me, with extra directions at the end since only doing what MichealAtOz states didn't solve the problem for me:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa

    "I have found a work-around.
    Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path;
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    My system had three entries;
    DELF003YY7707BR0MUL_30_07D7_6A^9A3774EB79DEE3E3E38496CC7DF4D936
    QHD32000001_31_07D6_D5^63E1ABDD175E7871DCAEB710418A0F75
    SIMULATED_8086_2A42_00000000_00020000_1010100^CDE365D1B3F0942F0CF38BFB8E127AB4

    Under each is a tree called "00" two of the keys are
    PrimSurfSize.cx
    PrimSurfSize.cy

    Under "00" was another branch also called "00" two of the keys are;
    ActiveSize.cx
    ActiveSize.cy

    The first two of the configs (ie DELF00... & QHD3...) the above keys were 1440x900,
    so they were not involved.

    The third (SIMULATED...) were set to 1024x768.

    I changed these to 1600x900 and the problem was solved.

    Further I changed resolution (via control panel) to 1920x1080, the moving/resize issue returned,
    but the lower right corner was set to 1600x900, ie the SIMULATED... settings."

    Use MichealAtOz's advice but within all the folders that are labeled "00" or "01", (etc, I had 00 and 01) look for any settings that contain 1024, 768, or I 4096 in the data values at the end in parenthesis. Change the 1024 to the x resolution of your desktop (the first number in resolutions) and the 768 to the y resolution of your desktop. Change the 4096 number of "Stride" to whatever number there already is in a "00" or similar titled folder that already has (without you changing them) the desired desktop resolution numbers in primsurfsize.cx and ...y. Right click the name and choose modify, then select binary as the base to enter correct resolution values.

    Hopefully this makes sense - it solved the issue for me.

    I LOVE YOU!!

    This has been annoying me ages and I finally decided to get to the bottom of it. After trawling through endless pages of MS engineers telling people to update their drivers, and the sage advice of, "have you turned it on and off?", I stumbled across this.

    Great job, fixed my problem with a 5 second registry tweak.

    Friday, September 07, 2012 10:54 PM
  • I am currently running Windows 8 64 Bit and also using HDMI from my Vid card to my Monitor.

    After editing these two entries in my registry with my appropriate resolution, the open applications and windows no longer change location and size when resuming from sleep!!

    Thank you!

    Under each is a tree called "00" two of the keys are
    PrimSurfSize.cx
    PrimSurfSize.cy

    Under "00" was another branch also called "00" two of the keys are;
    ActiveSize.cx
    ActiveSize.cy

    Wednesday, December 12, 2012 8:00 AM
  • The WDDM resolution I posted earlier stopped working for me a few weeks ago (after a bunch of new software was installed including Office 2010 suite, or was it some automatic update?). The machine locked up at least once a day, often recovering with the message that the graphics driver had crashed, but in other cases completely freezing, from remote desktop too.

    The PrimSurfSize/ActiveSize. solution works out to a large degree, but one program (Visual C++ 2005) is still affected when the screen goes to sleep. The window keeps it shape, but an internal panel gets resized. It looks weird. Turning the monitor off and on actually repairs the situation again.

    I tried deleting all the entries under the Configuration key, and the similar set under the Connectivity key. No harm is done but nothing good either: the entries are inserted again as soon as you turn off the screen, the SIMULATED key with that lovely 1024x768 resolution.

    • Proposed as answer by Anil.idk Friday, November 08, 2013 10:20 AM
    • Unproposed as answer by Anil.idk Friday, November 08, 2013 10:20 AM
    Wednesday, April 10, 2013 3:05 PM
  • This solved my problem with Media Center on Windows 8. As soon as the TV which was connected with HDMI was powered off then on again it would show the media in a smaller windows. To fix I had to exit out of media center then come back into the application then it would be full screen again.

    Changing the SIMULATED section of the registry to my TVs resolution (1920x1024) in both locations fixed the issue 100%.

    Thanks for the post and solution.


    mark

    Monday, April 22, 2013 3:08 AM
  • I was very glad to find this thread and the solution works.

    A couple of observations;

    The problem is related to specific hdmi monitors or TV's that do not keep the hdmi ports "alive" when the monitor powers down.

    This can be obeserved by positioning a large window in the center of the display, then simply power down the monitor and powering it back up.  If the monitor does not maintain a signal connection with the computer, when the monitor is powered back up, the window will return resized and located at the top left corner of the monitor screen.

    While the above fix assures that the window sizes will stay the same after a power cycle, it does not address the fact that the window will still be repositioned at the top left corner when the monitor power is recycled.

    It would appear that the values Position.cx and Position.cy should control this, but they do not.

    Position.cy set to 32 (50) lowers the top edge when repositioned, but Position.cx has no effect at all.

    (strike the .cy assumption... changing it's value has inconsistent results ;-/)

    Any registry wiz here have any thoughts on how to set the window position?  I'm running classic shell and this repositioning covers all of the desktop icons that are located down the left edge of the monitor screen.

    One final tip... RegJump.exe has been a huge help in this sleuthing... if you don't know about it, check it out.  I'm using it in conjunction with Gary Chanson's QMenu which means if I have the key in the clipboard buffer, two keystrokes and I'm in the registry at that key.

    Hope that this information is of value.

    Beverly Howard


    Beverly Howard [MS MVP-Mobile Devices]


    • Edited by bevhoward Monday, January 06, 2014 7:27 PM
    Monday, January 06, 2014 7:24 PM

  • Wow - it's now Sept 2014, and I find a solution MORE THAN 2 YEARS OLD for this same problem that just cropped up for me in Windows 7. To be fair, this might be on a new monitor install since I have just recently changed my monitor (and it's now on Displayport rather than DVI) and didn't notice this problem in the past. Must be that when a new monitor is installed the SIMULATED settings are just created from a default.

    I expected more from MSFT, especially considering the number of hotfixes I've had to install in the last 2 years ;)

    Thanks for digging this up!


    • Edited by rjdennison Saturday, September 13, 2014 8:52 PM
    Saturday, September 13, 2014 8:48 PM
  • It should be your other monitor not another.
    Tuesday, December 16, 2014 9:54 PM
  • Fixed my problem. I had 2 of 6 drivers that needed this change described above.

    Windows 8.1 Pro 64-bit
    GeForce GTX 760
    DisplayPort
    Samsung UD28D590

    3840 x 2160

    Friday, January 09, 2015 2:37 PM
  • NOTE: I can't make the reg fix work with switching between displayport and mini-displayport inputs on a 4096X2160@60Hz LG monitor.It's enough to make me lose whatever hair I have left.

    Windows 10 should fix this issue for once and for all!

    Wednesday, January 21, 2015 3:05 PM
  • Hello everyone.I found an easier way to fix this at a least on a single monitor.I went thru this a few years ago and just had to redo it a few minutes ago on my htpc with hdmi 52 inch tv rig...

    Set up a remote assistance request on the affected machine,,create the invite and use it from a laptop or another pc in your home/work whatever...

    When you are connected you must request control from your second pc and grant control on the first pc.

    You are now remotely controlling the affected pc..turn off the monitor to the affected pc...thru the second pc you will see the windows resize...now reset the correct resolution on the affected pc thru your second pc..

    Now turn your monitor off and on a few times....voila no more resizing..FIXED at least for my rig..shut down your remote connection on both ends and you're done....GOOD LUCK

    Wednesday, February 04, 2015 3:49 AM
  • Indeed, the problem is that when the monitor is turned off (when you are not using DVI cable, and you use HDMI or DP), the windows switch the default monitor to Generic Non PNP VGA display. And this makes the resolution like 1024/768 and the windows are just too big to fit so they are re-sized down. 

    Like "mortimusmaximus1st"  said, you need to connect to the PC i did it with team viewer, and then turn off the display, and when it is on Generic Non PNP VGA display, change the resolution to your resolution, do this couple of times if needed by turning your monitor off and on and it will be fixed.

    • Proposed as answer by Ango eleven Tuesday, March 31, 2015 2:39 PM
    Tuesday, March 31, 2015 2:35 PM
  • Like everyone here, this problem had me extremely frustrated.  I was about to give up but then I found this little app!

    http://www.ninjacrab.com/persistent-windows/

    I know that sounds like a bad sales pitch but this little app totally fixed the problem for me!

    tim


    • Edited by ts_mpls Wednesday, April 01, 2015 2:39 AM
    Wednesday, April 01, 2015 2:38 AM
  • Hello everyone.I found an easier way to fix this at a least on a single monitor.I went thru this a few years ago and just had to redo it a few minutes ago on my htpc with hdmi 52 inch tv rig...

    Set up a remote assistance request on the affected machine,,create the invite and use it from a laptop or another pc in your home/work whatever...

    When you are connected you must request control from your second pc and grant control on the first pc.

    You are now remotely controlling the affected pc..turn off the monitor to the affected pc...thru the second pc you will see the windows resize...now reset the correct resolution on the affected pc thru your second pc..

    Now turn your monitor off and on a few times....voila no more resizing..FIXED at least for my rig..shut down your remote connection on both ends and you're done....GOOD LUCK

    I have Windows 7 Professional, NVIDIA GeForceGTX 960 and dual Dell P2715Q monitors (3840 x 2160). After all other methods failed I tried also this one with remote control. But without succes because after switching monitors off on offending PC in there was no possibility in remote session to change monitor resolution. Monitor defaulted to VGA and resolution 640x480 without possibility to change it (grayed out).
    Wednesday, May 20, 2015 1:25 PM
  • Sorry i don't run dual monitors but did you try shutting off 1 monitor at a time?

    Or switch to a single monitor setup, perform the above fix and then switch to a dual monitor setup?

    Thursday, June 11, 2015 2:16 AM
  • Hello everyone.I found an easier way to fix this at a least on a single monitor.I went thru this a few years ago and just had to redo it a few minutes ago on my htpc with hdmi 52 inch tv rig...

    Set up a remote assistance request on the affected machine,,create the invite and use it from a laptop or another pc in your home/work whatever...

    When you are connected you must request control from your second pc and grant control on the first pc.

    You are now remotely controlling the affected pc..turn off the monitor to the affected pc...thru the second pc you will see the windows resize...now reset the correct resolution on the affected pc thru your second pc..

    Now turn your monitor off and on a few times....voila no more resizing..FIXED at least for my rig..shut down your remote connection on both ends and you're done....GOOD LUCK

    I have Windows 7 Professional, NVIDIA GeForceGTX 960 and dual Dell P2715Q monitors (3840 x 2160). After all other methods failed I tried also this one with remote control. But without succes because after switching monitors off on offending PC in there was no possibility in remote session to change monitor resolution. Monitor defaulted to VGA and resolution 640x480 without possibility to change it (grayed out).

    Same here except I'm on windows 10. I try to remote in and 640x480 is selected and greyed out.

    I tried the registry changes proposed on the microsoft answers thread (changing simulated resolution to 1920x1080) but that has no effect. Seems to work for some other people though. This is really annoying...

    Tuesday, August 11, 2015 9:52 PM
  • Registry hack under "SIMULATED_*" key seems to have worked for me.

    Windows 10, NVIDIA GeForce GTX 750 Ti - 1920x1200 using Display Port, Dell U2410 monitor. Problem did not exist on my Samsung 24 inch monitor using DVI port.

    //Allang

    Thursday, August 20, 2015 2:27 AM
  • Windows10 here, now I've understood why it didn't happen at the beginning and then, it suddenly happened.

    It was teamviewer. If you connect to the computer remotely and the display is turned off, then the generic driver drives and changes the resolution to 1024. If you do this, teamviewer options and the driver (right button on the desktop) will only allow me to put 2500 (similar number) as the maximum, whereas I have 3860 (similar number).

    Then, what has worked for me is to change to that resolution, then see in the regedit keys before mentioned which device had changed the 1024 for the 2500, and then change these numbers (the ones referred in the posts) for the 3860 good resolution.

    It has fixed me the resolution and windows location (apparently). But I haven't tested what happens if I connect again with teamviewer and the display off.

    In my eyes, this is a problem of the generic driver, which then it should be something from Windows, isn't it?


    • Edited by ggerard Monday, August 31, 2015 8:46 PM
    • Proposed as answer by mikesmithfl Friday, May 20, 2016 9:39 PM
    Monday, August 31, 2015 8:46 PM
  • Still an issue!

    Seriously Microsoft? I particularly love how absurdly incompetent Arthur_Li was at the beginning of this thread. What a failure. 

    Wednesday, May 25, 2016 5:02 PM
  • Thanks to this thread I successfully stopped my windows misbehaving. I was so happy! Then, after some while, I have no idea what happened but my edge snapping windows started to resize every time I turned on my amp with HDMI connection. Or turned it off, even, after painfully resizing the windows again.

    I want to be able to have a smaller, exact width, full-height window snapped to the left edge and a wider full-height window on the right. Every time I turn on/off the HDMI connection both windows still are snapped to the edges but they're both the same width, meeting at the default edge snapping middle point. I've been messing around with opening/closing/resizing/program settings regarding window sizes but no help. So it seems I'm going to be stuck with super annoying resizing problem unless anyone else has the same thing, because I've been unable to find anything on this edge snapping case on the interwebs.

    My main monitor is 2560x1400 DP, the amp is HDMI and takes 1080p.

    Wednesday, July 06, 2016 12:30 PM
  • Like everyone here, this problem had me extremely frustrated.  I was about to give up but then I found this little app!

    http://www.ninjacrab.com/persistent-windows/

    I know that sounds like a bad sales pitch but this little app totally fixed the problem for me!

    tim


    This was the only solution that worked for me.
    Shame on you, Microsoft!
    Thank you very much Tim!
    Monday, September 19, 2016 12:38 AM
  • This is one of the top threads on this issue of = HDMI / turning off monitor causes windows to resize to upper left corner. So, I am bumping it to add another option.


    From what others have said, Windows switches drivers / screen settings when the monitor disconnects. However, MS FAILED to automatically update the OFF/disconnected settings to the main monitor ON/connected settings. 

    The REG changes discussed make the disconnected settings equal to the connected settings. 

    Another possible solution is to set your monitor to go into "standby" instead of turning all the way off. Some monitors and TVs may have a "standby" option. I know that this uses power when off, but it may fix the issue.

    My LG UHD TV has a setting named "Quick Start" which fixes the issue when set to On. 

    I hope this helps someone.

    Tuesday, January 10, 2017 7:35 PM
  • This issue is something I now have several months and it is driving me crazy.

    When leaving my computer and need it to stay "online", just powering off the monitor, after powering on the monitor, all my opened windows are on the top left corner of the screen.

    I am using Windows 10 (v1703).

    This would not be such a pain if I would not have a screen resolution of 3440x1440 (21:9). My applications often are centered on the screen, not maximized. So getting them back in position is a pain!!!!

    I do not want to manually change the registry, nor do I want to use any third party tool (as mentioned above)!!

    Please.... you guys from Microsoft... isn't there any "FixIt"-Tool you could provide? This thread startet 8 years ago....

    Wednesday, August 02, 2017 9:44 PM