none
virtual network adapter remove sbs2008 RRS feed

  • Question

  • I can't remove Virtual Network adapter's form Device manager created by Hyper-V Manager in SBS2008. I able to enable /disable but can't remove. In Hyper-V -> Virtulal Network manager there is only one Virtual network adapter. I can press uninstall but nothing happend, no error message. Any idea how to solve this problem.
    • Edited by LSIPOS Wednesday, June 17, 2009 5:24 PM
    Wednesday, June 17, 2009 3:04 PM

Answers

All replies

  • hi there,

    i see that issue is more likely with the SBS server , and i would recommend you to post your query under appropriate sbs group . If SBS group feels the issue is not with them , we are more happy to assist you further.

    Regarding the Windows Small Business Server issue, please post to the Windows Small Business Server discussion group. The support professionals there are better equipped to assist you.

    For your convenience, I’ve included the link of Windows Small Business Server discussion group:

    Discussions in Windows Small Business Server General
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windows.server.sbs

    SBS08 Public Newsgroups
    https://connect.microsoft.com/cougar/content/content.aspx?ContentID=8333


    Also i would suggest you to post your query under Hyper-v forum

    http://social.technet.microsoft.com/Forums/en/winserverhyperv/threads

    best of luck.


    sainath !analyze
    Wednesday, June 17, 2009 4:55 PM
    Moderator
  • Hi,

     

    First of all, as Sainath said, you didn't get the correct forum for you question.

     

    Secondly, I am a bit confused about your environment. In order to do the further research, please provide us more information.

     

    1. You mentioned that "I can't remove Virtual Network adapter's form Device manager created by Hyper-V Manager in SBS2008."

    Actually, we can just UNINSTALL a device from Device Manager instead of REMOVE. I'd like to confirm whether what you want to said is uninstall the device from the Device Manager? Did you get any errors when  you try to "remove" the adapter?

     

    2. You mentioned that "In Hyper-V -> Virtulal Network manager there is only one Virtual network adapter. "

    I am confused here. In Hyper-V manager---->Virtual Network Manager, you will never see any Virtual Network Adapters. You can create Virtual Network such as External Virtual Network, Internal Virtual Network and Private Virtual Network. We will be very clear to get your concern if you send us the screen shot.

     

    In addition, I recommend that you have a read of the following articles about Hyper-V networking:

     

    Understanding Networking with Hyper-V

    http://blogs.msdn.com/virtual_pc_guy/archive/2008/01/08/understanding-networking-with-hyper-v.aspx

     

    How does basic networking work in Hyper-V?

    http://blogs.technet.com/jhoward/archive/2008/06/16/how-does-basic-networking-work-in-hyper-v.aspx

     

    Configuring Virtual Networks

    http://technet.microsoft.com/en-us/library/cc816585.aspx

     

     

    Best regards,

    Vincent Hu

     

    Thursday, June 18, 2009 4:06 AM
    Moderator
  • Hi

    1. Correct...Uninstall ,there is no Remove ! No error message! nothing happend :-(

    2.From the beginning... I'll try add virtual network (Hyper-V manager-> Virtual Network Manager->Create virtual network
    interna,external...just testing ....so I add some Virtual Network and the system is creating the v network too long and I stop it throught Task manager and try again with another setting. After that I see to Device manager and there is +3 New Virtual Networks with same names what I write when I creating the virtual networks. I thing Hyper-V create this network adapters, but I dont have these Virtual network in Virtual Network Manager.

    So I would like to delete these adapters.

    LS

    Thursday, June 18, 2009 4:03 PM
  • Hi,

     

    According to the description, it seems that you encountered some problems when you create the Virtual Network, but not involved VMs.

     

    Please uninstall Hyper-V and then install Hyper-V role again. At this time, please create the Virtual Network you want, please wait for the process of creating.

    Note: Don't disturb the process of creating Virtual Network.

     

     

    Best regards,

    Vincent Hu

     

    Friday, June 19, 2009 5:46 AM
    Moderator
  • Hi Vincent,
    When I tried to create a Hyper-V virtual network on my SBS 2008 box , the process went on for more than a day!..I had to forcefully shut it down however a virtual network was created. However if I have my server doing heavy transfers it brings down the entire network.




    C# Fan! ananda84(at)gmail(dot)com
    Thursday, September 10, 2009 6:49 AM
  • Hi,

     

    Please initial a new post in this form and provide details about your environment. Thanks for your understanding.

     

     

    Best Regards,

    Vincent Hu

     

    Friday, September 11, 2009 2:12 AM
    Moderator
  • I had the exact same problem.  I had to install a new ethernet card because my intel card was not supported and panic'ed the kernel.  The Virtual Network (3) was left behind by the old connection and I could not get it to go away. My new card would not bind to it.  I am running 2008 R2 with a 64 bit windows 7 guest and 32 bit windows xp for compatibility of some older hardware I like.

    What I did is:

    0. In Hyper-V I removed all network defintions from the guest OSs and the network manager.
    1. On the Server R2 network configuration screen I disabled the Virtual Network.
    2. In the Hype-V I defined a new network interface called "wired lan" on the new card which I had already configured in Server 2008 r2.
    3. I linked the new "wired lan" interface to each guest OS.

    When I finished, the process created another Virtual network interface on Server 2008 R2 and everthing worked.

    I tried to delete the old interface but could not get it to go away.  I read an article which indicated you can un-check all the services and delete the interface.  I will try that tonight.

     
    Monday, November 16, 2009 9:04 PM
  • I know this thread is old but just for the record you can remove that pesky adapter by installing a different driver for it like the loopback adapter driver then uninstall it!
    Thursday, May 12, 2011 3:44 AM
  • I installed vista on my bin,

    Thanks for that - great help and exactly the answer i was looking for

     

     

    Thursday, June 30, 2011 12:40 PM
  • This is a genius answer. Worked like a charm. :)

    C Vallejo

    Friday, September 7, 2012 5:22 AM
  • Thank you! This helped me.
    Friday, November 16, 2012 8:04 AM
  • Absolutely genius. I had taken over a network where someone had installed Hyper-V on the SBS 2008 box. I was finally able to migrate that server and removed the Hyper-V role. After many reboots, the last thing remaining were the old virtual adapters that caused the most trouble in the first place. They wouldn't uninstall. After switching the drivers out, boom bang all removed.
    • Edited by Subloc Wednesday, February 6, 2013 6:24 PM
    Wednesday, February 6, 2013 6:24 PM