locked
verification of replica failed. an active directory domain controller could not be contacted RRS feed

  • Question

  • I have a windows 2012 server and recently i have a active directory installed as company.local, i removed company.local from the server and tried to install again with the same name "company.local"

    now i'm having issues saying "verification of replica failed. an active directory domain controller could not be contacted" when promoting it to a domain controller.

    i tried to put in a different name but still give me the same error.

    I also removed DNS server and installed it again, thinking it might resolved the problem. Now, DNS server doesnt have any configuration in forward lookup zone.

    Please advise on what to do.

    Thanks


    • Edited by Alg.pasco Monday, November 10, 2014 7:37 AM
    Monday, November 10, 2014 7:35 AM

All replies

  • Hi ,

    If it is an new active directory environment , i suggest you a build a new os on that machine instead of building up the AD from the current os  because why i am saying is some stale entries will cause these issues during installation.

    Is that domain is the new domain in the existing active directory forest or else it is an new forest?

    The server what you are going to build is an additional domain controller ?

    Did you have any other member servers in the domain company.local ?

    if answer is no for all the questions then you can go with the fresh os installation on that server to have a healthy AD for the domain company.local 

    Note : Stale entries can be removed by using the metadatacleanup in the NTDSUTIL tool.

    Please feel free to reply me if you have any queries.


    Thanks & Regards S.Nithyanandham



    Monday, November 10, 2014 7:53 AM
  • See this for metadata cleanup

    https://awinish.wordpress.com/2011/05/08/metadata-cleanup-of-a-domain-controller/


    Regards,

    Biswajit

    MCTS, MCP 2003,MCSA 2003, MCSA:M 2003, CCNA, Enterprise Admin, ITIL F 2011

    Blog:   Script Gallary:   LinkedIn:   

    Note: Disclaimer: This posting is provided & with no warranties or guarantees and confers no rights..

    Monday, November 10, 2014 10:02 AM
  • well, to be honest, it had a previous active directory but the configurations were incorrect so i decided to remove all services and plan to setup my server as if it is a new server.

    I have already removed all services and then when i installed the AD DS, it went fine, but when I tried to go to ADAC, a error occurred saying "Cannot find an available server in the domain that is running the Active Directory Web Service"

    Any idea in how I can resolved this.

    Also, is there a way to restore Windows Server 2012 to its factory settings so I can have a fresh Start?

    And regarding the NTDSUTIL, i tried it but I cannot connect to the server saying, there is no server to be connected to.

    Hope you can help me. 

    Monday, November 10, 2014 11:40 AM
  • Hi,

    Please run DCdiag.exe on the problematic DC and post out related error and warning messages to see if we can solve the issue.

    Dcdiag

    http://technet.microsoft.com/en-us/library/cc731968.aspx

    Best Regards,

    Amy

    Friday, November 14, 2014 11:43 AM