locked
Disk not initialized in Vista or Win7 but fine in XP RRS feed

  • Question

  • I have a hard disk(IDE 320GB) I wanted to install into a Vista box to be able to access files and use as storage but the Vista box has no ide header on the mainboard. I plugged the disk into a disk caddy and connected it via usb to the computer and Vista went about installing drivers for it and happily said the device was ready to use. But the device did not show up in 'Computer' and it showed up as not initialized in Disk Manager. Trying both methods to initialize the disk brought back the error "Device is not ready". I subsequently tried to access the disk on my Win7 box and got the same results. I then tried it on an XP box and it all worked as expected ( drivers loaded, said it was good to go, I was able to see the drive/files in Explorer). I also installed it via the ide cable on the xp box and it reponded as you would expect. I checked the drive for errors and it found none. I deleted boot files from C: and tried to see it again in Win7 without success.(It had contained an XP install and is formatted in NTFS)
      I really need to get these files on the Vista box but I'm looking at 40GB+ in files so just burning them to a dvd isn't really feasible. Is there some reason Vista/Win7 can't see the drive properly?

    Edited to add......

    An update on this.

     I purchased a new SATA drive for the Vista machine and was intending to transfer the music files to it and install it. For kicks I plugged the new drive into my disk caddy(which does both IDE and SATA) and plugged it into my Win7 box. I was also curious if perhaps the hardware of my caddy was having issues. Immediately it asked to be intialized which I did. I formatted it and assigned a drive letter and it showed up in Computer as you would expect.

    With this being successful I plugged the IDE drive back into the caddy and tried that again. It came up without a hitch. I can access all the files (after taking ownership) like I should have been able to do in the first place.

    Very odd but it works now on the Win 7 box. I don't have access to the Vista machine yet and since I'm putting the new SATA drive in anyway it doesn't matter much to me but I found this procedure interesting and thought I'd post the results here for future refference should anyone else have a similar issue.
    Monday, October 26, 2009 1:59 AM

All replies

  • I am having the same problem. I have a disk drive that works externally on a Windows XP Pro machine but when I connect to Windows 7 it says I need to initialize the disk. I can't re-initialize because I will loose my data. I do have a backup but not sure how recent it is. Any ideas?
    Sunday, March 14, 2010 4:18 PM
  • I just figured out what was wrong....

    The problem was my drive was USB 2.0 but I was connecting it to USB 1.0. So I guess Windows 7 requires you to plug into the drive that it was designed for????? I shut down the drive. Turned it back on. Then plugged it into a drive that was 2.0.

    Worked like a charm.
    Sunday, March 14, 2010 4:39 PM
  • This fixed my problem.. Thank you !
    Saturday, May 28, 2011 1:28 AM