locked
Exchange Server 2007 SP1 & Server 2008 R2 RRS feed

  • Question

  • Hello, im currently testing out server 2008 R2 and was trying to install Exchange 2007 SP1 and two of the readiness checks fail (Hub Transport & Client Access) they say, "unable to read from the metabase" And "Unable to access the 'default website' on this computer".what can i do to fix this so it will install?
    Sunday, February 22, 2009 5:59 PM

Answers

All replies

  • Windows Server 2008 R2 is still in beta.
    You cannot install Exchange 2007 on Windows Server 2008 R2 at the moment. Hopefully this will be possible sometime in the future, for now you have to settle for Windows Server 2008.


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Sunday, February 22, 2009 6:14 PM
  • Hi,

    I agree with Lasse, you need to wait for Windows 2008 R2 RTM release and/or Exchange 2007 SP2 with official document/guidance of installation on it.


    Amit Tank | MVP - Exchange | MCITP:EMA MCSA:M | http://ExchangeShare.WordPress.com
    • Marked as answer by Elvis Wei Tuesday, February 24, 2009 7:24 AM
    Monday, February 23, 2009 4:09 AM
  • I have found workarounds for the problems and was able to get Exchange 2007 SP1 working in Server 2008 R2 (7100).

    To get the domain prepped you have to do that from a Server 2008 (non-R2) server.
    You should then be able to install everything except the mailbox role.

    If you get the error "Access Denied" and an error number of "3221684229", if you right-click on the setup.exe file and cloose the run it in compatibility mode (I chose Vista SP1) then the mailbox role successfully installs.

    Let me know how it goes.
    Thanks
    Robin
    Robin Wilson
    • Proposed as answer by robinwilson16 Thursday, August 20, 2009 7:50 PM
    Saturday, May 2, 2009 6:21 PM
  • Hi!

    Not really a workaround, more a complete redesign, the question still stands, any way to get Exchange 2007 SP1 to work on a Server 2008 R2 RC.

    I´ve virtualised my test environment with nothing but R2 so the question stands...

    /JK
    Friday, May 29, 2009 8:36 PM
  • If you follow my instructions to right-click the setup file it does install properly and work well after installation and I have not encountered any further issues and everything seems to work properly.

    You can also install Exchange 2010 beta onto Server 2008 R2 but it still only works on the beta release and not the RC. As far as I understand it this is because PowerShell was redesigned and the Exchange Management Console controls Exchange by firing the commands through that.

    I'm sure there will be updates to the 2007 version nearer the release of R2 or maybe even a new service pack if we're lucky.

    P.S. Sorry about all the typos in my previous post but I think I was in a rush at the time!

    Robin Wilson
    Friday, May 29, 2009 9:44 PM
  • Hi

    I am facing issue with the Exchange 2007 SP1 installtion(mailbox role) on Windows 2008 R2 event after using compatibilty mode as Windows Vista SP1.

    the error is -

    An error occurred. The error code was 3221684346. The message was The data area passed to a system call is too small..


    Please let me know anyone has any solution or workarond for this error..


    ~Sujay

    Wednesday, July 1, 2009 9:06 AM
  • This worked perfectly for me. I was even able to use Vista SP2 compatibility mode.

    Thanks a bung Robin!
    Friday, July 3, 2009 5:33 PM
  • As an update this also works with the RTM version of Server 2008 R2 and I have Exchange 2007 working properly. By slipstreaming the latest service packs into other programs I was able to get most other things working as well such as SQL Server 2008, SharePoint, Office Communications Server 2007 and others.

    Also my domain is running at Server 2008 R2 functional level and no problems with that either (so far...!)

    Thursday, August 20, 2009 7:50 PM
  • It may work but question comes when you look for support when Exchange 2007 SP1/SP2 is installed on Windows 2008 R2 which is not supported ultimately... :(

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    Friday, August 21, 2009 10:09 AM
  • True, good point!

    I am currently just running it on a test domain I have so if it all goes wrong then it doesn't really matter. Actually I normally learn the most in trying to fix things again after I brake them! I did believe that SP2 of Exchange 2007 was going to be supported on R2 when it was released. Is this not the case?
    Robin Wilson
    Friday, August 21, 2009 10:45 AM
  • Test environment is not a problem :)

    BTW, Exchange 2007 SP2 will be blocked to install on Windows 2008 R2, setup will NOT allow you to install it on R2, further info will be available when it will release...

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    Friday, August 21, 2009 11:03 AM
  • Hi,
    My situation was this
    New installation of Server 2008 R2 x64
    new forest and with DC, DNS roles etc

    Added the IIS role with just the default selections

    Ran the Exchange 2010 setup exe (trial download eng only)
    Once I got to the pre-req checks I got the same 2 errors about
    "unable to read IIS metabase"
    "unable to access default website"

    Then I saw this post
    http://www.whichwaydoigo.com/tag/metabase/

    Once I added role features for IIS called
    - IIS6 Metabase Compatibility, and
    - IIS6 Management Console

    Try Exchange 2010 set-up again and voila it passed the checks
    Yes, it seems strange the the advice given for the errors takes you to unhelpful info about Exchange 2007.
    Perhaps it is documented somewhere that you must enable certain IIS roles/features before installing Exchange 2010 - but I haven't looked that hard to read the deployment docs (as I'm just jumping in to test)

    Fingers crossed that I report back once the installer has finished and it all went ok

    Cheers
    • Proposed as answer by RyanProsser Thursday, November 26, 2009 11:41 AM
    Thursday, November 26, 2009 10:37 AM
  • Brilliant. That works. Wondering what the implications are.
    Wednesday, February 3, 2010 9:10 PM
  • Now that it's April 2010, and Win2008 R2 has actually been officially released, how would one go about figuring out if Exchange 2007 is supported on it?

    I'm having the same problems with being "unable to read from the metabase" and pretty frustrated that the links the Exchange setup program points me to tells me about uninstalling Exchange 2000, and configuring IIS on Windows Server 2003.


    tom
    Friday, April 2, 2010 8:14 PM
  • 
    One way is to ask here.  It's not.  Cheers!
    --
    Ed Crowley MVP
    "There are seldom good technological solutions to behavioral problems."
    .
    "tbreit" wrote in message news:6726ff51-e52a-429e-bd85-f68e0d878644...

    Now that it's April 2010, and Win2008 R2 has actually been officially released, how would one go about figuring out if Exchange 2007 is supported on it?

    I'm having the same problems with being "unable to read from the metabase" and pretty frustrated that the links the Exchange setup program points me to tells me about uninstalling Exchange 2000, and configuring IIS on Windows Server 2003.


    tom

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Wednesday, April 7, 2010 2:30 AM
  • HI..

    i am installing exchange server 2007 but during installing. error gave. atleast one gc of windows 2003 server available. so any one can help me how i solve this problem....

    bcz i have 5 servers and all of them are windows 2008 server. we upgrade that all.

    but we get problem now when we deploy exhange 2007..

    but we get these error...

    aliakber.sakhi@hotmail.com

    MCTS,MCSE,MCSA & MCP....

    A+CERTIFIED,,

    Tuesday, May 25, 2010 5:39 AM
  • You must set up a GC server in your domain environment.
    • Proposed as answer by DammZ Wednesday, March 23, 2011 8:00 AM
    Wednesday, March 23, 2011 8:00 AM
  • Hi Sujay,

    I worked around this error by first setting the compatibility mode to Vista SP1, then right click the installation setup file and choose "Run as Administrator". 

    Best Regards

    Jason Ma


    jason

    Friday, December 14, 2012 9:09 AM