Attempting .jar / jnlp launch with sequenced Java RRS feed

  • Question

  • I've sequenced numerous versions of Java without a single issue. I recently came across an internal webpage to that for some reason just does not play nice. No matter if I try to get to the webpage with the local version or any of the sequenced versions I have, nothing works. When I try it, it returns "C:\Program Files (x86)\Microsoft Application Virtualization Client\sfttray.exe" http://x.x.x.x/switchExplorer_installed.html instead of sfttray.exe /launch applicationname.

    If we remove the .jar and .jnlp file type associations, it launches no problem. The website will then continue onto a webtools installation check and installation if needed.

    I'm not sure if this is a limitation with Java and the Java check that is running is hosing things up or if it's tied to the webtools installation. Sequencer version is all 4.6 SP1. PVS Citrix XA 6.0 running 2k8R2SP1.

    Saturday, February 11, 2012 5:01 AM

All replies

  • Hello,

    For you to open a web-page using a parameter for a virtualized internet explorer - the address would be needed to be appended after the definition of the application.

    Essentially, this should be it

    sfttray.exe /launch "app version" http://address

    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, February 11, 2012 8:52 AM
  • Yup. That's what we have. But when I open up any browser (sequenced, local versions) and just try to go to that http://x.x.x.x, it forwards to the switchexplorer_installed.html and does not launch the app. Instead it tries to just launch sfttray.exe http://address.

    This is the only web page that does this.

    Saturday, February 11, 2012 2:03 PM
  • Hello,

    Try reading the documentation for Internet Explorer (as you say - it happens for both the virtualized or non-virtualized) and determine if there is something happening. Otherwise you create a URL-shortcut - see this as an example;


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, February 12, 2012 8:17 AM
  • Thanks Znack. I'll check into the IE documentation but as a quick work around the URL shortcut does infact work. Thanks for the help.
    Monday, February 13, 2012 4:45 PM