none
ILR - Weird Issue RRS feed

  • Question

  • Hi,

    I've had issues with ILR on my DPM box for a while now. Its comes up with the eroro stating about dynamic volumes, no volumes, DPM role or auto mounting not being enabled. The ID is 958 and the error code is 0x80990F4E.

    What I have found is that it wont do a ILR mount on a server with more than one disc. I have a couple of servers where I've stuck the data on a different VHDX and these aren't viewable in the recovery console. Single VHDX servers go in fine.

    When I mount a single VHDX server I get in the event log

    Volume \\?\Volume{0c427bb5-7d79-4ecf-b48b-8756042aeb90} (\Device\HarddiskVolume121) is healthy.  No action is needed.

    I don't get any log entries on servers with the issue.

    Looking at the DPM  logs when it fails I see

    15:28:46.345 22 nativevhdprovider.cpp(174) [0000000000A26A60] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80070013] : c:\Program Files\Microsoft System Center 2012 R2\DPM\DPM\DpmVhds\bf56ca19-a372-4f2b-94fc-c0cfd3e861b5.diff.vhdx: lVal : pfnCreateVirtualDisk(&storageType, ssDiffVhdPath.PeekStr(), VIRTUAL_DISK_ACCESS_CREATE, NULL, CREATE_VIRTUAL_DISK_FLAG_NONE, 0, &createParam, NULL, &hDisk)
    188C 2088 05/11 15:28:46.345 31 hypervvhdhelper.cpp(155) [00000000009C26A0] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80070013] : m_pVHDProvider->CreateDifferencingVhd() path:[c:\Program Files\Microsoft System Center 2012 R2\DPM\DPM\DpmVhds\bf56ca19-a372-4f2b-94fc-c0cfd3e861b5.diff.vhdx], parent path:[c:\Program Files\Microsoft System Center 2012 R2\DPM\DPM\DpmVhds\bf56ca19-a372-4f2b-94fc-c0cfd3e861b5.vhdx]
    188C 2088 05/11 15:28:46.345 31 hypervvhdmanager.cpp(340) [0000000000A32A90] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990e52] : CreateDifferencingVhd: ssParentPath [\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy389\76b21287-0f74-4580-bb7a-eb1f55c32a6c\Full\D-Vol\Email\Exchange2013\Skinner2_BEDFAB9E-DD04-417E-BE5C-8E042B21F78E.avhdx]
    188C 2088 05/11 15:28:46.345 31 vhdmanager.cpp(270) [0000000000A32A90] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990e52] : Encountered Failure: : lVal : MountVhdInternal(ssVhdIdentifierInCache, ssParentPath, psErrorDetail)
    188C 2088 05/11 15:28:46.345 61 vhdutils.cpp(78)  99303538-624D-4F25-AB30-45F6D758E77D NORMAL arrVhdChain[0] is [\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy389\76b21287-0f74-4580-bb7a-eb1f55c32a6c\Full\D-Vol\Email\Exchange2013\Skinner2_BEDFAB9E-DD04-417E-BE5C-8E042B21F78E.avhdx]
    188C 2088 05/11 15:28:46.345 61 vhdutils.cpp(78)  99303538-624D-4F25-AB30-45F6D758E77D NORMAL arrVhdChain[1] is [\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy389\76b21287-0f74-4580-bb7a-eb1f55c32a6c\Full\D-Vol\Email\Exchange2013\Skinner2.vhdx]
    188C 2088 05/11 15:28:46.345 61 inquirysubtask.cpp(1222) [0000000000A2C160] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990f4e] Ignoring processing error, processing continues for other nodes
    188C 2088 05/11 15:28:46.345 61 inquirysubtask.cpp(1705) [0000000000A2C160] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990f4e] CInquirySubTask::CreateAndLogError::Adding inquiry error for component
    188C 2088 05/11 15:28:46.345 61 inquirysubtask.cpp(1031) [0000000000A2C160] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL <--CInquirySubTask::ExecuteInquiry
    188C 13FC 05/11 15:28:46.345 61 inquirysubtask.cpp(458) [0000000000A2C160] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL Sending final response with 1 records
    188C 13FC 05/11 15:28:46.345 61 vhdutils.cpp(51)  99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990f4e] : \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy389\76b21287-0f74-4580-bb7a-eb1f55c32a6c\Full\D-Vol\Email\Exchange2013\Skinner2_BEDFAB9E-DD04-417E-BE5C-8E042B21F78E.avhdx: lVal : E_COORD_HYPERV_VHD_MOUNT_FAILED
    188C 13FC 05/11 15:28:46.345 61 nevhd.cpp(124)  99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990f4e] : Encountered Failure: : lVal : VHDUtils::MountAndEnumerateVHD(ssId, arrVhdChain, arrVolLabel, arrVolGuid, arrVolId)
    188C 13FC 05/11 15:28:46.345 61 nevhd.cpp(61) [0000000000A2BBA0] 99303538-624D-4F25-AB30-45F6D758E77D WARNING Failed: Hr: = [0x80990f4e] : Encountered Failure: : lVal : EnumerateVHDChildren(m_path, traversingReplica, callback)
    188C 13FC 05/11 15:28:46.345 61 inquirysubtask.cpp(990) [0000000000A2C160] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL CInquirySubTask::Inquiry finished with status [0000000000]
    188C 13FC 05/11 15:28:46.345 03 workitem.cpp(296) [0000000000A2A880] 99303538-624D-4F25-AB30-45F6D758E77D ACTIVITY WorkItem stopping
    188C 13FC 05/11 15:28:46.345 31 vsssnapshotrequestor.cpp(122) [0000000000A2C4A8] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL CVssSnapshotRequestor::~CVssSnapshotRequestor [0000000000A2C4A8]
    188C 13FC 05/11 15:28:46.345 31 vsssnapshotrequestor.cpp(2182) [0000000000A2C4A8] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL CVssSnapshotRequestor::CleanUp [0000000000A2C4A8]
    188C 13FC 05/11 15:28:46.345 31 vsssnapshotrequestor.cpp(1768) [0000000000A2C4A8] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL CVssSnapshotRequestor::ReleaseVolumesForSnapshot [0000000000A2C4A8]
    188C 13FC 05/11 15:28:46.345 31 vssbaserequestor.cpp(69) [0000000000A2C4A8] 99303538-624D-4F25-AB30-45F6D758E77D NORMAL CVssBaseRequestor: destructor [0000000000A2C4A8]
    188C 110C 05/11 15:28:53.896 22 vdshelper.cpp(923) [0000000000A2D530]  WARNING Failed: Hr: = [0x80990fb0] Disk [\\?\PHYSICALDRIVE7] is not found as unknown
    188C 110C 05/11 15:28:53.896 22 vdshelper.cpp(1892) [0000000000A2D530]  NORMAL Disk Name, fIsDiskFound = Port0Path0Target0Lun0, 0x0
    188C 110C 05/11 15:28:53.896 22 vdshelper.cpp(1892) [0000000000A2D530]  NORMAL

    It was working fine up until a couple of months ago.

    Anyone got any ideas? I really hope it wasn't the new Anti-Virus I installed

    Wednesday, May 11, 2016 3:33 PM

All replies

  • Bumpety Bump Bump

    Right so I installed a new VM last week and did some backups which all worked with ILR. I went to check today and I am getting that stupid error again.

    The only think I have changed is I have installed DPM inside the VM so I can do a SQL backup also... could have mess it up? Its never done it before.

    Thursday, May 19, 2016 1:52 PM
  • Just been on the client and it just hung when I ran

    vssadmin list writers

    Thursday, May 19, 2016 2:21 PM