none
ProClarity 6.3 Install problems...

    Question

  • I am installing ProClarity 6.3 on a web server with the database on the SQL box.  During the install (done with a sysadmin user) the database is created however, the install fails towards the end.  It does not create a PAS user.  If I create the PAS user and reinstall using the database...it will tell me the user password is invalid.

     

    This is the error in event viewer.  (Which does not completely make sense as it does connect to create the Database)

     

    Product: ProClarity Analytics Server 6.3 -- Error 27502.Could not connect to Microsoft SQL Server 'sfintsqlsdsm2'.  [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (17)

     

     

    And the error from the install:

     


    Error message: "1603 Fatal Error during installation. Consult Windows Installer Help (Msi.chm) or MSDN for more information

     

     

     

    Also... TCP Ports are changed from the standard 1433.   not sure if that would matter.

     

    Thanks,

    Kevin

    Wednesday, April 09, 2008 1:41 PM

Answers

  • Hello Kevin,

     

    The default port number for AS 2005 is 2383.  Have you changed that?  If so, have you tried specifying ServernameStick out tongueortNum (ServernameColonPortNum - the "ColonP" is translating to an emoticon) during the PAS installation?  You might give that a try to see if that helps. If you're installing to an instance I believe the context is Servername\InstanceStick out tongueortNum.

     

    One other point of consideration; is this a 64 bit machine?  If so there are a few precautionary steps you'll need to take in order to complete the installation. 

     

    (1) Install PAS as the machine's Local Administrator account (not a domain account with Admin rights, but the actual Administrator account for that machine).
    (2) Stop the IIS Admin Service (Administrative Tools / Services) immediately after the installation wizard completes
    (3) Run the following file: Inetpub\wwwroot\PAS\x64Extra\PInitx64.bat
    (4) Reboot and log back in as the machine's Local Administrator to allow necessary scripts to complete.

    This should allow all files and .dlls to register successfully.

     

    If neither of those options are relevant to your situation, you might try using the sa account during installation to see if that allows successful creation of the PAS User and Database.  Maybe you're sysadmin doesn't have the correct privileges to create content for the PAS repository.

     

    Thanks,

    Amanda

     

    Wednesday, April 09, 2008 2:36 PM

All replies

  • Hello Kevin,

     

    The default port number for AS 2005 is 2383.  Have you changed that?  If so, have you tried specifying ServernameStick out tongueortNum (ServernameColonPortNum - the "ColonP" is translating to an emoticon) during the PAS installation?  You might give that a try to see if that helps. If you're installing to an instance I believe the context is Servername\InstanceStick out tongueortNum.

     

    One other point of consideration; is this a 64 bit machine?  If so there are a few precautionary steps you'll need to take in order to complete the installation. 

     

    (1) Install PAS as the machine's Local Administrator account (not a domain account with Admin rights, but the actual Administrator account for that machine).
    (2) Stop the IIS Admin Service (Administrative Tools / Services) immediately after the installation wizard completes
    (3) Run the following file: Inetpub\wwwroot\PAS\x64Extra\PInitx64.bat
    (4) Reboot and log back in as the machine's Local Administrator to allow necessary scripts to complete.

    This should allow all files and .dlls to register successfully.

     

    If neither of those options are relevant to your situation, you might try using the sa account during installation to see if that allows successful creation of the PAS User and Database.  Maybe you're sysadmin doesn't have the correct privileges to create content for the PAS repository.

     

    Thanks,

    Amanda

     

    Wednesday, April 09, 2008 2:36 PM
  • Check to make sure that your password meets SQL password requirements. 

    Wednesday, April 09, 2008 3:57 PM
    Moderator
  • Adding the port number to the server name worked.   Thanks very much!!   it was  servername,port#   instead of colon though.  If I read the small details I would have notice in the begining.

    Wednesday, April 09, 2008 6:16 PM