locked
Disable Error Prompting RRS feed

  • Question

  • Is it possible to stop Windows prompting about errors? Have them just log to the even log and not popup on screen?

    I'm setting up a customized Windows Media Center environment and when launching applications from within WMC it gives the following error:

    I've tested and this appears to cause no issues in WMC following on at all and I can't find any affect it has on continued use. I'm very doubtful that I'll find a solution or a way to fix whatever is causing the error. As it's causing no harm I'd rather just hide it - at least for now.

    Does Windows have the ability to disable the showing of errors such as this?

    Thursday, January 10, 2013 3:38 AM

Answers

All replies

  • To disable windows error reporting try going to Control Panel -- Action Center -- Change Action Center Settings (Left side) -- near the bottom click on Problem Reporting Settings.  Now on this screen select the option "Never Check for solutions" and that should disable error reporting.  

    Another method, in case above doesn't work, is a registry edit as such :

    HKLM\Software\Microsoft\Windows\Windows Error Reporting "ForceQueue"=dword:00000001

    HKLM\Software\Microsoft\Windows\Windows Error Reporting

    "DontShowUI"=dword:00000001

    HKLM\Software\Microsoft\Windows\Windows Error Reporting\Consent "DefaultConsent"=dword:00000001



    Be kind and Mark as Answer if I helped.


    • Marked as answer by Allister Wade Thursday, January 10, 2013 4:16 AM
    • Unmarked as answer by Allister Wade Thursday, January 10, 2013 4:16 AM
    • Edited by Chris DeCarlo Thursday, January 10, 2013 4:19 AM
    Thursday, January 10, 2013 4:15 AM
  • Woops hit wrong button! Sorry!

    Already did that Chris - the popup in the screenshot above is the behavior when that is set. What I want is errors to not display at all.

    Thursday, January 10, 2013 4:17 AM
  • Hmm, so even the registry entries didn't help?  Ok, try this....

    Start--Run-- GPedit.msc.  Navigate to Computer Configuration -- Administrative Templates -- System -- Internet Communication Management -- Internet Communication Settings.  ENABLE the setting "Turn off Windows Customer Experience Improvement Program".


    Be kind and Mark as Answer if I helped.

    Thursday, January 10, 2013 4:24 AM
  • I'm trying to disable errors displaying at all, not just error reporting. With reporting disabled you still get the prompt as in the screenshot above.
    Thursday, January 10, 2013 4:32 AM
  • Have you tried any of these suggestions i just gave or are you reading over them and saying NOPE?

    Be kind and Mark as Answer if I helped.

    Friday, January 11, 2013 1:55 AM
  • Hi,


    You can the test whether the registry settings could help you reach this.


    Note: Please refer to this knowledge base (KB) article to back up the registry key.

    How to disable the pop up that Windows shows when an app crashes

    http://blogs.msdn.com/b/alejacma/archive/2011/02/18/how-to-disable-the-pop-up-that-windows-shows-when-an-app-crashes.aspx


    Hope this helps.


    Vincent Wang
    TechNet Community Support

    • Marked as answer by Allister Wade Monday, January 14, 2013 3:29 AM
    Friday, January 11, 2013 8:13 AM
  • Thanks for your help Vincent! You need a cape for being a Super Hero!
    Monday, January 14, 2013 3:29 AM